diff mbox series

package/go: security bump to version 1.17.9

Message ID 20220413141711.2529851-1-peter@korsgaard.com
State Accepted
Headers show
Series package/go: security bump to version 1.17.9 | expand

Commit Message

Peter Korsgaard April 13, 2022, 2:17 p.m. UTC
go1.17.9 (released 2022-04-12) includes security fixes to the
crypto/elliptic and encoding/pem packages, as well as bug fixes to the
linker and runtime.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
---
 package/go/go.hash | 2 +-
 package/go/go.mk   | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

Comments

Christian Stewart April 14, 2022, 7:42 p.m. UTC | #1
Hi,

I also sent a Go 1.18.1 patch, which now works w/ everything in the
tree (as far as I'm aware).

On Wed, Apr 13, 2022 at 7:17 AM Peter Korsgaard <peter@korsgaard.com> wrote:
>
> go1.17.9 (released 2022-04-12) includes security fixes to the
> crypto/elliptic and encoding/pem packages, as well as bug fixes to the
> linker and runtime.
>
> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
> ---
>  package/go/go.hash | 2 +-
>  package/go/go.mk   | 2 +-
>  2 files changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/package/go/go.hash b/package/go/go.hash
> index 85e6adfb8c..507887eaaa 100644
> --- a/package/go/go.hash
> +++ b/package/go/go.hash
> @@ -1,3 +1,3 @@
>  # From https://golang.org/dl/
> -sha256  2effcd898140da79a061f3784ca4f8d8b13d811fb2abe9dad2404442dabbdf7a  go1.17.8.src.tar.gz
> +sha256  763ad4bafb80a9204458c5fa2b8e7327fa971aee454252c0e362c11236156813  go1.17.9.src.tar.gz

Reviewed-by: Christian Stewart <christian@paral.in>

Thanks,
Christian
Peter Korsgaard April 14, 2022, 8:11 p.m. UTC | #2
>>>>> "Christian" == Christian Stewart <christian@paral.in> writes:

 > Hi,
 > I also sent a Go 1.18.1 patch, which now works w/ everything in the
 > tree (as far as I'm aware).

Ok, the 1.17.9 bump is handy for backporting to 2022.02.x first though.

>> crypto/elliptic and encoding/pem packages, as well as bug fixes to the
 >> linker and runtime.
 >> 
 >> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
 >> ---
 >> package/go/go.hash | 2 +-
 >> package/go/go.mk   | 2 +-
 >> 2 files changed, 2 insertions(+), 2 deletions(-)
 >> 
 >> diff --git a/package/go/go.hash b/package/go/go.hash
 >> index 85e6adfb8c..507887eaaa 100644
 >> --- a/package/go/go.hash
 >> +++ b/package/go/go.hash
 >> @@ -1,3 +1,3 @@
 >> # From https://golang.org/dl/
 >> -sha256  2effcd898140da79a061f3784ca4f8d8b13d811fb2abe9dad2404442dabbdf7a  go1.17.8.src.tar.gz
 >> +sha256  763ad4bafb80a9204458c5fa2b8e7327fa971aee454252c0e362c11236156813  go1.17.9.src.tar.gz

 > Reviewed-by: Christian Stewart <christian@paral.in>

Committed, thanks.
Peter Korsgaard May 21, 2022, 9:58 p.m. UTC | #3
>>>>> "Peter" == Peter Korsgaard <peter@korsgaard.com> writes:

 > go1.17.9 (released 2022-04-12) includes security fixes to the
 > crypto/elliptic and encoding/pem packages, as well as bug fixes to the
 > linker and runtime.

 > Signed-off-by: Peter Korsgaard <peter@korsgaard.com>

Committed to 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/package/go/go.hash b/package/go/go.hash
index 85e6adfb8c..507887eaaa 100644
--- a/package/go/go.hash
+++ b/package/go/go.hash
@@ -1,3 +1,3 @@ 
 # From https://golang.org/dl/
-sha256  2effcd898140da79a061f3784ca4f8d8b13d811fb2abe9dad2404442dabbdf7a  go1.17.8.src.tar.gz
+sha256  763ad4bafb80a9204458c5fa2b8e7327fa971aee454252c0e362c11236156813  go1.17.9.src.tar.gz
 sha256  2d36597f7117c38b006835ae7f537487207d8ec407aa9d9980794b2030cbc067  LICENSE
diff --git a/package/go/go.mk b/package/go/go.mk
index 3df16c9a68..41c9a8648f 100644
--- a/package/go/go.mk
+++ b/package/go/go.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-GO_VERSION = 1.17.8
+GO_VERSION = 1.17.9
 GO_SITE = https://storage.googleapis.com/golang
 GO_SOURCE = go$(GO_VERSION).src.tar.gz