diff mbox series

[v12,11/11] package/compiler-rt: runtime test use toolchain-wrapper

Message ID 20220322232224.2842266-11-james.hilliard1@gmail.com
State Accepted
Headers show
Series [v12,01/11] package/llvm: bump to version 11.1.0 | expand

Commit Message

James Hilliard March 22, 2022, 11:22 p.m. UTC
From: Matt Weber <matthew.weber@rockwellcollins.com>

The toolchain wrapper for clang allows the build of the
libfuzzer package to not point at "-B $(HOST_DIR)/opt/ext-toolchain"
which prevents a build failure to link due to missing crtbeging.o
and libgcc.

Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com>
---
 .../clang-compiler-rt/package/libfuzzer/libfuzzer.mk            | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Arnout Vandecappelle June 20, 2022, 7:34 p.m. UTC | #1
On 23/03/2022 00:22, James Hilliard wrote:
> From: Matt Weber <matthew.weber@rockwellcollins.com>
> 
> The toolchain wrapper for clang allows the build of the
> libfuzzer package to not point at "-B $(HOST_DIR)/opt/ext-toolchain"
> which prevents a build failure to link due to missing crtbeging.o
> and libgcc.

  I've reordered the patches and squashed this with the one that adds the test.

  Regards,
  Arnout

> 
> Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com>
> ---
>   .../clang-compiler-rt/package/libfuzzer/libfuzzer.mk            | 2 +-
>   1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/support/testing/tests/package/br2-external/clang-compiler-rt/package/libfuzzer/libfuzzer.mk b/support/testing/tests/package/br2-external/clang-compiler-rt/package/libfuzzer/libfuzzer.mk
> index 6c6371bea7..0515b9da35 100644
> --- a/support/testing/tests/package/br2-external/clang-compiler-rt/package/libfuzzer/libfuzzer.mk
> +++ b/support/testing/tests/package/br2-external/clang-compiler-rt/package/libfuzzer/libfuzzer.mk
> @@ -12,7 +12,7 @@ LIBFUZZER_DEPENDENCIES = compiler-rt
>   
>   define LIBFUZZER_BUILD_CMDS
>   	$(HOST_DIR)/bin/clang++ --sysroot=$(STAGING_DIR) \
> -		-B $(HOST_DIR)/opt/ext-toolchain -fsanitize=address,fuzzer \
> +		-fsanitize=address,fuzzer \
>   		$(@D)/tutorial/libFuzzer/fuzz_me.cc \
>   		-o $(@D)/fuzz_me
>   endef
diff mbox series

Patch

diff --git a/support/testing/tests/package/br2-external/clang-compiler-rt/package/libfuzzer/libfuzzer.mk b/support/testing/tests/package/br2-external/clang-compiler-rt/package/libfuzzer/libfuzzer.mk
index 6c6371bea7..0515b9da35 100644
--- a/support/testing/tests/package/br2-external/clang-compiler-rt/package/libfuzzer/libfuzzer.mk
+++ b/support/testing/tests/package/br2-external/clang-compiler-rt/package/libfuzzer/libfuzzer.mk
@@ -12,7 +12,7 @@  LIBFUZZER_DEPENDENCIES = compiler-rt
 
 define LIBFUZZER_BUILD_CMDS
 	$(HOST_DIR)/bin/clang++ --sysroot=$(STAGING_DIR) \
-		-B $(HOST_DIR)/opt/ext-toolchain -fsanitize=address,fuzzer \
+		-fsanitize=address,fuzzer \
 		$(@D)/tutorial/libFuzzer/fuzz_me.cc \
 		-o $(@D)/fuzz_me
 endef