diff mbox series

Makefile: unexport 'DEVICE_TREE' environment variable

Message ID 20220223124109.2370215-1-peter@korsgaard.com
State Accepted
Headers show
Series Makefile: unexport 'DEVICE_TREE' environment variable | expand

Commit Message

Peter Korsgaard Feb. 23, 2022, 12:41 p.m. UTC
U-Boot looks for the environment variable DEVICE_TREE and uses its value if
set instead of the CONFIG_DEFAULT_DEVICE_TREE configuration option since
v2021.01, more specifically commit c0f1ebe9c1b9745e (binman: Allow selecting
default FIT configuration) - So unexport it like we do for other
"troublesome" environment variables to ensure consistent behaviour.

Reported-by: Neal Frager <nealf@xilinx.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
---
 Makefile | 1 +
 1 file changed, 1 insertion(+)

Comments

Yann E. MORIN Feb. 23, 2022, 2:05 p.m. UTC | #1
Peter, All,

On 2022-02-23 13:41 +0100, Peter Korsgaard spake thusly:
> U-Boot looks for the environment variable DEVICE_TREE and uses its value if
> set instead of the CONFIG_DEFAULT_DEVICE_TREE configuration option since
> v2021.01, more specifically commit c0f1ebe9c1b9745e (binman: Allow selecting
> default FIT configuration) - So unexport it like we do for other
> "troublesome" environment variables to ensure consistent behaviour.
> 
> Reported-by: Neal Frager <nealf@xilinx.com>
> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  Makefile | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/Makefile b/Makefile
> index d92438166f..0ed93e600d 100644
> --- a/Makefile
> +++ b/Makefile
> @@ -426,6 +426,7 @@ unexport O
>  unexport GCC_COLORS
>  unexport PLATFORM
>  unexport OS
> +unexport DEVICE_TREE
>  
>  GNU_HOST_NAME := $(shell support/gnuconfig/config.guess)
>  
> -- 
> 2.30.2
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/Makefile b/Makefile
index d92438166f..0ed93e600d 100644
--- a/Makefile
+++ b/Makefile
@@ -426,6 +426,7 @@  unexport O
 unexport GCC_COLORS
 unexport PLATFORM
 unexport OS
+unexport DEVICE_TREE
 
 GNU_HOST_NAME := $(shell support/gnuconfig/config.guess)