diff mbox series

[2/3] portable: new init system

Message ID 20220221043034.2736010-3-francois.perrad@gadz.org
State Rejected
Headers show
Series portable services: another use case of BR | expand

Commit Message

Francois Perrad Feb. 21, 2022, 4:30 a.m. UTC
see https://systemd.io/PORTABLE_SERVICES/

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
---
 package/pkg-generic.mk | 2 ++
 system/Config.in       | 9 +++++++++
 2 files changed, 11 insertions(+)
diff mbox series

Patch

diff --git a/package/pkg-generic.mk b/package/pkg-generic.mk
index b3a7e1d60..e62e7aada 100644
--- a/package/pkg-generic.mk
+++ b/package/pkg-generic.mk
@@ -383,6 +383,8 @@  $(BUILD_DIR)/%/.stamp_target_installed:
 	+$($(PKG)_INSTALL_TARGET_CMDS)
 	$(if $(BR2_INIT_SYSTEMD),\
 		$($(PKG)_INSTALL_INIT_SYSTEMD))
+	$(if $(BR2_INIT_PORTABLE),\
+		$($(PKG)_INSTALL_INIT_SYSTEMD))
 	$(if $(BR2_INIT_SYSV)$(BR2_INIT_BUSYBOX),\
 		$($(PKG)_INSTALL_INIT_SYSV))
 	$(if $(BR2_INIT_OPENRC), \
diff --git a/system/Config.in b/system/Config.in
index a4ffbfa18..e71e57915 100644
--- a/system/Config.in
+++ b/system/Config.in
@@ -141,6 +141,15 @@  comment "systemd needs a glibc toolchain w/ SSP, headers >= 3.10, host and targe
 		!BR2_TOOLCHAIN_GCC_AT_LEAST_5 || \
 		!BR2_HOST_GCC_AT_LEAST_5
 
+config BR2_INIT_PORTABLE
+	bool "portable"
+	select BR2_ROOTFS_MERGED_USR
+	select BR2_PACKAGE_SKELETON_INIT_PORTABLE if BR2_ROOTFS_SKELETON_DEFAULT
+	help
+	  portable services with systemd
+	  
+	  https://systemd.io/PORTABLE_SERVICES/
+
 config BR2_INIT_NONE
 	bool "None"
 	select BR2_PACKAGE_SKELETON_INIT_NONE if BR2_ROOTFS_SKELETON_DEFAULT