diff mbox series

package/python-joblib: new host-only package

Message ID 20220219181554.32204-1-guillaume.bressaix@gmail.com
State Changes Requested
Headers show
Series package/python-joblib: new host-only package | expand

Commit Message

Guillaume Bres Feb. 19, 2022, 6:15 p.m. UTC
Joblib is a set of tools to provide lightweight pipelining in Python

Signed-off-by: Guillaume W. Bres <guillaume.bressaix@gmail.com>

---
host-python-joblib is a requirement of python-scikitlearn,
which first requires the current python-scipy work to be merged.

---
 DEVELOPERS                               |  1 +
 package/python-joblib/python-joblib.hash |  3 +++
 package/python-joblib/python-joblib.mk   | 13 +++++++++++++
 3 files changed, 17 insertions(+)
 create mode 100644 package/python-joblib/python-joblib.hash
 create mode 100644 package/python-joblib/python-joblib.mk

Comments

Thomas Petazzoni July 27, 2022, 6:25 a.m. UTC | #1
Hello Guillaume,

On Sat, 19 Feb 2022 19:15:54 +0100
"Guillaume W. Bres" <guillaume.bressaix@gmail.com> wrote:

> Joblib is a set of tools to provide lightweight pipelining in Python
> 
> Signed-off-by: Guillaume W. Bres <guillaume.bressaix@gmail.com>

Thanks a lot for this patch. It looks good. However, could you send it
in a patch series that includes python-scikitlearn? Indeed, we don't
really like to have orphan host packages in Buildroot, i.e host
packages that are not used by any other package visible in menuconfig.

Thanks!

Thomas
Guillaume Bres July 27, 2022, 7:40 p.m. UTC | #2
Hello Thomas,

I did not propose sklearn along these patches because it
requires python-scipy to be merged first.
I just resubmitted an updated version of the scipy serie
https://patchwork.ozlabs.org/project/buildroot/patch/20220727192948.18653-4-guillaume.bressaix@gmail.com/

btw, thanks for merging the new NTP daemon "ntpsec" ! :)

Guillaume W. Bres
Software engineer
<guillaume.bressaix@gmail.com>


Le mer. 27 juil. 2022 à 08:25, Thomas Petazzoni <
thomas.petazzoni@bootlin.com> a écrit :

> Hello Guillaume,
>
> On Sat, 19 Feb 2022 19:15:54 +0100
> "Guillaume W. Bres" <guillaume.bressaix@gmail.com> wrote:
>
> > Joblib is a set of tools to provide lightweight pipelining in Python
> >
> > Signed-off-by: Guillaume W. Bres <guillaume.bressaix@gmail.com>
>
> Thanks a lot for this patch. It looks good. However, could you send it
> in a patch series that includes python-scikitlearn? Indeed, we don't
> really like to have orphan host packages in Buildroot, i.e host
> packages that are not used by any other package visible in menuconfig.
>
> Thanks!
>
> Thomas
> --
> Thomas Petazzoni, co-owner and CEO, Bootlin
> Embedded Linux and Kernel engineering and training
> https://bootlin.com
>
Thomas Petazzoni July 27, 2022, 8:24 p.m. UTC | #3
Hello Guillaume,

On Wed, 27 Jul 2022 21:40:49 +0200
Guillaume Bres <guillaume.bressaix@gmail.com> wrote:

> I did not propose sklearn along these patches because it
> requires python-scipy to be merged first.

You can propose a complete series that includes python-scipy, the
dependencies of sklearn, and sklearn itself.

> I just resubmitted an updated version of the scipy serie
> https://patchwork.ozlabs.org/project/buildroot/patch/20220727192948.18653-4-guillaume.bressaix@gmail.com/

Seen that, thanks a lot!

> btw, thanks for merging the new NTP daemon "ntpsec" ! :)

You're welcome, thanks for your patience!

Best regards,

Thomas
diff mbox series

Patch

diff --git a/DEVELOPERS b/DEVELOPERS
index ac702d8d0f..ca2e6e81e7 100644
--- a/DEVELOPERS
+++ b/DEVELOPERS
@@ -1148,6 +1148,7 @@  F:	package/libnids/
 F:	package/libxcrypt/
 F:	package/liquid-dsp/
 F:	package/pixiewps/
+F:	package/python-joblib/
 F:	package/python-pybind/
 F:	package/reaver/
 F:	support/testing/tests/package/br2-external/python-pybind
diff --git a/package/python-joblib/python-joblib.hash b/package/python-joblib/python-joblib.hash
new file mode 100644
index 0000000000..5023ba872c
--- /dev/null
+++ b/package/python-joblib/python-joblib.hash
@@ -0,0 +1,3 @@ 
+# Locally calculated
+sha256  4cda464ca712a4814849c9477d7551b696ce215dc05d79fc516460814ef48f4f  python-joblib-1.1.0.tar.gz
+sha256  42612911c1872c5e4b43f6ae0e8ee59467cd350332241cf72ce90640264fae6a  LICENSE.txt
diff --git a/package/python-joblib/python-joblib.mk b/package/python-joblib/python-joblib.mk
new file mode 100644
index 0000000000..27289a0a2e
--- /dev/null
+++ b/package/python-joblib/python-joblib.mk
@@ -0,0 +1,13 @@ 
+################################################################################
+#
+# python-joblib
+#
+################################################################################
+
+PYTHON_JOBLIB_VERSION = 1.1.0
+PYTHON_JOBLIB_SITE = $(call github,joblib,joblib,$(PYTHON_JOBLIB_VERSION))
+PYTHON_JOBLIB_LICENSE = BSD-3-Clause
+PYTHON_JOBLIB_LICENSE_FILES = LICENSE.txt
+PYTHON_JOBLIB_SETUP_TYPE = setuptools
+
+$(eval $(host-python-package))