diff mbox series

[1/2] package/gdk-pixbuf: enable relocatable option

Message ID 20220219122526.2954354-1-fontaine.fabrice@gmail.com
State Superseded
Headers show
Series [1/2] package/gdk-pixbuf: enable relocatable option | expand

Commit Message

Fabrice Fontaine Feb. 19, 2022, 12:25 p.m. UTC
Enable relocatable option to fix the following PPD build failure of
adwaita-icon-theme raised since commit
b06294e9897e90862656416e8b67fdace15488d7 which now correctly updates
loaders.cache:

Can't load file: Unrecognized image file format

Fixes:
 - http://autobuild.buildroot.org/results/0e00059b09b4445eaaec1030997883187c6a80d6

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/gdk-pixbuf/gdk-pixbuf.mk | 2 ++
 1 file changed, 2 insertions(+)

Comments

Yann E. MORIN Feb. 20, 2022, 11:03 a.m. UTC | #1
Fabrice, All,

On 2022-02-19 13:25 +0100, Fabrice Fontaine spake thusly:
> Enable relocatable option to fix the following PPD build failure of
> adwaita-icon-theme raised since commit
> b06294e9897e90862656416e8b67fdace15488d7 which now correctly updates
> loaders.cache:
> 
> Can't load file: Unrecognized image file format

You probably need to explain a bit more what is going here.

> Fixes:
>  - http://autobuild.buildroot.org/results/0e00059b09b4445eaaec1030997883187c6a80d6
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/gdk-pixbuf/gdk-pixbuf.mk | 2 ++
>  1 file changed, 2 insertions(+)
> 
> diff --git a/package/gdk-pixbuf/gdk-pixbuf.mk b/package/gdk-pixbuf/gdk-pixbuf.mk
> index cd30d450d5..7b9c9cdbda 100644
> --- a/package/gdk-pixbuf/gdk-pixbuf.mk
> +++ b/package/gdk-pixbuf/gdk-pixbuf.mk
> @@ -20,12 +20,14 @@ HOST_GDK_PIXBUF_DEPENDENCIES = host-libpng host-pkgconf host-libglib2
>  GDK_PIXBUF_CONF_OPTS = \
>  	-Dgio_sniffing=false \
>  	-Dinstalled_tests=false \
> +	-Drelocatable=true \

As far as I can understand, we do not care about the relocation for the
target build, only for the host build, no?

Regards,
Yann E. MORIN.

>  	-Dman=false
>  
>  HOST_GDK_PIXBUF_CONF_OPTS = \
>  	-Dgio_sniffing=false \
>  	-Dinstalled_tests=false \
>  	-Dintrospection=disabled \
> +	-Drelocatable=true \
>  	-Dman=false
>  
>  ifeq ($(BR2_STATIC_LIBS),y)
> -- 
> 2.34.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/gdk-pixbuf/gdk-pixbuf.mk b/package/gdk-pixbuf/gdk-pixbuf.mk
index cd30d450d5..7b9c9cdbda 100644
--- a/package/gdk-pixbuf/gdk-pixbuf.mk
+++ b/package/gdk-pixbuf/gdk-pixbuf.mk
@@ -20,12 +20,14 @@  HOST_GDK_PIXBUF_DEPENDENCIES = host-libpng host-pkgconf host-libglib2
 GDK_PIXBUF_CONF_OPTS = \
 	-Dgio_sniffing=false \
 	-Dinstalled_tests=false \
+	-Drelocatable=true \
 	-Dman=false
 
 HOST_GDK_PIXBUF_CONF_OPTS = \
 	-Dgio_sniffing=false \
 	-Dinstalled_tests=false \
 	-Dintrospection=disabled \
+	-Drelocatable=true \
 	-Dman=false
 
 ifeq ($(BR2_STATIC_LIBS),y)