diff mbox series

[2/2] package/gnuradio: move to package/volk instead of using the internal one

Message ID 20220208162409.496110-2-gwenj@trabucayre.com
State Accepted
Headers show
Series [1/2] package/volk: new package | expand

Commit Message

Gwenhael Goavec-Merou Feb. 8, 2022, 4:24 p.m. UTC
From: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>

Until recent releases GNURadio was shipped with volk as a submodule. With 3.9
and 3.10 this is no more true and requires building volk before GNURadio.

This patch disable internal's volk, and add a dependency to the corresponding
package, to use inconditionnaly the one build by buildroot 

Signed-off-by: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
---
 package/gnuradio/Config.in   | 1 +
 package/gnuradio/gnuradio.mk | 4 +++-
 2 files changed, 4 insertions(+), 1 deletion(-)

Comments

Romain Naour July 26, 2022, 5:41 p.m. UTC | #1
Hello Gwenhael,

Le 08/02/2022 à 17:24, Gwenhael Goavec-Merou a écrit :
> From: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
> 
> Until recent releases GNURadio was shipped with volk as a submodule. With 3.9
> and 3.10 this is no more true and requires building volk before GNURadio.

Currently Buildroot still provide gnuradio 3.8, adding volk dependency here is a
preliminary work before bumping gnuradio to a newer version.

> 
> This patch disable internal's volk, and add a dependency to the corresponding
> package, to use inconditionnaly the one build by buildroot 
> 
> Signed-off-by: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
> ---
>  package/gnuradio/Config.in   | 1 +
>  package/gnuradio/gnuradio.mk | 4 +++-
>  2 files changed, 4 insertions(+), 1 deletion(-)
> 
> diff --git a/package/gnuradio/Config.in b/package/gnuradio/Config.in
> index 1896d1326a..103175946c 100644
> --- a/package/gnuradio/Config.in
> +++ b/package/gnuradio/Config.in
> @@ -28,6 +28,7 @@ config BR2_PACKAGE_GNURADIO
>  	select BR2_PACKAGE_BOOST_THREAD
>  	select BR2_PACKAGE_LOG4CPP
>  	select BR2_PACKAGE_GMP
> +	select BR2_PACKAGE_VOLK

Maybe you could update the comment on wchar dependency:

depends on BR2_USE_WCHAR # boost, volk

Reviewed-by: Romain Naour <romain.naour@smile.fr>

Best regards,
Romain


>  	help
>  	  GNU Radio is a free & open-source software development
>  	  toolkit that provides signal processing blocks to implement
> diff --git a/package/gnuradio/gnuradio.mk b/package/gnuradio/gnuradio.mk
> index 417a51e067..ed7060b85c 100644
> --- a/package/gnuradio/gnuradio.mk
> +++ b/package/gnuradio/gnuradio.mk
> @@ -19,13 +19,15 @@ GNURADIO_DEPENDENCIES = \
>  	host-swig \
>  	boost \
>  	log4cpp \
> -	gmp
> +	gmp \
> +	volk
>  
>  GNURADIO_CONF_OPTS = \
>  	-DPYTHON_EXECUTABLE=$(HOST_DIR)/bin/python3 \
>  	-DENABLE_DEFAULT=OFF \
>  	-DENABLE_VOLK=ON \
>  	-DENABLE_GNURADIO_RUNTIME=ON \
> +	-DENABLE_INTERNAL_VOLK=OFF \
>  	-DENABLE_TESTING=OFF \
>  	-DXMLTO_EXECUTABLE=NOTFOUND
>
Thomas Petazzoni July 26, 2022, 6:50 p.m. UTC | #2
On Tue,  8 Feb 2022 17:24:09 +0100
Gwenhael Goavec-Merou <gwenj@trabucayre.com> wrote:

> From: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
> 
> Until recent releases GNURadio was shipped with volk as a submodule. With 3.9
> and 3.10 this is no more true and requires building volk before GNURadio.
> 
> This patch disable internal's volk, and add a dependency to the corresponding
> package, to use inconditionnaly the one build by buildroot 
> 
> Signed-off-by: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
> ---
>  package/gnuradio/Config.in   | 1 +
>  package/gnuradio/gnuradio.mk | 4 +++-
>  2 files changed, 4 insertions(+), 1 deletion(-)

Applied to master, thanks.

Thomas
Gwenhael Goavec-Merou July 26, 2022, 6:56 p.m. UTC | #3
Hello Romain,

On Tue, 26 Jul 2022 19:41:17 +0200
Romain Naour <romain.naour@smile.fr> wrote:

> Hello Gwenhael,
> 
> Le 08/02/2022 à 17:24, Gwenhael Goavec-Merou a écrit :
> > From: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
> > 
> > Until recent releases GNURadio was shipped with volk as a submodule. With
> > 3.9 and 3.10 this is no more true and requires building volk before
> > GNURadio.  
> 
> Currently Buildroot still provide gnuradio 3.8, adding volk dependency here
> is a preliminary work before bumping gnuradio to a newer version.
> 
Yes. I have postponed gnuradio update because at this time many OOT blocks
wasn't compatibles, and more recently a problem with python-pybind (can't built
with a 64bits host for 32bits target and reciprocal). Now It's fixed and I have
to update this patch and complete serie with a bump for gnuradio and uhd.

Gwenhael

> > 
> > This patch disable internal's volk, and add a dependency to the
> > corresponding package, to use inconditionnaly the one build by buildroot 
> > 
> > Signed-off-by: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
> > ---
> >  package/gnuradio/Config.in   | 1 +
> >  package/gnuradio/gnuradio.mk | 4 +++-
> >  2 files changed, 4 insertions(+), 1 deletion(-)
> > 
> > diff --git a/package/gnuradio/Config.in b/package/gnuradio/Config.in
> > index 1896d1326a..103175946c 100644
> > --- a/package/gnuradio/Config.in
> > +++ b/package/gnuradio/Config.in
> > @@ -28,6 +28,7 @@ config BR2_PACKAGE_GNURADIO
> >  	select BR2_PACKAGE_BOOST_THREAD
> >  	select BR2_PACKAGE_LOG4CPP
> >  	select BR2_PACKAGE_GMP
> > +	select BR2_PACKAGE_VOLK  
> 
> Maybe you could update the comment on wchar dependency:
> 
> depends on BR2_USE_WCHAR # boost, volk
> 
Thanks!
> Reviewed-by: Romain Naour <romain.naour@smile.fr>
> 
> Best regards,
> Romain
> 
> 
> >  	help
> >  	  GNU Radio is a free & open-source software development
> >  	  toolkit that provides signal processing blocks to implement
> > diff --git a/package/gnuradio/gnuradio.mk b/package/gnuradio/gnuradio.mk
> > index 417a51e067..ed7060b85c 100644
> > --- a/package/gnuradio/gnuradio.mk
> > +++ b/package/gnuradio/gnuradio.mk
> > @@ -19,13 +19,15 @@ GNURADIO_DEPENDENCIES = \
> >  	host-swig \
> >  	boost \
> >  	log4cpp \
> > -	gmp
> > +	gmp \
> > +	volk
> >  
> >  GNURADIO_CONF_OPTS = \
> >  	-DPYTHON_EXECUTABLE=$(HOST_DIR)/bin/python3 \
> >  	-DENABLE_DEFAULT=OFF \
> >  	-DENABLE_VOLK=ON \
> >  	-DENABLE_GNURADIO_RUNTIME=ON \
> > +	-DENABLE_INTERNAL_VOLK=OFF \
> >  	-DENABLE_TESTING=OFF \
> >  	-DXMLTO_EXECUTABLE=NOTFOUND
> >    
>
diff mbox series

Patch

diff --git a/package/gnuradio/Config.in b/package/gnuradio/Config.in
index 1896d1326a..103175946c 100644
--- a/package/gnuradio/Config.in
+++ b/package/gnuradio/Config.in
@@ -28,6 +28,7 @@  config BR2_PACKAGE_GNURADIO
 	select BR2_PACKAGE_BOOST_THREAD
 	select BR2_PACKAGE_LOG4CPP
 	select BR2_PACKAGE_GMP
+	select BR2_PACKAGE_VOLK
 	help
 	  GNU Radio is a free & open-source software development
 	  toolkit that provides signal processing blocks to implement
diff --git a/package/gnuradio/gnuradio.mk b/package/gnuradio/gnuradio.mk
index 417a51e067..ed7060b85c 100644
--- a/package/gnuradio/gnuradio.mk
+++ b/package/gnuradio/gnuradio.mk
@@ -19,13 +19,15 @@  GNURADIO_DEPENDENCIES = \
 	host-swig \
 	boost \
 	log4cpp \
-	gmp
+	gmp \
+	volk
 
 GNURADIO_CONF_OPTS = \
 	-DPYTHON_EXECUTABLE=$(HOST_DIR)/bin/python3 \
 	-DENABLE_DEFAULT=OFF \
 	-DENABLE_VOLK=ON \
 	-DENABLE_GNURADIO_RUNTIME=ON \
+	-DENABLE_INTERNAL_VOLK=OFF \
 	-DENABLE_TESTING=OFF \
 	-DXMLTO_EXECUTABLE=NOTFOUND