diff mbox series

[4/5] package/efl: handle input option

Message ID 20220129224651.1282263-4-romain.naour@gmail.com
State Changes Requested
Headers show
Series [1/5] package/efl: bump to version 1.26.1 | expand

Commit Message

Romain Naour Jan. 29, 2022, 10:46 p.m. UTC
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Commit 2d7a3e48c574c05346b66f79cdb75ecdfa7f074e forgot to manage input
option on target which was added (and enabled by default) by
https://git.enlightenment.org/core/efl.git/commit/?id=0c2cf7e1bf7ca547655d25aaea30d081101b42be
resulting in the following build failure when eeze is disabled:

../output-1/build/efl-1.26.0/src/lib/elput/meson.build:1:0: ERROR: Unknown variable "eeze".

Fixes:
 - http://autobuild.buildroot.org/results/4a840c54bad9748b5748738378a0352d02de1f7e

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[Romain: use BR2_PACKAGE_EFL_LIBINPUT for BR2_PACKAGE_EFL_DRM]
Signed-off-by: Romain Naour <romain.naour@gmail.com>
---
v2: rework BR2_PACKAGE_EFL_DRM
---
 package/efl/Config.in | 19 +++++++++++++++----
 package/efl/efl.mk    |  7 +++++++
 2 files changed, 22 insertions(+), 4 deletions(-)

Comments

Thomas Petazzoni Jan. 30, 2022, 2:05 p.m. UTC | #1
Hello,

On Sat, 29 Jan 2022 23:46:50 +0100
Romain Naour <romain.naour@gmail.com> wrote:

> +config BR2_PACKAGE_EFL_LIBINPUT
> +	bool "Enable libinput support (recommended)"
> +	default y
> +	depends on BR2_PACKAGE_HAS_UDEV # libinput

Should be:

	depends on BR2_PACKAGE_HAS_UDEV # libinput, efl-eeze

> +comment "libinput needs udev /dev management (eeze)"

Drop "eeze" between parenthesis.

> +	depends on !BR2_PACKAGE_HAS_UDEV
> +
>  config BR2_PACKAGE_EFL_LIBSNDFILE
>  	bool "Enable libsndfile support (recommended)"
>  	default y
> @@ -216,13 +229,11 @@ endchoice # OpenGL support
>  
>  config BR2_PACKAGE_EFL_DRM
>  	bool "Evas DRM Engine"
> -	depends on BR2_PACKAGE_HAS_UDEV (eeze)
> +	depends on BR2_PACKAGE_HAS_UDEV # elput, eeze

You fixed a bug from the previous commit here. What is "elput" ?

>  	depends on BR2_TOOLCHAIN_HAS_THREADS # libdrm
>  	depends on BR2_PACKAGE_MESA3D_OPENGL_EGL # require libgbm from mesa3d
> -	select BR2_PACKAGE_EFL_EEZE
> +	select BR2_PACKAGE_EFL_LIBINPUT

Is that the explanation for PATCH 3/5 ? But even that doesn't seem to
justify PATCH 3/5: you could have done the same with a "depends on
BR2_PACKAGE_EFL_EEZE".

Again: I agree with PATCH 3/5, and I think it's the right patch. I just
don't understand the justification it has in its commit log.

>  	select BR2_PACKAGE_LIBDRM
> -	select BR2_PACKAGE_LIBINPUT # For elput

What is "elput" ?

Thanks!

Thomas
diff mbox series

Patch

diff --git a/package/efl/Config.in b/package/efl/Config.in
index 21845ba306..bc89f2609b 100644
--- a/package/efl/Config.in
+++ b/package/efl/Config.in
@@ -85,6 +85,19 @@  config BR2_PACKAGE_EFL_LIBFRIBIDI
 	  so you may also trigger code paths with bugs that are never
 	  normally used.
 
+config BR2_PACKAGE_EFL_LIBINPUT
+	bool "Enable libinput support (recommended)"
+	default y
+	depends on BR2_PACKAGE_HAS_UDEV # libinput
+	select BR2_PACKAGE_EFL_EEZE
+	select BR2_PACKAGE_LIBINPUT
+	select BR2_PACKAGE_LIBXKBCOMMON
+	help
+	  Libinput is used to support gesture recognition.
+
+comment "libinput needs udev /dev management (eeze)"
+	depends on !BR2_PACKAGE_HAS_UDEV
+
 config BR2_PACKAGE_EFL_LIBSNDFILE
 	bool "Enable libsndfile support (recommended)"
 	default y
@@ -216,13 +229,11 @@  endchoice # OpenGL support
 
 config BR2_PACKAGE_EFL_DRM
 	bool "Evas DRM Engine"
-	depends on BR2_PACKAGE_HAS_UDEV (eeze)
+	depends on BR2_PACKAGE_HAS_UDEV # elput, eeze
 	depends on BR2_TOOLCHAIN_HAS_THREADS # libdrm
 	depends on BR2_PACKAGE_MESA3D_OPENGL_EGL # require libgbm from mesa3d
-	select BR2_PACKAGE_EFL_EEZE
+	select BR2_PACKAGE_EFL_LIBINPUT
 	select BR2_PACKAGE_LIBDRM
-	select BR2_PACKAGE_LIBINPUT # For elput
-	select BR2_PACKAGE_LIBXKBCOMMON
 	help
 	  This option enable building support for the Evas DRM Engine.
 
diff --git a/package/efl/efl.mk b/package/efl/efl.mk
index 43a2dc4fcb..021afa8204 100644
--- a/package/efl/efl.mk
+++ b/package/efl/efl.mk
@@ -67,6 +67,13 @@  else
 EFL_CONF_OPTS += -Deeze=false
 endif
 
+ifeq ($(BR2_PACKAGE_EFL_LIBINPUT),y)
+EFL_DEPENDENCIES += libinput libxkbcommon
+EFL_CONF_OPTS += -Dinput=true
+else
+EFL_CONF_OPTS += -Dinput=false
+endif
+
 ifeq ($(BR2_PACKAGE_EFL_UTIL_LINUX_LIBMOUNT),y)
 EFL_DEPENDENCIES += util-linux
 EFL_CONF_OPTS += -Dlibmount=true