diff mbox series

[1/1] package/tesseract-ocr: override neon check

Message ID 20220125223454.444515-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/tesseract-ocr: override neon check | expand

Commit Message

Fabrice Fontaine Jan. 25, 2022, 10:34 p.m. UTC
Override neon check to avoid the following build failure with uclibc-ng
raised since bump to version 5.0.1 in commit
df3f0c226fccd8d6143b09a1e05a0f5f23587136:

src/arch/simddetect.cpp:61:14: fatal error: sys/auxv.h: No such file or directory
   61 | #    include <sys/auxv.h>
      |              ^~~~~~~~~~~~

It should be noted that a patch to properly fix this build failure was
rejected by upstream as "ARM support without NEON would result in a very
slow Tesseract": https://github.com/tesseract-ocr/tesseract/pull/3717

So, a follow-up patch adding a dependency on !BR2_TOOLCHAIN_USES_UCLIBC
for all CPU architectures or only for ARM without NEON could be
approriate.

Fixes:
 - http://autobuild.buildroot.org/results/0bac6491188b6681df2ca13eb230706e83cbb130

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/tesseract-ocr/tesseract-ocr.mk | 6 ++++++
 1 file changed, 6 insertions(+)

Comments

Arnout Vandecappelle Feb. 1, 2022, 10 p.m. UTC | #1
On 25/01/2022 23:34, Fabrice Fontaine wrote:
> Override neon check to avoid the following build failure with uclibc-ng
> raised since bump to version 5.0.1 in commit
> df3f0c226fccd8d6143b09a1e05a0f5f23587136:
> 
> src/arch/simddetect.cpp:61:14: fatal error: sys/auxv.h: No such file or directory
>     61 | #    include <sys/auxv.h>
>        |              ^~~~~~~~~~~~
> 
> It should be noted that a patch to properly fix this build failure was
> rejected by upstream as "ARM support without NEON would result in a very
> slow Tesseract": https://github.com/tesseract-ocr/tesseract/pull/3717
> 
> So, a follow-up patch adding a dependency on !BR2_TOOLCHAIN_USES_UCLIBC
> for all CPU architectures or only for ARM without NEON could be
> approriate.
> 
> Fixes:
>   - http://autobuild.buildroot.org/results/0bac6491188b6681df2ca13eb230706e83cbb130
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

  Applied to master, thanks.

  Regards,
  Arnout

> ---
>   package/tesseract-ocr/tesseract-ocr.mk | 6 ++++++
>   1 file changed, 6 insertions(+)
> 
> diff --git a/package/tesseract-ocr/tesseract-ocr.mk b/package/tesseract-ocr/tesseract-ocr.mk
> index 7e23e64136..a7498931fb 100644
> --- a/package/tesseract-ocr/tesseract-ocr.mk
> +++ b/package/tesseract-ocr/tesseract-ocr.mk
> @@ -24,6 +24,12 @@ TESSERACT_OCR_CONF_ENV = \
>   TESSERACT_OCR_CONF_OPTS = \
>   	--disable-opencl
>   
> +ifeq ($(BR2_ARM_CPU_HAS_NEON),y)
> +TESSERACT_OCR_CONF_ENV += ax_cv_check_cxxflags__mfpu_neon=yes
> +else
> +TESSERACT_OCR_CONF_ENV += ax_cv_check_cxxflags__mfpu_neon=no
> +endif
> +
>   # Language data files download
>   ifeq ($(BR2_PACKAGE_TESSERACT_OCR_LANG_ENG),y)
>   TESSERACT_OCR_DATA_FILES += eng.traineddata
diff mbox series

Patch

diff --git a/package/tesseract-ocr/tesseract-ocr.mk b/package/tesseract-ocr/tesseract-ocr.mk
index 7e23e64136..a7498931fb 100644
--- a/package/tesseract-ocr/tesseract-ocr.mk
+++ b/package/tesseract-ocr/tesseract-ocr.mk
@@ -24,6 +24,12 @@  TESSERACT_OCR_CONF_ENV = \
 TESSERACT_OCR_CONF_OPTS = \
 	--disable-opencl
 
+ifeq ($(BR2_ARM_CPU_HAS_NEON),y)
+TESSERACT_OCR_CONF_ENV += ax_cv_check_cxxflags__mfpu_neon=yes
+else
+TESSERACT_OCR_CONF_ENV += ax_cv_check_cxxflags__mfpu_neon=no
+endif
+
 # Language data files download
 ifeq ($(BR2_PACKAGE_TESSERACT_OCR_LANG_ENG),y)
 TESSERACT_OCR_DATA_FILES += eng.traineddata