diff mbox series

[1/1] package/netopeer2: disable tests

Message ID 20220125210800.299916-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/netopeer2: disable tests | expand

Commit Message

Fabrice Fontaine Jan. 25, 2022, 9:08 p.m. UTC
Disable tests which are enabled since bump to version 2.0.35 in commit
13d4856b916d797c3c771669edd3eb883336766f and
https://github.com/CESNET/netopeer2/commit/466a0b3c268ee319b4f65980404715a2723b4c0a
to avoid the following build failure if cmocka is built before
netopeer2:

In file included from /home/buildroot/autobuild/instance-2/output-1/host/riscv64-buildroot-linux-musl/sysroot/usr/include/stdint.h:20,
                 from /home/buildroot/autobuild/instance-2/output-1/host/opt/ext-toolchain/lib/gcc/riscv64-buildroot-linux-musl/10.3.0/include/stdint.h:9,
                 from /home/buildroot/autobuild/instance-2/output-1/host/riscv64-buildroot-linux-musl/sysroot/usr/include/libyang/libyang.h:18,
                 from /home/buildroot/autobuild/instance-2/output-1/build/netopeer2-2.0.35/tests/test_sub_ntf.c:27:
/home/buildroot/autobuild/instance-2/output-1/host/riscv64-buildroot-linux-musl/sysroot/usr/include/bits/alltypes.h:53:24: error: conflicting types for 'uintptr_t'
   53 | typedef unsigned _Addr uintptr_t;
      |                        ^~~~~~~~~

Fixes:
 - http://autobuild.buildroot.org/results/0660a4f767d5cdaf07b28a508101b87f0300850f

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/netopeer2/netopeer2.mk | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

Heiko Thiery Jan. 26, 2022, 1:17 p.m. UTC | #1
Hi Fabrice,

Am Di., 25. Jan. 2022 um 22:09 Uhr schrieb Fabrice Fontaine
<fontaine.fabrice@gmail.com>:
>
> Disable tests which are enabled since bump to version 2.0.35 in commit
> 13d4856b916d797c3c771669edd3eb883336766f and
> https://github.com/CESNET/netopeer2/commit/466a0b3c268ee319b4f65980404715a2723b4c0a
> to avoid the following build failure if cmocka is built before
> netopeer2:
>
> In file included from /home/buildroot/autobuild/instance-2/output-1/host/riscv64-buildroot-linux-musl/sysroot/usr/include/stdint.h:20,
>                  from /home/buildroot/autobuild/instance-2/output-1/host/opt/ext-toolchain/lib/gcc/riscv64-buildroot-linux-musl/10.3.0/include/stdint.h:9,
>                  from /home/buildroot/autobuild/instance-2/output-1/host/riscv64-buildroot-linux-musl/sysroot/usr/include/libyang/libyang.h:18,
>                  from /home/buildroot/autobuild/instance-2/output-1/build/netopeer2-2.0.35/tests/test_sub_ntf.c:27:
> /home/buildroot/autobuild/instance-2/output-1/host/riscv64-buildroot-linux-musl/sysroot/usr/include/bits/alltypes.h:53:24: error: conflicting types for 'uintptr_t'
>    53 | typedef unsigned _Addr uintptr_t;
>       |                        ^~~~~~~~~
>
> Fixes:
>  - http://autobuild.buildroot.org/results/0660a4f767d5cdaf07b28a508101b87f0300850f
>
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Reviewed-by: Heiko Thiery <heiko.thiery@gmail.com>

> ---
>  package/netopeer2/netopeer2.mk | 4 +++-
>  1 file changed, 3 insertions(+), 1 deletion(-)
>
> diff --git a/package/netopeer2/netopeer2.mk b/package/netopeer2/netopeer2.mk
> index c8b6763313..43f22b7e4c 100644
> --- a/package/netopeer2/netopeer2.mk
> +++ b/package/netopeer2/netopeer2.mk
> @@ -11,7 +11,9 @@ NETOPEER2_LICENSE = BSD-3-Clause
>  NETOPEER2_LICENSE_FILES = LICENSE
>  NETOPEER2_DEPENDENCIES = libnetconf2 libyang sysrepo host-sysrepo
>
> -NETOPEER2_CONF_OPTS = -DBUILD_CLI=$(if $(BR2_PACKAGE_NETOPEER2_CLI),ON,OFF)
> +NETOPEER2_CONF_OPTS = \
> +       -DBUILD_CLI=$(if $(BR2_PACKAGE_NETOPEER2_CLI),ON,OFF) \
> +       -DENABLE_TESTS=OFF
>
>  # Set a build specific SYSREPO_SHM_PREFIX to ensure we can safely delete the
>  # files. This also ensures that concurrent parallel builds will not be
> --
> 2.34.1
>
Arnout Vandecappelle Feb. 1, 2022, 9:54 p.m. UTC | #2
On 25/01/2022 22:08, Fabrice Fontaine wrote:
> Disable tests which are enabled since bump to version 2.0.35 in commit
> 13d4856b916d797c3c771669edd3eb883336766f and
> https://github.com/CESNET/netopeer2/commit/466a0b3c268ee319b4f65980404715a2723b4c0a
> to avoid the following build failure if cmocka is built before
> netopeer2:
> 
> In file included from /home/buildroot/autobuild/instance-2/output-1/host/riscv64-buildroot-linux-musl/sysroot/usr/include/stdint.h:20,
>                   from /home/buildroot/autobuild/instance-2/output-1/host/opt/ext-toolchain/lib/gcc/riscv64-buildroot-linux-musl/10.3.0/include/stdint.h:9,
>                   from /home/buildroot/autobuild/instance-2/output-1/host/riscv64-buildroot-linux-musl/sysroot/usr/include/libyang/libyang.h:18,
>                   from /home/buildroot/autobuild/instance-2/output-1/build/netopeer2-2.0.35/tests/test_sub_ntf.c:27:
> /home/buildroot/autobuild/instance-2/output-1/host/riscv64-buildroot-linux-musl/sysroot/usr/include/bits/alltypes.h:53:24: error: conflicting types for 'uintptr_t'
>     53 | typedef unsigned _Addr uintptr_t;
>        |                        ^~~~~~~~~
> 
> Fixes:
>   - http://autobuild.buildroot.org/results/0660a4f767d5cdaf07b28a508101b87f0300850f
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

  Applied to master, thanks.

  Regards,
  Arnout

> ---
>   package/netopeer2/netopeer2.mk | 4 +++-
>   1 file changed, 3 insertions(+), 1 deletion(-)
> 
> diff --git a/package/netopeer2/netopeer2.mk b/package/netopeer2/netopeer2.mk
> index c8b6763313..43f22b7e4c 100644
> --- a/package/netopeer2/netopeer2.mk
> +++ b/package/netopeer2/netopeer2.mk
> @@ -11,7 +11,9 @@ NETOPEER2_LICENSE = BSD-3-Clause
>   NETOPEER2_LICENSE_FILES = LICENSE
>   NETOPEER2_DEPENDENCIES = libnetconf2 libyang sysrepo host-sysrepo
>   
> -NETOPEER2_CONF_OPTS = -DBUILD_CLI=$(if $(BR2_PACKAGE_NETOPEER2_CLI),ON,OFF)
> +NETOPEER2_CONF_OPTS = \
> +	-DBUILD_CLI=$(if $(BR2_PACKAGE_NETOPEER2_CLI),ON,OFF) \
> +	-DENABLE_TESTS=OFF
>   
>   # Set a build specific SYSREPO_SHM_PREFIX to ensure we can safely delete the
>   # files. This also ensures that concurrent parallel builds will not be
diff mbox series

Patch

diff --git a/package/netopeer2/netopeer2.mk b/package/netopeer2/netopeer2.mk
index c8b6763313..43f22b7e4c 100644
--- a/package/netopeer2/netopeer2.mk
+++ b/package/netopeer2/netopeer2.mk
@@ -11,7 +11,9 @@  NETOPEER2_LICENSE = BSD-3-Clause
 NETOPEER2_LICENSE_FILES = LICENSE
 NETOPEER2_DEPENDENCIES = libnetconf2 libyang sysrepo host-sysrepo
 
-NETOPEER2_CONF_OPTS = -DBUILD_CLI=$(if $(BR2_PACKAGE_NETOPEER2_CLI),ON,OFF)
+NETOPEER2_CONF_OPTS = \
+	-DBUILD_CLI=$(if $(BR2_PACKAGE_NETOPEER2_CLI),ON,OFF) \
+	-DENABLE_TESTS=OFF
 
 # Set a build specific SYSREPO_SHM_PREFIX to ensure we can safely delete the
 # files. This also ensures that concurrent parallel builds will not be