diff mbox series

[2/2] package/xvisor: add riscv support

Message ID 20220125190650.107677-2-fontaine.fabrice@gmail.com
State Superseded
Headers show
Series [1/2] package/xvisor: drop arm support | expand

Commit Message

Fabrice Fontaine Jan. 25, 2022, 7:06 p.m. UTC
riscv is supported since version 0.3.0 and
https://github.com/xvisor/xvisor/commit/d6feda4e80eefd372294b081111ce709d08ee4c0

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/xvisor/Config.in | 4 +++-
 package/xvisor/xvisor.mk | 2 ++
 2 files changed, 5 insertions(+), 1 deletion(-)

Comments

Alistair Francis Jan. 26, 2022, 10:49 p.m. UTC | #1
On Wed, Jan 26, 2022 at 5:09 AM Fabrice Fontaine
<fontaine.fabrice@gmail.com> wrote:
>
> riscv is supported since version 0.3.0 and
> https://github.com/xvisor/xvisor/commit/d6feda4e80eefd372294b081111ce709d08ee4c0
>
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Reviewed-by: Alistair Francis <alistair.francis@wdc.com>

Alistair

> ---
>  package/xvisor/Config.in | 4 +++-
>  package/xvisor/xvisor.mk | 2 ++
>  2 files changed, 5 insertions(+), 1 deletion(-)
>
> diff --git a/package/xvisor/Config.in b/package/xvisor/Config.in
> index 55c43e6959..4e7a3e1b53 100644
> --- a/package/xvisor/Config.in
> +++ b/package/xvisor/Config.in
> @@ -2,7 +2,7 @@ config BR2_PACKAGE_XVISOR_ARCH_SUPPORTS
>         bool
>         default y
>         depends on BR2_USE_MMU
> -       depends on BR2_aarch64 || BR2_x86_64
> +       depends on BR2_aarch64 || BR2_riscv || BR2_x86_64
>
>  menuconfig BR2_PACKAGE_XVISOR
>         bool "xvisor"
> @@ -32,6 +32,8 @@ endchoice
>  config BR2_PACKAGE_XVISOR_DEFCONFIG
>         string "Defconfig name"
>         default "generic-v8" if BR2_aarch64
> +       default "generic-32b" if BR2_RISCV_32
> +       default "generic-64b" if BR2_RISCV_64
>         default "x86_64_generic" if BR2_x86_64
>         depends on BR2_PACKAGE_XVISOR_USE_DEFCONFIG
>         help
> diff --git a/package/xvisor/xvisor.mk b/package/xvisor/xvisor.mk
> index 4ceb5ed7cb..1a7b49e689 100644
> --- a/package/xvisor/xvisor.mk
> +++ b/package/xvisor/xvisor.mk
> @@ -32,6 +32,8 @@ ifeq ($(BR2_x86_64),y)
>  XVISOR_ARCH = x86
>  else ifeq ($(BR2_aarch64),y)
>  XVISOR_ARCH = arm
> +else ifeq ($(BR2_riscv),y)
> +XVISOR_ARCH = riscv
>  endif
>
>  ifeq ($(BR2_PACKAGE_XVISOR)$(BR_BUILDING),yy)
> --
> 2.34.1
>
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/xvisor/Config.in b/package/xvisor/Config.in
index 55c43e6959..4e7a3e1b53 100644
--- a/package/xvisor/Config.in
+++ b/package/xvisor/Config.in
@@ -2,7 +2,7 @@  config BR2_PACKAGE_XVISOR_ARCH_SUPPORTS
 	bool
 	default y
 	depends on BR2_USE_MMU
-	depends on BR2_aarch64 || BR2_x86_64
+	depends on BR2_aarch64 || BR2_riscv || BR2_x86_64
 
 menuconfig BR2_PACKAGE_XVISOR
 	bool "xvisor"
@@ -32,6 +32,8 @@  endchoice
 config BR2_PACKAGE_XVISOR_DEFCONFIG
 	string "Defconfig name"
 	default "generic-v8" if BR2_aarch64
+	default "generic-32b" if BR2_RISCV_32
+	default "generic-64b" if BR2_RISCV_64
 	default "x86_64_generic" if BR2_x86_64
 	depends on BR2_PACKAGE_XVISOR_USE_DEFCONFIG
 	help
diff --git a/package/xvisor/xvisor.mk b/package/xvisor/xvisor.mk
index 4ceb5ed7cb..1a7b49e689 100644
--- a/package/xvisor/xvisor.mk
+++ b/package/xvisor/xvisor.mk
@@ -32,6 +32,8 @@  ifeq ($(BR2_x86_64),y)
 XVISOR_ARCH = x86
 else ifeq ($(BR2_aarch64),y)
 XVISOR_ARCH = arm
+else ifeq ($(BR2_riscv),y)
+XVISOR_ARCH = riscv
 endif
 
 ifeq ($(BR2_PACKAGE_XVISOR)$(BR_BUILDING),yy)