diff mbox series

[1/1] package/gstreamer/gst1-plugins-bad: fix build with neon

Message ID 20220125173328.3475928-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/gstreamer/gst1-plugins-bad: fix build with neon | expand

Commit Message

Fabrice Fontaine Jan. 25, 2022, 5:33 p.m. UTC
Fix the following build failure raised since bump of neon to version
0.32.2 in commit 029a6dc3e3320984c6369747e0b79060f13b2afc:

../output-1/build/gst1-plugins-bad-1.18.5/ext/neon/meson.build:1:0: ERROR: Invalid version of dependency, need 'neon' ['<= 0.31.99'] found '0.32.2'.

Fixes:
 - http://autobuild.buildroot.org/results/eaf1890176431000ea8b371956f0d2d7e9907aea

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 ...n-Allow-building-against-neon-0-32-x.patch | 29 +++++++++++++++++++
 1 file changed, 29 insertions(+)
 create mode 100644 package/gstreamer1/gst1-plugins-bad/0001-neon-Allow-building-against-neon-0-32-x.patch

Comments

Thomas Petazzoni Jan. 26, 2022, 10:34 p.m. UTC | #1
On Tue, 25 Jan 2022 18:33:28 +0100
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> Fix the following build failure raised since bump of neon to version
> 0.32.2 in commit 029a6dc3e3320984c6369747e0b79060f13b2afc:
> 
> ../output-1/build/gst1-plugins-bad-1.18.5/ext/neon/meson.build:1:0: ERROR: Invalid version of dependency, need 'neon' ['<= 0.31.99'] found '0.32.2'.
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/eaf1890176431000ea8b371956f0d2d7e9907aea
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  ...n-Allow-building-against-neon-0-32-x.patch | 29 +++++++++++++++++++
>  1 file changed, 29 insertions(+)
>  create mode 100644 package/gstreamer1/gst1-plugins-bad/0001-neon-Allow-building-against-neon-0-32-x.patch

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/gstreamer1/gst1-plugins-bad/0001-neon-Allow-building-against-neon-0-32-x.patch b/package/gstreamer1/gst1-plugins-bad/0001-neon-Allow-building-against-neon-0-32-x.patch
new file mode 100644
index 0000000000..e995a8cb91
--- /dev/null
+++ b/package/gstreamer1/gst1-plugins-bad/0001-neon-Allow-building-against-neon-0-32-x.patch
@@ -0,0 +1,29 @@ 
+From b83e85ab677c79b46f520abebd1ee031e3a139c0 Mon Sep 17 00:00:00 2001
+From: Heiko Becker <heirecka@exherbo.org>
+Date: Sun, 26 Sep 2021 21:34:30 +0200
+Subject: [PATCH] neon: Allow building against neon 0.32.x
+
+No API/ABI changes: https://github.com/notroj/neon/blob/0.32.0/NEWS#L3
+
+Part-of: <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/1267>
+
+[Retrieved from:
+https://gitlab.freedesktop.org/gstreamer/gstreamer/-/commit/b83e85ab677c79b46f520abebd1ee031e3a139c0]
+Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+---
+ subprojects/gst-plugins-bad/ext/neon/meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/ext/neon/meson.build b/ext/neon/meson.build
+index bf49be9111..abd9763649 100644
+--- a/ext/neon/meson.build
++++ b/ext/neon/meson.build
+@@ -1,4 +1,4 @@
+-neon_dep = dependency('neon', version: ['>= 0.27', '<= 0.31.99'],
++neon_dep = dependency('neon', version: ['>= 0.27', '<= 0.32.99'],
+                       required : get_option('neon'))
+ 
+ if neon_dep.found()
+-- 
+GitLab
+