diff mbox series

[1/1] package/uboot-tools: add fw_printenv to host uboot tools

Message ID 20220124223555.8595-1-quentin@barbe.me
State Accepted
Headers show
Series [1/1] package/uboot-tools: add fw_printenv to host uboot tools | expand

Commit Message

Quentin Barbe Jan. 24, 2022, 10:35 p.m. UTC
This is useful to be able to customize the default env images in post
build scripts.

Signed-off-by: Quentin Barbe <quentin@barbe.me>
---
 package/uboot-tools/uboot-tools.mk | 3 +++
 1 file changed, 3 insertions(+)

Comments

Thomas Petazzoni July 27, 2022, 3:46 p.m. UTC | #1
On Mon, 24 Jan 2022 23:35:55 +0100
Quentin Barbe <quentin@barbe.me> wrote:

> This is useful to be able to customize the default env images in post
> build scripts.
> 
> Signed-off-by: Quentin Barbe <quentin@barbe.me>
> ---
>  package/uboot-tools/uboot-tools.mk | 3 +++
>  1 file changed, 3 insertions(+)

Sorry for the long delay, but we have now finally applied your patch.
Thanks a lot for your contribution!

Thomas
diff mbox series

Patch

diff --git a/package/uboot-tools/uboot-tools.mk b/package/uboot-tools/uboot-tools.mk
index 37e329a2af..961e123fc5 100644
--- a/package/uboot-tools/uboot-tools.mk
+++ b/package/uboot-tools/uboot-tools.mk
@@ -203,6 +203,7 @@  endif #BR2_PACKAGE_HOST_UBOOT_TOOLS_BOOT_SCRIPT
 
 define HOST_UBOOT_TOOLS_BUILD_CMDS
 	$(BR2_MAKE1) -C $(@D) $(HOST_UBOOT_TOOLS_MAKE_OPTS) tools-only
+	$(BR2_MAKE1) -C $(@D) $(HOST_UBOOT_TOOLS_MAKE_OPTS) envtools no-dot-config-targets=envtools
 	$(HOST_UBOOT_TOOLS_GENERATE_ENVIMAGE)
 	$(HOST_UBOOT_TOOLS_GENERATE_BOOT_SCRIPT)
 endef
@@ -212,6 +213,8 @@  define HOST_UBOOT_TOOLS_INSTALL_CMDS
 	$(INSTALL) -m 0755 -D $(@D)/tools/mkeficapsule $(HOST_DIR)/bin/mkeficapsule
 	$(INSTALL) -m 0755 -D $(@D)/tools/mkenvimage $(HOST_DIR)/bin/mkenvimage
 	$(INSTALL) -m 0755 -D $(@D)/tools/dumpimage $(HOST_DIR)/bin/dumpimage
+	$(INSTALL) -m 0755 -D $(@D)/tools/env/fw_printenv $(HOST_DIR)/bin/fw_printenv
+	ln -sf $(HOST_DIR)/bin/fw_printenv $(HOST_DIR)/bin/fw_setenv
 	$(HOST_UBOOT_TOOLS_INSTALL_ENVIMAGE)
 	$(HOST_UBOOT_TOOLS_INSTALL_BOOT_SCRIPT)
 endef