diff mbox series

[1/1] package/vte: needs gcc >= 10

Message ID 20220123214548.783629-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/vte: needs gcc >= 10 | expand

Commit Message

Fabrice Fontaine Jan. 23, 2022, 9:45 p.m. UTC
vte needs C++20 since
https://gitlab.gnome.org/GNOME/vte/-/commit/eec33cce0b9359fddda35703e22bffd1f8f28852
to avoid the following build failure raised since bump to version 0.66.2
in commit 53c0c7dd01228122c7ceb44d65f2800dbcf473f1:

../output-1/build/vte-0.66.2/meson.build:144:0: ERROR: Assert failed: option -std=gnu++20 not supported by gcc

Fixes:
 - http://autobuild.buildroot.org/results/c0d1adeffbf97805a0f669d01929a56ccc66a835

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/vte/Config.in | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

Thomas Petazzoni Jan. 24, 2022, 9:03 p.m. UTC | #1
On Sun, 23 Jan 2022 22:45:48 +0100
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> vte needs C++20 since
> https://gitlab.gnome.org/GNOME/vte/-/commit/eec33cce0b9359fddda35703e22bffd1f8f28852
> to avoid the following build failure raised since bump to version 0.66.2
> in commit 53c0c7dd01228122c7ceb44d65f2800dbcf473f1:
> 
> ../output-1/build/vte-0.66.2/meson.build:144:0: ERROR: Assert failed: option -std=gnu++20 not supported by gcc
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/c0d1adeffbf97805a0f669d01929a56ccc66a835
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/vte/Config.in | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/vte/Config.in b/package/vte/Config.in
index 2635a6007c..45d627885f 100644
--- a/package/vte/Config.in
+++ b/package/vte/Config.in
@@ -5,7 +5,7 @@  config BR2_PACKAGE_VTE
 	depends on BR2_TOOLCHAIN_HAS_THREADS
 	depends on BR2_USE_MMU
 	depends on BR2_INSTALL_LIBSTDCPP
-	depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 # C++11
+	depends on BR2_TOOLCHAIN_GCC_AT_LEAST_10 # C++20
 	depends on BR2_TOOLCHAIN_HAS_SYNC_4
 	depends on !BR2_TOOLCHAIN_USES_MUSL
 	depends on BR2_PACKAGE_HAS_LIBEGL_WAYLAND || \
@@ -22,13 +22,13 @@  config BR2_PACKAGE_VTE
 
 	  http://github.com/GNOME/vte
 
-comment "vte needs a uClibc or glibc toolchain w/ wchar, threads, C++, gcc >= 4.8"
+comment "vte needs a uClibc or glibc toolchain w/ wchar, threads, C++, gcc >= 10"
 	depends on BR2_PACKAGE_HOST_RUSTC_ARCH_SUPPORTS
 	depends on BR2_USE_MMU
 	depends on BR2_TOOLCHAIN_HAS_SYNC_4
 	depends on !BR2_USE_WCHAR || !BR2_INSTALL_LIBSTDCPP || \
 		!BR2_TOOLCHAIN_HAS_THREADS || \
-		!BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 || \
+		!BR2_TOOLCHAIN_GCC_AT_LEAST_10 || \
 		BR2_TOOLCHAIN_USES_MUSL
 
 comment "vte needs an OpenGL or an OpenGL-EGL/wayland backend"