diff mbox series

[v2,2/6] package/lighttpd: add zstd support

Message ID 20220123095957.492671-2-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [v2,1/6] package/lighttpd: reorder alphabetically options | expand

Commit Message

Fabrice Fontaine Jan. 23, 2022, 9:59 a.m. UTC
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/lighttpd/Config.in   | 6 ++++++
 package/lighttpd/lighttpd.mk | 8 +++++++-
 2 files changed, 13 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/package/lighttpd/Config.in b/package/lighttpd/Config.in
index 59c1e0b2a6..05a7c84961 100644
--- a/package/lighttpd/Config.in
+++ b/package/lighttpd/Config.in
@@ -65,4 +65,10 @@  config BR2_PACKAGE_LIGHTTPD_ZLIB
 	help
 	  Enable zlib support for lighttpd mod_deflate.
 
+config BR2_PACKAGE_LIGHTTPD_ZSTD
+	bool "zstd support"
+	select BR2_PACKAGE_ZSTD
+	help
+	  Enable zstd support for lighttpd mod_deflate.
+
 endif
diff --git a/package/lighttpd/lighttpd.mk b/package/lighttpd/lighttpd.mk
index bdbf75191c..4f05db4e29 100644
--- a/package/lighttpd/lighttpd.mk
+++ b/package/lighttpd/lighttpd.mk
@@ -32,7 +32,6 @@  LIGHTTPD_CONF_OPTS = \
 	-Dwith_wolfssl=false \
 	-Dwith_xattr=false \
 	-Dwith_xxhash=true \
-	-Dwith_zstd=false \
 	-Dbuild_extra_warnings=false \
 	-Dbuild_static=false \
 	-Dmoduledir=lib/lighttpd
@@ -92,6 +91,13 @@  else
 LIGHTTPD_CONF_OPTS += -Dwith_zlib=false
 endif
 
+ifeq ($(BR2_PACKAGE_LIGHTTPD_ZSTD),y)
+LIGHTTPD_DEPENDENCIES += zstd
+LIGHTTPD_CONF_OPTS += -Dwith_zstd=true
+else
+LIGHTTPD_CONF_OPTS += -Dwith_zstd=false
+endif
+
 define LIGHTTPD_INSTALL_CONFIG
 	$(INSTALL) -d -m 0755 $(TARGET_DIR)/etc/lighttpd/conf.d
 	$(INSTALL) -d -m 0755 $(TARGET_DIR)/var/www