diff mbox series

[v2,2/2] package/clpeak: new package

Message ID 20220116175320.453041-2-gilles.talis@gmail.com
State Accepted
Headers show
Series [1/2] package/opencl-clhpp: new package | expand

Commit Message

Gilles Talis Jan. 16, 2022, 5:53 p.m. UTC
clpeak is a tool that profiles OpenCL devices to find
their peak capacities

Signed-off-by: Gilles Talis <gilles.talis@gmail.com>
---
v2:
 - Added opencl-clhpp dependency

 DEVELOPERS                 |  1 +
 package/Config.in          |  1 +
 package/clpeak/Config.in   | 15 +++++++++++++++
 package/clpeak/clpeak.hash |  3 +++
 package/clpeak/clpeak.mk   | 13 +++++++++++++
 5 files changed, 33 insertions(+)
 create mode 100644 package/clpeak/Config.in
 create mode 100644 package/clpeak/clpeak.hash
 create mode 100644 package/clpeak/clpeak.mk

Comments

Romain Naour July 26, 2022, 9:09 p.m. UTC | #1
Hello Gilles,

Le 16/01/2022 à 18:53, Gilles Talis a écrit :
> clpeak is a tool that profiles OpenCL devices to find
> their peak capacities
> 
> Signed-off-by: Gilles Talis <gilles.talis@gmail.com>
> ---
> v2:
>  - Added opencl-clhpp dependency

It seems you missed the second part of the review from Thomas about the issue
with NXP OpenCL provider:

http://lists.busybox.net/pipermail/buildroot/2021-December/631942.html

But after testing again locally the issue is gone since the Bootlin toolchain
has been updated to 2021.11-1 and now use a newer glibc version > 2.33.

Testing again with the previous toolchain [1] the build fail again.

I don't think the issue is really related to clpeak but the imx-gpu-viv package
itself. But we don't have a way in the current external toolchain infrastructure
to add a dependency on the glibc version provided by the external toolchain.

Otherwise:
Reviewed-by: Romain Naour <romain.naour@smile.fr>

[1]
https://toolchains.bootlin.com/downloads/releases/toolchains/aarch64/tarballs/aarch64--glibc--stable-2020.08-1.tar.bz2

Best regards,
Romain


> 
>  DEVELOPERS                 |  1 +
>  package/Config.in          |  1 +
>  package/clpeak/Config.in   | 15 +++++++++++++++
>  package/clpeak/clpeak.hash |  3 +++
>  package/clpeak/clpeak.mk   | 13 +++++++++++++
>  5 files changed, 33 insertions(+)
>  create mode 100644 package/clpeak/Config.in
>  create mode 100644 package/clpeak/clpeak.hash
>  create mode 100644 package/clpeak/clpeak.mk
> 
> diff --git a/DEVELOPERS b/DEVELOPERS
> index 483afa4932..04b3f8fba9 100644
> --- a/DEVELOPERS
> +++ b/DEVELOPERS
> @@ -1075,6 +1075,7 @@ N:	Gilles Talis <gilles.talis@gmail.com>
>  F:	board/freescale/imx8mmevk/
>  F:	configs/freescale_imx8mmevk_defconfig
>  F:	package/cctz/
> +F:	package/clpeak/
>  F:	package/faad2/
>  F:	package/fdk-aac/
>  F:	package/httping/
> diff --git a/package/Config.in b/package/Config.in
> index 08eb3ad809..b38d05b3b3 100644
> --- a/package/Config.in
> +++ b/package/Config.in
> @@ -87,6 +87,7 @@ menu "Debugging, profiling and benchmark"
>  	source "package/bonnie/Config.in"
>  	source "package/cache-calibrator/Config.in"
>  	source "package/clinfo/Config.in"
> +	source "package/clpeak/Config.in"
>  	source "package/coremark/Config.in"
>  	source "package/coremark-pro/Config.in"
>  	source "package/dacapo/Config.in"
> diff --git a/package/clpeak/Config.in b/package/clpeak/Config.in
> new file mode 100644
> index 0000000000..c83297549c
> --- /dev/null
> +++ b/package/clpeak/Config.in
> @@ -0,0 +1,15 @@
> +config BR2_PACKAGE_CLPEAK
> +	bool "clpeak"
> +	depends on BR2_PACKAGE_HAS_LIBOPENCL
> +	depends on BR2_INSTALL_LIBSTDCPP
> +	depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 # C++11
> +	select BR2_PACKAGE_OPENCL_CLHPP
> +	help
> +	  clpeak is a tool that profiles OpenCL devices
> +	  to find their peak capacities
> +
> +	  https://github.com/krrishnarraj/clpeak
> +
> +comment "clpeak needs an OpenCL provider, a toolchain w/ C++, gcc >= 4.8"
> +	depends on !BR2_PACKAGE_HAS_LIBOPENCL \
> +		|| !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_GCC_AT_LEAST_4_8
> diff --git a/package/clpeak/clpeak.hash b/package/clpeak/clpeak.hash
> new file mode 100644
> index 0000000000..e0d2c1e92b
> --- /dev/null
> +++ b/package/clpeak/clpeak.hash
> @@ -0,0 +1,3 @@
> +# Locally computed
> +sha256  1e9c3f959498253d6bb956dc786de7b3e4019264216a1781c06ae49a1d6600e5  clpeak-0777205be1d5681d5a76d46ec94588544e8462a5.tar.gz
> +sha256  88d9b4eb60579c191ec391ca04c16130572d7eedc4a86daa58bf28c6e14c9bcd  LICENSE
> diff --git a/package/clpeak/clpeak.mk b/package/clpeak/clpeak.mk
> new file mode 100644
> index 0000000000..5fa990fb34
> --- /dev/null
> +++ b/package/clpeak/clpeak.mk
> @@ -0,0 +1,13 @@
> +################################################################################
> +#
> +# clpeak
> +#
> +################################################################################
> +
> +CLPEAK_VERSION = 0777205be1d5681d5a76d46ec94588544e8462a5
> +CLPEAK_SITE = $(call github,krrishnarraj,clpeak,$(CLPEAK_VERSION))
> +CLPEAK_LICENSE = Unlicense
> +CLPEAK_LICENSE_FILES = LICENSE
> +CLPEAK_DEPENDENCIES = libopencl opencl-clhpp
> +
> +$(eval $(cmake-package))
Thomas Petazzoni July 27, 2022, 7:32 a.m. UTC | #2
Hello Gilles,

On Sun, 16 Jan 2022 18:53:20 +0100
Gilles Talis <gilles.talis@gmail.com> wrote:

> clpeak is a tool that profiles OpenCL devices to find
> their peak capacities
> 
> Signed-off-by: Gilles Talis <gilles.talis@gmail.com>
> ---
> v2:
>  - Added opencl-clhpp dependency

I have applied after updating to the slightly newer tagged release
1.1.2.

Thanks a lot!

Thomas
diff mbox series

Patch

diff --git a/DEVELOPERS b/DEVELOPERS
index 483afa4932..04b3f8fba9 100644
--- a/DEVELOPERS
+++ b/DEVELOPERS
@@ -1075,6 +1075,7 @@  N:	Gilles Talis <gilles.talis@gmail.com>
 F:	board/freescale/imx8mmevk/
 F:	configs/freescale_imx8mmevk_defconfig
 F:	package/cctz/
+F:	package/clpeak/
 F:	package/faad2/
 F:	package/fdk-aac/
 F:	package/httping/
diff --git a/package/Config.in b/package/Config.in
index 08eb3ad809..b38d05b3b3 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -87,6 +87,7 @@  menu "Debugging, profiling and benchmark"
 	source "package/bonnie/Config.in"
 	source "package/cache-calibrator/Config.in"
 	source "package/clinfo/Config.in"
+	source "package/clpeak/Config.in"
 	source "package/coremark/Config.in"
 	source "package/coremark-pro/Config.in"
 	source "package/dacapo/Config.in"
diff --git a/package/clpeak/Config.in b/package/clpeak/Config.in
new file mode 100644
index 0000000000..c83297549c
--- /dev/null
+++ b/package/clpeak/Config.in
@@ -0,0 +1,15 @@ 
+config BR2_PACKAGE_CLPEAK
+	bool "clpeak"
+	depends on BR2_PACKAGE_HAS_LIBOPENCL
+	depends on BR2_INSTALL_LIBSTDCPP
+	depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 # C++11
+	select BR2_PACKAGE_OPENCL_CLHPP
+	help
+	  clpeak is a tool that profiles OpenCL devices
+	  to find their peak capacities
+
+	  https://github.com/krrishnarraj/clpeak
+
+comment "clpeak needs an OpenCL provider, a toolchain w/ C++, gcc >= 4.8"
+	depends on !BR2_PACKAGE_HAS_LIBOPENCL \
+		|| !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_GCC_AT_LEAST_4_8
diff --git a/package/clpeak/clpeak.hash b/package/clpeak/clpeak.hash
new file mode 100644
index 0000000000..e0d2c1e92b
--- /dev/null
+++ b/package/clpeak/clpeak.hash
@@ -0,0 +1,3 @@ 
+# Locally computed
+sha256  1e9c3f959498253d6bb956dc786de7b3e4019264216a1781c06ae49a1d6600e5  clpeak-0777205be1d5681d5a76d46ec94588544e8462a5.tar.gz
+sha256  88d9b4eb60579c191ec391ca04c16130572d7eedc4a86daa58bf28c6e14c9bcd  LICENSE
diff --git a/package/clpeak/clpeak.mk b/package/clpeak/clpeak.mk
new file mode 100644
index 0000000000..5fa990fb34
--- /dev/null
+++ b/package/clpeak/clpeak.mk
@@ -0,0 +1,13 @@ 
+################################################################################
+#
+# clpeak
+#
+################################################################################
+
+CLPEAK_VERSION = 0777205be1d5681d5a76d46ec94588544e8462a5
+CLPEAK_SITE = $(call github,krrishnarraj,clpeak,$(CLPEAK_VERSION))
+CLPEAK_LICENSE = Unlicense
+CLPEAK_LICENSE_FILES = LICENSE
+CLPEAK_DEPENDENCIES = libopencl opencl-clhpp
+
+$(eval $(cmake-package))