diff mbox series

[PATCHv2,7/7] linux/linux.mk: correct LINUX_ARCH_PATH for sparc64

Message ID 20220115200306.14037-8-patrickdepinguin@gmail.com
State Accepted
Headers show
Series Basic support for 64-bit kernel and 32-bit userland | expand

Commit Message

Thomas De Schampheleire Jan. 15, 2022, 8:03 p.m. UTC
From: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>

Buildroot uses variable LINUX_ARCH_PATH to refer to the arch-specific
directory in the Linux tree, which may not necessarily be arch/$(KERNEL_ARCH).

Buildroot already accounts for the case of KERNEL_ARCH=i386 and
KERNEL_ARCH=x86_64, but does not for KERNEL_ARCH=sparc64, in which case the
correct directory is arch/sparc.

Reported-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
---
 linux/linux.mk | 2 ++
 1 file changed, 2 insertions(+)

Comments

Arnout Vandecappelle Feb. 8, 2022, 8:28 p.m. UTC | #1
On 15/01/2022 21:03, Thomas De Schampheleire wrote:
> From: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
> 
> Buildroot uses variable LINUX_ARCH_PATH to refer to the arch-specific
> directory in the Linux tree, which may not necessarily be arch/$(KERNEL_ARCH).
> 
> Buildroot already accounts for the case of KERNEL_ARCH=i386 and
> KERNEL_ARCH=x86_64, but does not for KERNEL_ARCH=sparc64, in which case the
> correct directory is arch/sparc.
> 
> Reported-by: Romain Naour <romain.naour@gmail.com>
> Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>

  AFAIU this is completely independent of the rest of the series, so I applied 
to master, thanks.

  Regards,
  Arnout

> ---
>   linux/linux.mk | 2 ++
>   1 file changed, 2 insertions(+)
> 
> diff --git a/linux/linux.mk b/linux/linux.mk
> index dd2eebd446..35e2484588 100644
> --- a/linux/linux.mk
> +++ b/linux/linux.mk
> @@ -242,6 +242,8 @@ ifeq ($(KERNEL_ARCH),i386)
>   LINUX_ARCH_PATH = $(LINUX_DIR)/arch/x86
>   else ifeq ($(KERNEL_ARCH),x86_64)
>   LINUX_ARCH_PATH = $(LINUX_DIR)/arch/x86
> +else ifeq ($(KERNEL_ARCH),sparc64)
> +LINUX_ARCH_PATH = $(LINUX_DIR)/arch/sparc
>   else
>   LINUX_ARCH_PATH = $(LINUX_DIR)/arch/$(KERNEL_ARCH)
>   endif
diff mbox series

Patch

diff --git a/linux/linux.mk b/linux/linux.mk
index dd2eebd446..35e2484588 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -242,6 +242,8 @@  ifeq ($(KERNEL_ARCH),i386)
 LINUX_ARCH_PATH = $(LINUX_DIR)/arch/x86
 else ifeq ($(KERNEL_ARCH),x86_64)
 LINUX_ARCH_PATH = $(LINUX_DIR)/arch/x86
+else ifeq ($(KERNEL_ARCH),sparc64)
+LINUX_ARCH_PATH = $(LINUX_DIR)/arch/sparc
 else
 LINUX_ARCH_PATH = $(LINUX_DIR)/arch/$(KERNEL_ARCH)
 endif