diff mbox series

[1/1] package/kf5/kf5-extra-cmake-modules: do not build documentation

Message ID 20220113233758.110264-1-aperez@igalia.com
State Accepted
Headers show
Series [1/1] package/kf5/kf5-extra-cmake-modules: do not build documentation | expand

Commit Message

Adrian Perez de Castro Jan. 13, 2022, 11:37 p.m. UTC
Pass needed CMake options to disable generating documentations. The
documentation is built using python-sphinx, which is not packaged in
Buildroot.

Prior to this change, if the build host would have a Python installation
with the sphinx module installed the automatic detection tried to build
documentation, which would fail in cases where the sphinxcontrib-qthelp
package is missing from the host Python installation. The error message
in this case was:

  Extension error:
  Could not import extension ecm (exception: cannot import name
    'htmlescape' from 'sphinx.util.pycompat'
    (/usr/lib/python3.10/site-packages/sphinx/util/pycompat.py))

Signed-off-by: Adrian Perez de Castro <aperez@igalia.com>
---
 .../kf5/kf5-extra-cmake-modules/kf5-extra-cmake-modules.mk   | 5 +++++
 1 file changed, 5 insertions(+)

Comments

Arnout Vandecappelle Feb. 3, 2022, 8:39 p.m. UTC | #1
On 14/01/2022 00:37, Adrian Perez de Castro wrote:
> Pass needed CMake options to disable generating documentations. The
> documentation is built using python-sphinx, which is not packaged in
> Buildroot.
> 
> Prior to this change, if the build host would have a Python installation
> with the sphinx module installed the automatic detection tried to build
> documentation, which would fail in cases where the sphinxcontrib-qthelp
> package is missing from the host Python installation. The error message
> in this case was:
> 
>    Extension error:
>    Could not import extension ecm (exception: cannot import name
>      'htmlescape' from 'sphinx.util.pycompat'
>      (/usr/lib/python3.10/site-packages/sphinx/util/pycompat.py))
> 
> Signed-off-by: Adrian Perez de Castro <aperez@igalia.com>

  Applied to master, thanks.

  (AFAICS the v2 was in fact identical)

  Regards,
  Arnout

> ---
>   .../kf5/kf5-extra-cmake-modules/kf5-extra-cmake-modules.mk   | 5 +++++
>   1 file changed, 5 insertions(+)
> 
> diff --git a/package/kf5/kf5-extra-cmake-modules/kf5-extra-cmake-modules.mk b/package/kf5/kf5-extra-cmake-modules/kf5-extra-cmake-modules.mk
> index 3c4281b960..ba2748456e 100644
> --- a/package/kf5/kf5-extra-cmake-modules/kf5-extra-cmake-modules.mk
> +++ b/package/kf5/kf5-extra-cmake-modules/kf5-extra-cmake-modules.mk
> @@ -14,4 +14,9 @@ KF5_EXTRA_CMAKE_MODULES_DEPENDENCIES = host-pkgconf
>   KF5_EXTRA_CMAKE_MODULES_INSTALL_STAGING = YES
>   KF5_EXTRA_CMAKE_MODULES_INSTALL_TARGET = NO
>   
> +KF5_EXTRA_CMAKE_MODULES_CONF_OPTS += \
> +	-DBUILD_HTML_DOCS=OFF \
> +	-DBUILD_MAN_DOCS=OFF \
> +	-DBUILD_QTHELP_DOCS=OFF
> +
>   $(eval $(cmake-package))
Peter Korsgaard Feb. 16, 2022, 8:29 a.m. UTC | #2
>>>>> "Arnout" == Arnout Vandecappelle <arnout@mind.be> writes:

 > On 14/01/2022 00:37, Adrian Perez de Castro wrote:
 >> Pass needed CMake options to disable generating documentations. The
 >> documentation is built using python-sphinx, which is not packaged in
 >> Buildroot.
 >> 
 >> Prior to this change, if the build host would have a Python installation
 >> with the sphinx module installed the automatic detection tried to build
 >> documentation, which would fail in cases where the sphinxcontrib-qthelp
 >> package is missing from the host Python installation. The error message
 >> in this case was:
 >> 
 >> Extension error:
 >> Could not import extension ecm (exception: cannot import name
 >> 'htmlescape' from 'sphinx.util.pycompat'
 >> (/usr/lib/python3.10/site-packages/sphinx/util/pycompat.py))
 >> 
 >> Signed-off-by: Adrian Perez de Castro <aperez@igalia.com>

 >  Applied to master, thanks.

 >  (AFAICS the v2 was in fact identical)

Committed to 2021.02.x and 2021.11.x, thanks.
diff mbox series

Patch

diff --git a/package/kf5/kf5-extra-cmake-modules/kf5-extra-cmake-modules.mk b/package/kf5/kf5-extra-cmake-modules/kf5-extra-cmake-modules.mk
index 3c4281b960..ba2748456e 100644
--- a/package/kf5/kf5-extra-cmake-modules/kf5-extra-cmake-modules.mk
+++ b/package/kf5/kf5-extra-cmake-modules/kf5-extra-cmake-modules.mk
@@ -14,4 +14,9 @@  KF5_EXTRA_CMAKE_MODULES_DEPENDENCIES = host-pkgconf
 KF5_EXTRA_CMAKE_MODULES_INSTALL_STAGING = YES
 KF5_EXTRA_CMAKE_MODULES_INSTALL_TARGET = NO
 
+KF5_EXTRA_CMAKE_MODULES_CONF_OPTS += \
+	-DBUILD_HTML_DOCS=OFF \
+	-DBUILD_MAN_DOCS=OFF \
+	-DBUILD_QTHELP_DOCS=OFF
+
 $(eval $(cmake-package))