diff mbox series

[1/1] package/polkit: fix build on meson 0.61.0

Message ID 20220112094731.2117910-1-james.hilliard1@gmail.com
State Accepted
Headers show
Series [1/1] package/polkit: fix build on meson 0.61.0 | expand

Commit Message

James Hilliard Jan. 12, 2022, 9:47 a.m. UTC
Backport a patch removing invalid positional arguments:
../output-1/build/polkit-0.120/actions/meson.build:3:5: ERROR: Function does not take positional arguments.

Fixes:
 - http://autobuild.buildroot.net/results/b2d/b2d2b27844b32b3609e11005966d85dc0dfb7a9f

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
---
 ...tional-parameters-to-i18n.merge_file.patch | 45 +++++++++++++++++++
 1 file changed, 45 insertions(+)
 create mode 100644 package/polkit/0002-Don-t-pass-positional-parameters-to-i18n.merge_file.patch

Comments

Thomas Petazzoni Jan. 12, 2022, 10:38 a.m. UTC | #1
On Wed, 12 Jan 2022 02:47:31 -0700
James Hilliard <james.hilliard1@gmail.com> wrote:

> Backport a patch removing invalid positional arguments:
> ../output-1/build/polkit-0.120/actions/meson.build:3:5: ERROR: Function does not take positional arguments.
> 
> Fixes:
>  - http://autobuild.buildroot.net/results/b2d/b2d2b27844b32b3609e11005966d85dc0dfb7a9f
> 
> Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
> ---
>  ...tional-parameters-to-i18n.merge_file.patch | 45 +++++++++++++++++++
>  1 file changed, 45 insertions(+)
>  create mode 100644 package/polkit/0002-Don-t-pass-positional-parameters-to-i18n.merge_file.patch

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/polkit/0002-Don-t-pass-positional-parameters-to-i18n.merge_file.patch b/package/polkit/0002-Don-t-pass-positional-parameters-to-i18n.merge_file.patch
new file mode 100644
index 0000000000..25fa4ef19b
--- /dev/null
+++ b/package/polkit/0002-Don-t-pass-positional-parameters-to-i18n.merge_file.patch
@@ -0,0 +1,45 @@ 
+From 30c368a6b729bc8a0a9d0d023739c4fa07b0928b Mon Sep 17 00:00:00 2001
+From: Simon McVittie <smcv@debian.org>
+Date: Mon, 25 Oct 2021 20:21:27 +0100
+Subject: [PATCH] Don't pass positional parameters to i18n.merge_file
+
+These were always ignored, and Meson 0.60.0 disallowed them.
+
+Resolves: https://gitlab.freedesktop.org/polkit/polkit/-/issues/160
+Reference: https://github.com/mesonbuild/meson/pull/9445
+Signed-off-by: Simon McVittie <smcv@debian.org>
+Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
+[Upstream status:
+https://gitlab.freedesktop.org/polkit/polkit/-/merge_requests/99]
+---
+ actions/meson.build      | 1 -
+ src/examples/meson.build | 1 -
+ 2 files changed, 2 deletions(-)
+
+diff --git a/actions/meson.build b/actions/meson.build
+index 2abaaf3..1e3f370 100644
+--- a/actions/meson.build
++++ b/actions/meson.build
+@@ -1,7 +1,6 @@
+ policy = 'org.freedesktop.policykit.policy'
+ 
+ i18n.merge_file(
+-  policy,
+   input: policy + '.in',
+   output: '@BASENAME@',
+   po_dir: po_dir,
+diff --git a/src/examples/meson.build b/src/examples/meson.build
+index c6305ab..8c18de5 100644
+--- a/src/examples/meson.build
++++ b/src/examples/meson.build
+@@ -1,7 +1,6 @@
+ policy = 'org.freedesktop.policykit.examples.pkexec.policy'
+ 
+ i18n.merge_file(
+-  policy,
+   input: policy + '.in',
+   output: '@BASENAME@',
+   po_dir: po_dir,
+-- 
+2.25.1
+