diff mbox series

[v2,4/4] package/systemd: always enable systemd-tmpfilesd

Message ID 20211203223127.274985-4-nolange79@gmail.com
State Accepted
Headers show
Series [v2,1/4] package/systemd: set cgroups default-hierarchy to unified | expand

Commit Message

Norbert Lange Dec. 3, 2021, 10:31 p.m. UTC
this tool and service is pretty much expected to be enabled,
making this a certainty will enable future improvements.

The config variable BR2_PACKAGE_SYSTEMD_TMPFILES is still
availabe and always set.

Signed-off-by: Norbert Lange <nolange79@gmail.com>
---
v1->v2
-   dont remove the config, instead just set it to 1
---
 package/dhcp/Config.in     | 1 -
 package/systemd/Config.in  | 9 +--------
 package/systemd/systemd.mk | 7 +------
 3 files changed, 2 insertions(+), 15 deletions(-)

Comments

Arnout Vandecappelle Jan. 9, 2022, 12:59 p.m. UTC | #1
On 03/12/2021 23:31, Norbert Lange wrote:
> this tool and service is pretty much expected to be enabled,
> making this a certainty will enable future improvements.
> 
> The config variable BR2_PACKAGE_SYSTEMD_TMPFILES is still
> availabe and always set.

  I don't understand why it's not simply removed. (The commit message should 
primarily explain *why* things are done, not so much *what* is done.)

  Since I think that the symbol can be removed entirely, I pushed a follow-up 
patch that
- removes the symbol;
- removes its use in cryptsetup.mk;
- adds it in Config.in.legacy, with an explanation of what to do if it's used in 
br2-external.

  It's a separate commit, so if you think that it really shouldn't have been 
removed we can easily revert it.

  Regards,
  Arnout

> 
> Signed-off-by: Norbert Lange <nolange79@gmail.com>
> ---
> v1->v2
> -   dont remove the config, instead just set it to 1
> ---
>   package/dhcp/Config.in     | 1 -
>   package/systemd/Config.in  | 9 +--------
>   package/systemd/systemd.mk | 7 +------
>   3 files changed, 2 insertions(+), 15 deletions(-)
> 
> diff --git a/package/dhcp/Config.in b/package/dhcp/Config.in
> index e6e70908dd..515040c612 100644
> --- a/package/dhcp/Config.in
> +++ b/package/dhcp/Config.in
> @@ -13,7 +13,6 @@ if BR2_PACKAGE_DHCP
>   
>   config BR2_PACKAGE_DHCP_SERVER
>   	bool "dhcp server"
> -	select BR2_PACKAGE_SYSTEMD_TMPFILES if BR2_PACKAGE_SYSTEMD
>   	help
>   	  DHCP server from the ISC DHCP distribution.
>   
> diff --git a/package/systemd/Config.in b/package/systemd/Config.in
> index 6f622c73f3..52c86aad59 100644
> --- a/package/systemd/Config.in
> +++ b/package/systemd/Config.in
> @@ -485,15 +485,8 @@ config BR2_PACKAGE_SYSTEMD_TIMESYNCD
>   	  http://www.freedesktop.org/software/systemd/man/systemd-timesyncd.html
>   
>   config BR2_PACKAGE_SYSTEMD_TMPFILES
> -	bool "enable tmpfiles support"
> +	bool
>   	default y
> -	help
> -	  systemd-tmpfiles creates, deletes, and cleans up volatile
> -	  and temporary files and directories, based on the
> -	  configuration file format and location specified in
> -	  tmpfiles.d(5).
> -
> -	  http://www.freedesktop.org/software/systemd/man/systemd-tmpfiles.html
>   
>   config BR2_PACKAGE_SYSTEMD_USERDB
>   	bool "enable userdb daemon"
> diff --git a/package/systemd/systemd.mk b/package/systemd/systemd.mk
> index 16202d4ac9..dfe9a1a5c7 100644
> --- a/package/systemd/systemd.mk
> +++ b/package/systemd/systemd.mk
> @@ -49,6 +49,7 @@ SYSTEMD_CONF_OPTS += \
>   	-Dsysvrcnd-path= \
>   	-Dtelinit-path= \
>   	-Dtests=false \
> +	-Dtmpfiles=true \
>   	-Dumount-path=/usr/bin/umount \
>   	-Dutmp=false
>   
> @@ -307,12 +308,6 @@ else
>   SYSTEMD_CONF_OPTS += -Dquotacheck=false
>   endif
>   
> -ifeq ($(BR2_PACKAGE_SYSTEMD_TMPFILES),y)
> -SYSTEMD_CONF_OPTS += -Dtmpfiles=true
> -else
> -SYSTEMD_CONF_OPTS += -Dtmpfiles=false
> -endif
> -
>   ifeq ($(BR2_PACKAGE_SYSTEMD_SYSUSERS),y)
>   SYSTEMD_CONF_OPTS += -Dsysusers=true
>   else
>
diff mbox series

Patch

diff --git a/package/dhcp/Config.in b/package/dhcp/Config.in
index e6e70908dd..515040c612 100644
--- a/package/dhcp/Config.in
+++ b/package/dhcp/Config.in
@@ -13,7 +13,6 @@  if BR2_PACKAGE_DHCP
 
 config BR2_PACKAGE_DHCP_SERVER
 	bool "dhcp server"
-	select BR2_PACKAGE_SYSTEMD_TMPFILES if BR2_PACKAGE_SYSTEMD
 	help
 	  DHCP server from the ISC DHCP distribution.
 
diff --git a/package/systemd/Config.in b/package/systemd/Config.in
index 6f622c73f3..52c86aad59 100644
--- a/package/systemd/Config.in
+++ b/package/systemd/Config.in
@@ -485,15 +485,8 @@  config BR2_PACKAGE_SYSTEMD_TIMESYNCD
 	  http://www.freedesktop.org/software/systemd/man/systemd-timesyncd.html
 
 config BR2_PACKAGE_SYSTEMD_TMPFILES
-	bool "enable tmpfiles support"
+	bool
 	default y
-	help
-	  systemd-tmpfiles creates, deletes, and cleans up volatile
-	  and temporary files and directories, based on the
-	  configuration file format and location specified in
-	  tmpfiles.d(5).
-
-	  http://www.freedesktop.org/software/systemd/man/systemd-tmpfiles.html
 
 config BR2_PACKAGE_SYSTEMD_USERDB
 	bool "enable userdb daemon"
diff --git a/package/systemd/systemd.mk b/package/systemd/systemd.mk
index 16202d4ac9..dfe9a1a5c7 100644
--- a/package/systemd/systemd.mk
+++ b/package/systemd/systemd.mk
@@ -49,6 +49,7 @@  SYSTEMD_CONF_OPTS += \
 	-Dsysvrcnd-path= \
 	-Dtelinit-path= \
 	-Dtests=false \
+	-Dtmpfiles=true \
 	-Dumount-path=/usr/bin/umount \
 	-Dutmp=false
 
@@ -307,12 +308,6 @@  else
 SYSTEMD_CONF_OPTS += -Dquotacheck=false
 endif
 
-ifeq ($(BR2_PACKAGE_SYSTEMD_TMPFILES),y)
-SYSTEMD_CONF_OPTS += -Dtmpfiles=true
-else
-SYSTEMD_CONF_OPTS += -Dtmpfiles=false
-endif
-
 ifeq ($(BR2_PACKAGE_SYSTEMD_SYSUSERS),y)
 SYSTEMD_CONF_OPTS += -Dsysusers=true
 else