diff mbox series

[PATCH/next,1/2] package/gnuradio: force python3-six

Message ID 20211129165001.363636-1-gwenj@trabucayre.com
State Accepted
Headers show
Series [PATCH/next,1/2] package/gnuradio: force python3-six | expand

Commit Message

Gwenhael Goavec-Merou Nov. 29, 2021, 4:50 p.m. UTC
From: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>

host-python-six needs host-python (aka python2) but since
commit e9df5b0fc3f6e8bb36deedefb392bbc968116ee7 python-mako is
python3 only. python-six is build using python2 and python-mako with
python3 and gnuradio build fails with:

-- Python checking for python >= 2.7
-- Python checking for python >= 2.7 - found
--
-- Python checking for mako >= 0.4.2
-- Python checking for mako >= 0.4.2 - not found

This patch force the use of host-python3-six to be coherent

Fixes:
- http://autobuild.buildroot.net/results/2685fb00883e6936e24ca1f17b693e6e1c13c9fa

Signed-off-by: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
---
 package/gnuradio/gnuradio.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Thomas Petazzoni Dec. 4, 2021, 8:24 p.m. UTC | #1
On Mon, 29 Nov 2021 17:50:00 +0100
Gwenhael Goavec-Merou <gwenj@trabucayre.com> wrote:

> From: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
> 
> host-python-six needs host-python (aka python2) but since
> commit e9df5b0fc3f6e8bb36deedefb392bbc968116ee7 python-mako is
> python3 only. python-six is build using python2 and python-mako with
> python3 and gnuradio build fails with:
> 
> -- Python checking for python >= 2.7
> -- Python checking for python >= 2.7 - found
> --
> -- Python checking for mako >= 0.4.2
> -- Python checking for mako >= 0.4.2 - not found
> 
> This patch force the use of host-python3-six to be coherent
> 
> Fixes:
> - http://autobuild.buildroot.net/results/2685fb00883e6936e24ca1f17b693e6e1c13c9fa
> 
> Signed-off-by: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
> ---
>  package/gnuradio/gnuradio.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)

Both applied to next. Thanks!

Thomas
diff mbox series

Patch

diff --git a/package/gnuradio/gnuradio.mk b/package/gnuradio/gnuradio.mk
index 2272a1162a..5616039559 100644
--- a/package/gnuradio/gnuradio.mk
+++ b/package/gnuradio/gnuradio.mk
@@ -22,7 +22,7 @@  endif
 GNURADIO_DEPENDENCIES = \
 	host-python3 \
 	host-python-mako \
-	host-python-six \
+	host-python3-six \
 	host-swig \
 	boost \
 	log4cpp \