diff mbox series

[PATCH/next] package/uhd: fix python module detection

Message ID 20211129155318.356600-1-gwenj@trabucayre.com
State Accepted
Headers show
Series [PATCH/next] package/uhd: fix python module detection | expand

Commit Message

Gwenhael Goavec-Merou Nov. 29, 2021, 3:53 p.m. UTC
From: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>

$(HOST_DIR)/bin/python symlink is only created when BR2_PACKAGE_PYTHON3 is
set.
When only host-python3 is used this symlink is not present and build fails
with:
-- Python checking for Python version 2.7 or greater
-- Python checking for Python version 2.7 or greater - unknown error

Comments

Thomas Petazzoni Dec. 4, 2021, 8:36 p.m. UTC | #1
On Mon, 29 Nov 2021 16:53:18 +0100
Gwenhael Goavec-Merou <gwenj@trabucayre.com> wrote:

> From: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
> 
> $(HOST_DIR)/bin/python symlink is only created when BR2_PACKAGE_PYTHON3 is
> set.
> When only host-python3 is used this symlink is not present and build fails
> with:

Applied to next, thanks!

Thomas
diff mbox series

Patch

diff --git a/package/uhd/uhd.mk b/package/uhd/uhd.mk
index 5da1697925..e8f197f9dd 100644
--- a/package/uhd/uhd.mk
+++ b/package/uhd/uhd.mk
@@ -19,7 +19,7 @@  UHD_DEPENDENCIES = \
 	host-python-mako
 
 UHD_CONF_OPTS = \
-	-DPYTHON_EXECUTABLE=$(HOST_DIR)/bin/python \
+	-DPYTHON_EXECUTABLE=$(HOST_DIR)/bin/python3 \
 	-DRUNTIME_PYTHON_EXECUTABLE=/usr/bin/python \
 	-DENABLE_C_API=ON \
 	-DENABLE_DOXYGEN=OFF \