diff mbox series

[2/4] package/libnetconf2: bump version to 2.0.24

Message ID 20211125125558.1087094-3-heiko.thiery@gmail.com
State Accepted
Headers show
Series Bump netopeer2 and dependencies | expand

Commit Message

Heiko Thiery Nov. 25, 2021, 12:55 p.m. UTC
Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com>
---
 ...IX-netopeer2-build-fails-when-buildi.patch | 34 +++++++++++++++++++
 package/libnetconf2/libnetconf2.hash          |  2 +-
 package/libnetconf2/libnetconf2.mk            |  2 +-
 3 files changed, 36 insertions(+), 2 deletions(-)
 create mode 100644 package/libnetconf2/0001-libnetconf2-BUGFIX-netopeer2-build-fails-when-buildi.patch
diff mbox series

Patch

diff --git a/package/libnetconf2/0001-libnetconf2-BUGFIX-netopeer2-build-fails-when-buildi.patch b/package/libnetconf2/0001-libnetconf2-BUGFIX-netopeer2-build-fails-when-buildi.patch
new file mode 100644
index 0000000000..c03fdc9999
--- /dev/null
+++ b/package/libnetconf2/0001-libnetconf2-BUGFIX-netopeer2-build-fails-when-buildi.patch
@@ -0,0 +1,34 @@ 
+From e06f291cc36c9e9a3c9c224e23109ac6dad4eb1c Mon Sep 17 00:00:00 2001
+From: Heiko Thiery <heiko.thiery@gmail.com>
+Date: Thu, 25 Nov 2021 12:29:47 +0100
+Subject: [PATCH] libnetconf2 BUGFIX netopeer2 build fails when building with
+ musl libc
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+/home/hthiery/sources/mainline/buildroot/output/host/x86_64-buildroot-linux-musl/sysroot/usr/include/libnetconf2/session_server.h:439:55: error: unknown type name ‘mode_t’
+  439 | int nc_server_endpt_set_perms(const char *endpt_name, mode_t mode, uid_t uid, gid_t gid);
+
+For musl libc the include "sys/types.h" is required.
+
+Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com>
+---
+ src/session_server.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/session_server.h b/src/session_server.h
+index 4507eea..4779119 100644
+--- a/src/session_server.h
++++ b/src/session_server.h
+@@ -19,6 +19,7 @@
+ extern "C" {
+ #endif
+ 
++#include <sys/types.h>
+ #include <libyang/libyang.h>
+ #include <stdint.h>
+ 
+-- 
+2.30.2
+
diff --git a/package/libnetconf2/libnetconf2.hash b/package/libnetconf2/libnetconf2.hash
index 24cc3a5557..2dee93cc4c 100644
--- a/package/libnetconf2/libnetconf2.hash
+++ b/package/libnetconf2/libnetconf2.hash
@@ -1,3 +1,3 @@ 
 # Locally calculated
-sha256  66139fc9e68aa89c82235f4135dba9e44f5db663541279c14c74131e22b7f571  libnetconf2-1.1.43.tar.gz
+sha256  78ffa0bd85823abd321a1dbb09c1ead36612f2a12049638a14bb081567f86ade  libnetconf2-2.0.24.tar.gz
 sha256  bd962ab457c8a8cb8faaaa36c11484680f3c9a47dbc336507817ae8935384064  LICENSE
diff --git a/package/libnetconf2/libnetconf2.mk b/package/libnetconf2/libnetconf2.mk
index 40fa935bb1..33e1fadf76 100644
--- a/package/libnetconf2/libnetconf2.mk
+++ b/package/libnetconf2/libnetconf2.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-LIBNETCONF2_VERSION = 1.1.43
+LIBNETCONF2_VERSION = 2.0.24
 LIBNETCONF2_SITE = $(call github,CESNET,libnetconf2,v$(LIBNETCONF2_VERSION))
 LIBNETCONF2_INSTALL_STAGING = YES
 LIBNETCONF2_LICENSE = BSD-3-Clause