diff mbox series

[PATCH-next,v2,7/7] Makefile: include *.patch in check-package

Message ID 20211121170756.3810922-7-ricardo.martincoski@gmail.com
State Accepted
Headers show
Series [PATCH-next,v2,1/7] boot/lpc32xxcdl: rename patches with the proper naming convention | expand

Commit Message

Ricardo Martincoski Nov. 21, 2021, 5:07 p.m. UTC
From: "Arnout Vandecappelle (Essensium/Mind)" <arnout@mind.be>

Since a long time, we have a check-package check for patches. Make sure
that this check runs in 'make check-package', by including *.patch in
the find expression.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
[Ricardo: do not run check for SoB for now]
Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>
---
v2 for http://patchwork.ozlabs.org/project/buildroot/patch/20211025192813.159336-1-arnout@mind.be/
At next branch currently we have 53 SoB warnings.

I don't want to mess with missing SoBs for now :)
These are the reasons:
IMO, someone must check every single one of the 53 .patches to add a
SoB. What should we do for them?
 - check where the patch came from? Maybe not possible in some cases.
 - assume that who added the patch was signing it (is this a valid legal
   assumption?)
 - maybe add the SoB of the person checking the patch instead?
 - many patches missing a SoB also completely miss a header describing
   the patch

But while these .patch files are not fixed, we can use this
'--exclude=Sob' and check in the GitLab pipeline all other parts of
.patch files that check-package knows already. See:
$ ./utils/check-package --dry-run package/screen/0001-no-memcpy-fallback.patch
package/screen/0001-no-memcpy-fallback.patch: would run: ['ApplyOrder', 'NewlineAtEof', 'NumberedSubject', 'Sob']

v2 of this series can be applied already, see a run in the GitLab CI
using this series:
https://gitlab.com/RicardoMartincoski/buildroot/-/jobs/1804683744
---
 Makefile | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Arnout Vandecappelle Dec. 11, 2021, 7:55 p.m. UTC | #1
On 21/11/2021 18:07, Ricardo Martincoski wrote:
> From: "Arnout Vandecappelle (Essensium/Mind)" <arnout@mind.be>

  I normally don't like applying my own patches, but this time: series applied 
to master, thanks.

> 
> Since a long time, we have a check-package check for patches. Make sure
> that this check runs in 'make check-package', by including *.patch in
> the find expression.
> 
> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
> [Ricardo: do not run check for SoB for now]

  I've updated the commit message to briefly explain why.

  Regards,
  Arnout

> Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>
> ---
> v2 for http://patchwork.ozlabs.org/project/buildroot/patch/20211025192813.159336-1-arnout@mind.be/
> At next branch currently we have 53 SoB warnings.
> 
> I don't want to mess with missing SoBs for now :)
> These are the reasons:
> IMO, someone must check every single one of the 53 .patches to add a
> SoB. What should we do for them?
>   - check where the patch came from? Maybe not possible in some cases.
>   - assume that who added the patch was signing it (is this a valid legal
>     assumption?)
>   - maybe add the SoB of the person checking the patch instead?
>   - many patches missing a SoB also completely miss a header describing
>     the patch
> 
> But while these .patch files are not fixed, we can use this
> '--exclude=Sob' and check in the GitLab pipeline all other parts of
> .patch files that check-package knows already. See:
> $ ./utils/check-package --dry-run package/screen/0001-no-memcpy-fallback.patch
> package/screen/0001-no-memcpy-fallback.patch: would run: ['ApplyOrder', 'NewlineAtEof', 'NumberedSubject', 'Sob']
> 
> v2 of this series can be applied already, see a run in the GitLab CI
> using this series:
> https://gitlab.com/RicardoMartincoski/buildroot/-/jobs/1804683744
> ---
>   Makefile | 4 ++--
>   1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/Makefile b/Makefile
> index 4062883cc2..55676386f9 100644
> --- a/Makefile
> +++ b/Makefile
> @@ -1224,8 +1224,8 @@ check-flake8:
>   	| xargs -- python3 -m flake8 --statistics
>   
>   check-package:
> -	find $(TOPDIR) -type f \( -name '*.mk' -o -name '*.hash' -o -name 'Config.*' \) \
> -		-exec ./utils/check-package {} +
> +	find $(TOPDIR) -type f \( -name '*.mk' -o -name '*.hash' -o -name 'Config.*' -o -name '*.patch' \) \
> +		-exec ./utils/check-package --exclude=Sob {} +
>   
>   include docs/manual/manual.mk
>   -include $(foreach dir,$(BR2_EXTERNAL_DIRS),$(sort $(wildcard $(dir)/docs/*/*.mk)))
>
diff mbox series

Patch

diff --git a/Makefile b/Makefile
index 4062883cc2..55676386f9 100644
--- a/Makefile
+++ b/Makefile
@@ -1224,8 +1224,8 @@  check-flake8:
 	| xargs -- python3 -m flake8 --statistics
 
 check-package:
-	find $(TOPDIR) -type f \( -name '*.mk' -o -name '*.hash' -o -name 'Config.*' \) \
-		-exec ./utils/check-package {} +
+	find $(TOPDIR) -type f \( -name '*.mk' -o -name '*.hash' -o -name 'Config.*' -o -name '*.patch' \) \
+		-exec ./utils/check-package --exclude=Sob {} +
 
 include docs/manual/manual.mk
 -include $(foreach dir,$(BR2_EXTERNAL_DIRS),$(sort $(wildcard $(dir)/docs/*/*.mk)))