diff mbox series

package/rpi-firmware: update vcdbg runtime dependencies

Message ID 20211115144620.80555-1-kory.maincent@bootlin.com
State Accepted
Headers show
Series package/rpi-firmware: update vcdbg runtime dependencies | expand

Commit Message

Kory Maincent Nov. 15, 2021, 2:46 p.m. UTC
We used to select the rpi-userland to make the vcdbg tool work but it
conflict with the use of mesa. It implies we can not install vcdbg with
mesa libraries but it is false. We could use the prebuilt libraries from
the rpi-firmware sources to run vcdbg.

This patch removes the select dependency of rpi-userland package and
installs the prebuilt libraries needed by vcdbg only if rpi-userland
is not selected.

Signed-off-by: Kory Maincent <kory.maincent@bootlin.com>
---
 package/rpi-firmware/Config.in       |  1 -
 package/rpi-firmware/rpi-firmware.mk | 11 +++++++++++
 2 files changed, 11 insertions(+), 1 deletion(-)

Comments

Bryce Schober Dec. 2, 2021, 12:39 a.m. UTC | #1
On Mon, Nov 15, 2021 at 6:46 AM Kory Maincent <kory.maincent@bootlin.com>
wrote:
>
> We used to select the rpi-userland to make the vcdbg tool work but it
> conflict with the use of mesa. It implies we can not install vcdbg with
> mesa libraries but it is false. We could use the prebuilt libraries from
> the rpi-firmware sources to run vcdbg.
>
> This patch removes the select dependency of rpi-userland package and
> installs the prebuilt libraries needed by vcdbg only if rpi-userland
> is not selected.
>
> Signed-off-by: Kory Maincent <kory.maincent@bootlin.com>

Reviewed-by: Bryce Schober <bryce.schober@gmail.com>
Tested-by: Bryce Schober <bryce.schober@gmail.com>

> ---
>  package/rpi-firmware/Config.in       |  1 -
>  package/rpi-firmware/rpi-firmware.mk | 11 +++++++++++
>  2 files changed, 11 insertions(+), 1 deletion(-)
>
> diff --git a/package/rpi-firmware/Config.in
b/package/rpi-firmware/Config.in
> index f5a25c5680..d8bcc8ba96 100644
> --- a/package/rpi-firmware/Config.in
> +++ b/package/rpi-firmware/Config.in
> @@ -98,7 +98,6 @@ config BR2_PACKAGE_RPI_FIRMWARE_INSTALL_VCDBG
>         depends on BR2_arm # prebuilt arm binary, rpi-userland
>         depends on BR2_TOOLCHAIN_USES_GLIBC
>         depends on BR2_INSTALL_LIBSTDCPP # rpi-userland
> -       select BR2_PACKAGE_RPI_USERLAND
>         help
>           Install vcdbg, to help debug communication with the GPU.
>
> diff --git a/package/rpi-firmware/rpi-firmware.mk b/package/rpi-firmware/
rpi-firmware.mk
> index d74f7155c7..743a259dc3 100644
> --- a/package/rpi-firmware/rpi-firmware.mk
> +++ b/package/rpi-firmware/rpi-firmware.mk
> @@ -32,12 +32,23 @@ define RPI_FIRMWARE_INSTALL_DTB_OVERLAYS
>  endef
>  endif
>
> +# Install prebuilt libraries if RPI_USERLAND not enabled
> +ifneq ($(BR2_PACKAGE_RPI_USERLAND),y)
> +define RPI_FIRMWARE_INSTALL_TARGET_LIB
> +       $(INSTALL) -D -m 0644 $(@D)/$(if
BR2_ARM_EABIHF,hardfp/)opt/vc/lib/libvcos.so \
> +               $(TARGET_DIR)/usr/lib/libvcos.so
> +       $(INSTALL) -D -m 0644 $(@D)/$(if
BR2_ARM_EABIHF,hardfp/)opt/vc/lib/libdebug_sym.so \
> +               $(TARGET_DIR)/usr/lib/libdebug_sym.so
> +endef
> +endif
> +
>  ifeq ($(BR2_PACKAGE_RPI_FIRMWARE_INSTALL_VCDBG),y)
>  define RPI_FIRMWARE_INSTALL_TARGET_CMDS
>         $(INSTALL) -D -m 0700 $(@D)/$(if
BR2_ARM_EABIHF,hardfp/)opt/vc/bin/vcdbg \
>                 $(TARGET_DIR)/usr/sbin/vcdbg
>         $(INSTALL) -D -m 0644 $(@D)/$(if
BR2_ARM_EABIHF,hardfp/)opt/vc/lib/libelftoolchain.so \
>                 $(TARGET_DIR)/usr/lib/libelftoolchain.so
> +       $(RPI_FIRMWARE_INSTALL_TARGET_LIB)
>  endef
>  endif # INSTALL_VCDBG
>
> --
> 2.25.1
>
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
Arnout Vandecappelle Dec. 10, 2021, 7:11 p.m. UTC | #2
On 15/11/2021 15:46, Kory Maincent wrote:
> We used to select the rpi-userland to make the vcdbg tool work but it
> conflict with the use of mesa. It implies we can not install vcdbg with
> mesa libraries but it is false. We could use the prebuilt libraries from
> the rpi-firmware sources to run vcdbg.
> 
> This patch removes the select dependency of rpi-userland package and
> installs the prebuilt libraries needed by vcdbg only if rpi-userland
> is not selected.
> 
> Signed-off-by: Kory Maincent <kory.maincent@bootlin.com>

  Applied to master, thanks.

  Regards,
  Arnout

> ---
>   package/rpi-firmware/Config.in       |  1 -
>   package/rpi-firmware/rpi-firmware.mk | 11 +++++++++++
>   2 files changed, 11 insertions(+), 1 deletion(-)
> 
> diff --git a/package/rpi-firmware/Config.in b/package/rpi-firmware/Config.in
> index f5a25c5680..d8bcc8ba96 100644
> --- a/package/rpi-firmware/Config.in
> +++ b/package/rpi-firmware/Config.in
> @@ -98,7 +98,6 @@ config BR2_PACKAGE_RPI_FIRMWARE_INSTALL_VCDBG
>   	depends on BR2_arm # prebuilt arm binary, rpi-userland
>   	depends on BR2_TOOLCHAIN_USES_GLIBC
>   	depends on BR2_INSTALL_LIBSTDCPP # rpi-userland
> -	select BR2_PACKAGE_RPI_USERLAND
>   	help
>   	  Install vcdbg, to help debug communication with the GPU.
>   
> diff --git a/package/rpi-firmware/rpi-firmware.mk b/package/rpi-firmware/rpi-firmware.mk
> index d74f7155c7..743a259dc3 100644
> --- a/package/rpi-firmware/rpi-firmware.mk
> +++ b/package/rpi-firmware/rpi-firmware.mk
> @@ -32,12 +32,23 @@ define RPI_FIRMWARE_INSTALL_DTB_OVERLAYS
>   endef
>   endif
>   
> +# Install prebuilt libraries if RPI_USERLAND not enabled
> +ifneq ($(BR2_PACKAGE_RPI_USERLAND),y)
> +define RPI_FIRMWARE_INSTALL_TARGET_LIB
> +	$(INSTALL) -D -m 0644 $(@D)/$(if BR2_ARM_EABIHF,hardfp/)opt/vc/lib/libvcos.so \
> +		$(TARGET_DIR)/usr/lib/libvcos.so
> +	$(INSTALL) -D -m 0644 $(@D)/$(if BR2_ARM_EABIHF,hardfp/)opt/vc/lib/libdebug_sym.so \
> +		$(TARGET_DIR)/usr/lib/libdebug_sym.so
> +endef
> +endif
> +
>   ifeq ($(BR2_PACKAGE_RPI_FIRMWARE_INSTALL_VCDBG),y)
>   define RPI_FIRMWARE_INSTALL_TARGET_CMDS
>   	$(INSTALL) -D -m 0700 $(@D)/$(if BR2_ARM_EABIHF,hardfp/)opt/vc/bin/vcdbg \
>   		$(TARGET_DIR)/usr/sbin/vcdbg
>   	$(INSTALL) -D -m 0644 $(@D)/$(if BR2_ARM_EABIHF,hardfp/)opt/vc/lib/libelftoolchain.so \
>   		$(TARGET_DIR)/usr/lib/libelftoolchain.so
> +	$(RPI_FIRMWARE_INSTALL_TARGET_LIB)
>   endef
>   endif # INSTALL_VCDBG
>   
>
diff mbox series

Patch

diff --git a/package/rpi-firmware/Config.in b/package/rpi-firmware/Config.in
index f5a25c5680..d8bcc8ba96 100644
--- a/package/rpi-firmware/Config.in
+++ b/package/rpi-firmware/Config.in
@@ -98,7 +98,6 @@  config BR2_PACKAGE_RPI_FIRMWARE_INSTALL_VCDBG
 	depends on BR2_arm # prebuilt arm binary, rpi-userland
 	depends on BR2_TOOLCHAIN_USES_GLIBC
 	depends on BR2_INSTALL_LIBSTDCPP # rpi-userland
-	select BR2_PACKAGE_RPI_USERLAND
 	help
 	  Install vcdbg, to help debug communication with the GPU.
 
diff --git a/package/rpi-firmware/rpi-firmware.mk b/package/rpi-firmware/rpi-firmware.mk
index d74f7155c7..743a259dc3 100644
--- a/package/rpi-firmware/rpi-firmware.mk
+++ b/package/rpi-firmware/rpi-firmware.mk
@@ -32,12 +32,23 @@  define RPI_FIRMWARE_INSTALL_DTB_OVERLAYS
 endef
 endif
 
+# Install prebuilt libraries if RPI_USERLAND not enabled
+ifneq ($(BR2_PACKAGE_RPI_USERLAND),y)
+define RPI_FIRMWARE_INSTALL_TARGET_LIB
+	$(INSTALL) -D -m 0644 $(@D)/$(if BR2_ARM_EABIHF,hardfp/)opt/vc/lib/libvcos.so \
+		$(TARGET_DIR)/usr/lib/libvcos.so
+	$(INSTALL) -D -m 0644 $(@D)/$(if BR2_ARM_EABIHF,hardfp/)opt/vc/lib/libdebug_sym.so \
+		$(TARGET_DIR)/usr/lib/libdebug_sym.so
+endef
+endif
+
 ifeq ($(BR2_PACKAGE_RPI_FIRMWARE_INSTALL_VCDBG),y)
 define RPI_FIRMWARE_INSTALL_TARGET_CMDS
 	$(INSTALL) -D -m 0700 $(@D)/$(if BR2_ARM_EABIHF,hardfp/)opt/vc/bin/vcdbg \
 		$(TARGET_DIR)/usr/sbin/vcdbg
 	$(INSTALL) -D -m 0644 $(@D)/$(if BR2_ARM_EABIHF,hardfp/)opt/vc/lib/libelftoolchain.so \
 		$(TARGET_DIR)/usr/lib/libelftoolchain.so
+	$(RPI_FIRMWARE_INSTALL_TARGET_LIB)
 endef
 endif # INSTALL_VCDBG