diff mbox series

[v2] package/mksh: use plain HTTP in download and license links

Message ID 20211114210316.1403514-1-unixmania@gmail.com
State Accepted
Headers show
Series [v2] package/mksh: use plain HTTP in download and license links | expand

Commit Message

Carlos Santos Nov. 14, 2021, 9:03 p.m. UTC
From: Carlos Santos <unixmania@gmail.com>

The server does not support TLS v1.2, causing dowloads to fall back to
sources.buildroot.net. Mail sent to the project owner bounces, so it
looks like this issue will not be solved anytime soon. Switch to HTTP
and rely on the hashes to verify the integrity and authenticity of the
download.

Signed-off-by: Carlos Santos <unixmania@gmail.com>
---
 package/mksh/mksh.mk | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Yann E. MORIN Nov. 14, 2021, 9:25 p.m. UTC | #1
Carlos, All,

On 2021-11-14 18:03 -0300, unixmania@gmail.com spake thusly:
> From: Carlos Santos <unixmania@gmail.com>
> 
> The server does not support TLS v1.2, causing dowloads to fall back to
> sources.buildroot.net. Mail sent to the project owner bounces, so it
> looks like this issue will not be solved anytime soon. Switch to HTTP
> and rely on the hashes to verify the integrity and authenticity of the
> download.
> 
> Signed-off-by: Carlos Santos <unixmania@gmail.com>

Applied to master, after adding a reference to your recent commit for
the homepage, thanks!

Regards,
Yann E. MORIN.

> ---
>  package/mksh/mksh.mk | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/package/mksh/mksh.mk b/package/mksh/mksh.mk
> index 386b1bd016..c4818e8692 100644
> --- a/package/mksh/mksh.mk
> +++ b/package/mksh/mksh.mk
> @@ -6,8 +6,8 @@
>  
>  MKSH_VERSION = 59c
>  MKSH_SOURCE = mksh-R$(MKSH_VERSION).tgz
> -MKSH_SITE = https://www.mirbsd.org/MirOS/dist/mir/mksh
> -# For MirOS License see https://www.mirbsd.org/TaC-mksh.txt
> +MKSH_SITE = http://www.mirbsd.org/MirOS/dist/mir/mksh
> +# For MirOS License see http://www.mirbsd.org/TaC-mksh.txt
>  MKSH_LICENSE = MirOS, ISC
>  MKSH_LICENSE_FILES = mksh.1
>  
> -- 
> 2.27.0
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
Peter Korsgaard Nov. 17, 2021, 10:33 p.m. UTC | #2
>>>>> "unixmania" == unixmania  <unixmania@gmail.com> writes:

 > From: Carlos Santos <unixmania@gmail.com>
 > The server does not support TLS v1.2, causing dowloads to fall back to
 > sources.buildroot.net. Mail sent to the project owner bounces, so it
 > looks like this issue will not be solved anytime soon. Switch to HTTP
 > and rely on the hashes to verify the integrity and authenticity of the
 > download.

 > Signed-off-by: Carlos Santos <unixmania@gmail.com>

Committed to 2021.02.x and 2021.08.x, thanks.
diff mbox series

Patch

diff --git a/package/mksh/mksh.mk b/package/mksh/mksh.mk
index 386b1bd016..c4818e8692 100644
--- a/package/mksh/mksh.mk
+++ b/package/mksh/mksh.mk
@@ -6,8 +6,8 @@ 
 
 MKSH_VERSION = 59c
 MKSH_SOURCE = mksh-R$(MKSH_VERSION).tgz
-MKSH_SITE = https://www.mirbsd.org/MirOS/dist/mir/mksh
-# For MirOS License see https://www.mirbsd.org/TaC-mksh.txt
+MKSH_SITE = http://www.mirbsd.org/MirOS/dist/mir/mksh
+# For MirOS License see http://www.mirbsd.org/TaC-mksh.txt
 MKSH_LICENSE = MirOS, ISC
 MKSH_LICENSE_FILES = mksh.1