diff mbox series

[2/2] support/dependencies: avoid spurious warning on print-vars

Message ID 20211109165908.1942790-2-yann.morin.1998@free.fr
State Handled Elsewhere
Headers show
Series [1/2] package/kodi-*: run pkg-config at build time, not at parse time | expand

Commit Message

Yann E. MORIN Nov. 9, 2021, 4:59 p.m. UTC
When calling 'printvars', the 'suitable-host-package' macro is printed
(a macro is just a variable like the others, after all, just with some
parameters). Because it is printed as a variable, it is missing its
parameters, but it still tries to evaluate the $(shell) construct.

This causes spurious warning:

    make[1]: support/dependencies/check-host-.sh: Command not found

Only try and call the script if there is actually a tool to check for.

Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
---
 support/dependencies/dependencies.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Peter Korsgaard Dec. 12, 2021, 10:12 p.m. UTC | #1
>>>>> "Yann" == Yann E MORIN <yann.morin.1998@free.fr> writes:

 > When calling 'printvars', the 'suitable-host-package' macro is printed
 > (a macro is just a variable like the others, after all, just with some
 > parameters). Because it is printed as a variable, it is missing its
 > parameters, but it still tries to evaluate the $(shell) construct.

 > This causes spurious warning:

 >     make[1]: support/dependencies/check-host-.sh: Command not found

 > Only try and call the script if there is actually a tool to check for.

 > Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>

Committed to 2021.02.x and 2021.08.x, thanks.
diff mbox series

Patch

diff --git a/support/dependencies/dependencies.mk b/support/dependencies/dependencies.mk
index 4fac5c731b..a7bb1a6080 100644
--- a/support/dependencies/dependencies.mk
+++ b/support/dependencies/dependencies.mk
@@ -15,7 +15,7 @@  else
 # script should use 'which' to find a candidate. The script should return
 # the path to the suitable host tool, or nothing if no suitable tool was found.
 define suitable-host-package
-$(shell support/dependencies/check-host-$(1).sh $(2))
+$(if $(1),$(shell support/dependencies/check-host-$(1).sh $(2)))
 endef
 endif
 # host utilities needs host-tar to extract the source code tarballs, so