diff mbox series

[1/1] package/bird: fix build with autoconf >= 2.70

Message ID 20211105201257.2589008-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/bird: fix build with autoconf >= 2.70 | expand

Commit Message

Fabrice Fontaine Nov. 5, 2021, 8:12 p.m. UTC
Fix the following build failure raised since bump of autoconf to version
2.71 in commit ecd54b65c1f998a7ccd91f7c523e4ff38c4781da:

checking for glob.h... no
configure: error: glob.h not found.

Fixes:
 - http://autobuild.buildroot.org/results/d7aab7df196e0f6d6389b87ff29da7c2971e6b6d

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 ...gure.ac-fix-build-with-autoconf-2.70.patch | 43 +++++++++++++++++++
 1 file changed, 43 insertions(+)
 create mode 100644 package/bird/0001-configure.ac-fix-build-with-autoconf-2.70.patch

Comments

Arnout Vandecappelle Nov. 9, 2021, 10:16 p.m. UTC | #1
On 05/11/2021 21:12, Fabrice Fontaine wrote:
> Fix the following build failure raised since bump of autoconf to version
> 2.71 in commit ecd54b65c1f998a7ccd91f7c523e4ff38c4781da:
> 
> checking for glob.h... no
> configure: error: glob.h not found.
> 
> Fixes:
>   - http://autobuild.buildroot.org/results/d7aab7df196e0f6d6389b87ff29da7c2971e6b6d
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>   ...gure.ac-fix-build-with-autoconf-2.70.patch | 43 +++++++++++++++++++
>   1 file changed, 43 insertions(+)
>   create mode 100644 package/bird/0001-configure.ac-fix-build-with-autoconf-2.70.patch
> 
> diff --git a/package/bird/0001-configure.ac-fix-build-with-autoconf-2.70.patch b/package/bird/0001-configure.ac-fix-build-with-autoconf-2.70.patch
> new file mode 100644
> index 0000000000..b412a55ead
> --- /dev/null
> +++ b/package/bird/0001-configure.ac-fix-build-with-autoconf-2.70.patch
> @@ -0,0 +1,43 @@
> +From aa5bc6d2e59c5257d777a45ee4a0e0a784c44244 Mon Sep 17 00:00:00 2001
> +From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> +Date: Fri, 5 Nov 2021 20:58:41 +0100
> +Subject: [PATCH] configure.ac: fix build with autoconf >= 2.70
> +
> +On some embedded toolchains, glob.h detection fails because -g is
> +wrongly added (even when CFLAGS is overwritten):
> +
> +configure:5881: checking for glob.h
> +configure:5904: /home/giuliobenetti/autobuild/run/instance-2/output-1/host/bin/mips64el-linux-gcc -o conftest -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64  -Os -g0  -pthread -fno-strict-aliasing -fno-strict-overflow -flto -Wall -Wextra -Wstrict-prototypes -Wno-parentheses -Wno-pointer-sign -Wno-missing-field-initializers -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64  -pthread -flto=4 -g conftest.c  >&5
> +/home/giuliobenetti/autobuild/run/instance-2/output-1/host/opt/ext-toolchain/bin/../lib/gcc/mips64el-buildroot-linux-uclibc/8.4.0/../../../../mips64el-buildroot-linux-uclibc/bin/ld: /tmp/ccldlED9.ltrans0.ltrans.o:(.debug_info+0x2a): undefined reference to `conftest.c.fb729d13'
> +/home/giuliobenetti/autobuild/run/instance-2/output-1/host/opt/ext-toolchain/bin/../lib/gcc/mips64el-buildroot-linux-uclibc/8.4.0/../../../../mips64el-buildroot-linux-uclibc/bin/ld: /tmp/ccldlED9.ltrans0.ltrans.o:(.debug_info+0x2f): undefined reference to `conftest.c.fb729d13'
> +
> +This build failure is raised since autoconf 2.70 and
> +https://git.savannah.gnu.org/cgit/autoconf.git/commit/?id=76754e04fce5f6a7701bec57b057020585df2ae3
> +because ac_test_CFLAGS is now set to ${CFLAGS+y} instead of
> +${CFLAGS+set}
> +
> +Fixes:
> + - http://autobuild.buildroot.org/results/d7aab7df196e0f6d6389b87ff29da7c2971e6b6d
> +
> +Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> +[Upstream status: sent to bird-users@network.cz]

  Why not create an MR? You can log in to their gitlab with a github account 
(funny that you can't log in with a gitlab.com account...)

> +---
> + configure.ac | 2 +-
> + 1 file changed, 1 insertion(+), 1 deletion(-)
> +
> +diff --git a/configure.ac b/configure.ac
> +index 64181d29..b4b3fcfb 100644
> +--- a/configure.ac
> ++++ b/configure.ac
> +@@ -114,7 +114,7 @@ AC_SEARCH_LIBS([clock_gettime], [rt posix4],
> + AC_CANONICAL_HOST
> +
> + # Store this value because ac_test_CFLAGS is overwritten by AC_PROG_CC
> +-if test "$ac_test_CFLAGS" != set ; then
> ++if ! test $ac_test_CFLAGS ; then

  Wouldn't it be more future-safe to put quotes around $ac_test_CFLAGS?

  Regards,
  Arnout

> +   bird_cflags_default=yes
> + fi
> +
> +--
> +2.33.0
> +
>
Fabrice Fontaine Nov. 9, 2021, 10:30 p.m. UTC | #2
Le mar. 9 nov. 2021 à 23:16, Arnout Vandecappelle <arnout@mind.be> a écrit :
>
>
>
> On 05/11/2021 21:12, Fabrice Fontaine wrote:
> > Fix the following build failure raised since bump of autoconf to version
> > 2.71 in commit ecd54b65c1f998a7ccd91f7c523e4ff38c4781da:
> >
> > checking for glob.h... no
> > configure: error: glob.h not found.
> >
> > Fixes:
> >   - http://autobuild.buildroot.org/results/d7aab7df196e0f6d6389b87ff29da7c2971e6b6d
> >
> > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> > ---
> >   ...gure.ac-fix-build-with-autoconf-2.70.patch | 43 +++++++++++++++++++
> >   1 file changed, 43 insertions(+)
> >   create mode 100644 package/bird/0001-configure.ac-fix-build-with-autoconf-2.70.patch
> >
> > diff --git a/package/bird/0001-configure.ac-fix-build-with-autoconf-2.70.patch b/package/bird/0001-configure.ac-fix-build-with-autoconf-2.70.patch
> > new file mode 100644
> > index 0000000000..b412a55ead
> > --- /dev/null
> > +++ b/package/bird/0001-configure.ac-fix-build-with-autoconf-2.70.patch
> > @@ -0,0 +1,43 @@
> > +From aa5bc6d2e59c5257d777a45ee4a0e0a784c44244 Mon Sep 17 00:00:00 2001
> > +From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> > +Date: Fri, 5 Nov 2021 20:58:41 +0100
> > +Subject: [PATCH] configure.ac: fix build with autoconf >= 2.70
> > +
> > +On some embedded toolchains, glob.h detection fails because -g is
> > +wrongly added (even when CFLAGS is overwritten):
> > +
> > +configure:5881: checking for glob.h
> > +configure:5904: /home/giuliobenetti/autobuild/run/instance-2/output-1/host/bin/mips64el-linux-gcc -o conftest -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64  -Os -g0  -pthread -fno-strict-aliasing -fno-strict-overflow -flto -Wall -Wextra -Wstrict-prototypes -Wno-parentheses -Wno-pointer-sign -Wno-missing-field-initializers -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64  -pthread -flto=4 -g conftest.c  >&5
> > +/home/giuliobenetti/autobuild/run/instance-2/output-1/host/opt/ext-toolchain/bin/../lib/gcc/mips64el-buildroot-linux-uclibc/8.4.0/../../../../mips64el-buildroot-linux-uclibc/bin/ld: /tmp/ccldlED9.ltrans0.ltrans.o:(.debug_info+0x2a): undefined reference to `conftest.c.fb729d13'
> > +/home/giuliobenetti/autobuild/run/instance-2/output-1/host/opt/ext-toolchain/bin/../lib/gcc/mips64el-buildroot-linux-uclibc/8.4.0/../../../../mips64el-buildroot-linux-uclibc/bin/ld: /tmp/ccldlED9.ltrans0.ltrans.o:(.debug_info+0x2f): undefined reference to `conftest.c.fb729d13'
> > +
> > +This build failure is raised since autoconf 2.70 and
> > +https://git.savannah.gnu.org/cgit/autoconf.git/commit/?id=76754e04fce5f6a7701bec57b057020585df2ae3
> > +because ac_test_CFLAGS is now set to ${CFLAGS+y} instead of
> > +${CFLAGS+set}
> > +
> > +Fixes:
> > + - http://autobuild.buildroot.org/results/d7aab7df196e0f6d6389b87ff29da7c2971e6b6d
> > +
> > +Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> > +[Upstream status: sent to bird-users@network.cz]
>
>   Why not create an MR? You can log in to their gitlab with a github account
> (funny that you can't log in with a gitlab.com account...)
I was able to log in with my github account but then I couldn't fork
the project (project limit reached ...). Opening an issue is not
possible either. So I sent in by email.
>
> > +---
> > + configure.ac | 2 +-
> > + 1 file changed, 1 insertion(+), 1 deletion(-)
> > +
> > +diff --git a/configure.ac b/configure.ac
> > +index 64181d29..b4b3fcfb 100644
> > +--- a/configure.ac
> > ++++ b/configure.ac
> > +@@ -114,7 +114,7 @@ AC_SEARCH_LIBS([clock_gettime], [rt posix4],
> > + AC_CANONICAL_HOST
> > +
> > + # Store this value because ac_test_CFLAGS is overwritten by AC_PROG_CC
> > +-if test "$ac_test_CFLAGS" != set ; then
> > ++if ! test $ac_test_CFLAGS ; then
>
>   Wouldn't it be more future-safe to put quotes around $ac_test_CFLAGS?
Why not, I just copy/pasted the change made by autoconf lib/autoconf/c.m4:

-if test "$ac_test_CXXFLAGS" = set; then
+if test $ac_test_CXXFLAGS; then
>
>   Regards,
>   Arnout
>
> > +   bird_cflags_default=yes
> > + fi
> > +
> > +--
> > +2.33.0
> > +
> >
Best Regards,

Fabrice
Thomas Petazzoni Dec. 28, 2021, 2:20 p.m. UTC | #3
Hello Fabrice,

On Fri,  5 Nov 2021 21:12:57 +0100
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> +++ b/package/bird/0001-configure.ac-fix-build-with-autoconf-2.70.patch
> @@ -0,0 +1,43 @@
> +From aa5bc6d2e59c5257d777a45ee4a0e0a784c44244 Mon Sep 17 00:00:00 2001
> +From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> +Date: Fri, 5 Nov 2021 20:58:41 +0100
> +Subject: [PATCH] configure.ac: fix build with autoconf >= 2.70
> +
> +On some embedded toolchains, glob.h detection fails because -g is
> +wrongly added (even when CFLAGS is overwritten):

I fail to understand why adding -g would cause that build failure.
There is already -g0 in the command line, then -g, which enables
debugging symbols, this shouldn't cause any build failure.

Perhaps the issue is more related to the addition of -flto=4, which
enables link-time optimization?

But even then, I don't quite understand this ac_test_CFLAGS stuff. Do
you understand why their configure.ac script is doing:

# Store this value because ac_test_CFLAGS is overwritten by AC_PROG_CC
if test "$ac_test_CFLAGS" != set ; then
  bird_cflags_default=yes
fi

in the first place?

Could you help me connect the dots here ?

Thanks!

Thomas
Thomas Petazzoni Dec. 28, 2021, 2:24 p.m. UTC | #4
On Tue, 28 Dec 2021 15:20:59 +0100
Thomas Petazzoni <thomas.petazzoni@bootlin.com> wrote:

> I fail to understand why adding -g would cause that build failure.
> There is already -g0 in the command line, then -g, which enables
> debugging symbols, this shouldn't cause any build failure.
> 
> Perhaps the issue is more related to the addition of -flto=4, which
> enables link-time optimization?
> 
> But even then, I don't quite understand this ac_test_CFLAGS stuff. Do
> you understand why their configure.ac script is doing:
> 
> # Store this value because ac_test_CFLAGS is overwritten by AC_PROG_CC
> if test "$ac_test_CFLAGS" != set ; then
>   bird_cflags_default=yes
> fi
> 
> in the first place?
> 
> Could you help me connect the dots here ?

Also, I thought we had already fixed this issue with
https://git.buildroot.org/buildroot/commit/package/bird?id=03c148c8dec4e8c3fa13fcde4a730b3ab97f3f10 ?

Thomas
Arnout Vandecappelle July 25, 2022, 7:28 p.m. UTC | #5
On 05/11/2021 21:12, Fabrice Fontaine wrote:
> Fix the following build failure raised since bump of autoconf to version
> 2.71 in commit ecd54b65c1f998a7ccd91f7c523e4ff38c4781da:
> 
> checking for glob.h... no
> configure: error: glob.h not found.
> 
> Fixes:
>   - http://autobuild.buildroot.org/results/d7aab7df196e0f6d6389b87ff29da7c2971e6b6d
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>   ...gure.ac-fix-build-with-autoconf-2.70.patch | 43 +++++++++++++++++++
>   1 file changed, 43 insertions(+)
>   create mode 100644 package/bird/0001-configure.ac-fix-build-with-autoconf-2.70.patch
> 
> diff --git a/package/bird/0001-configure.ac-fix-build-with-autoconf-2.70.patch b/package/bird/0001-configure.ac-fix-build-with-autoconf-2.70.patch
> new file mode 100644
> index 0000000000..b412a55ead
> --- /dev/null
> +++ b/package/bird/0001-configure.ac-fix-build-with-autoconf-2.70.patch
> @@ -0,0 +1,43 @@
> +From aa5bc6d2e59c5257d777a45ee4a0e0a784c44244 Mon Sep 17 00:00:00 2001
> +From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> +Date: Fri, 5 Nov 2021 20:58:41 +0100
> +Subject: [PATCH] configure.ac: fix build with autoconf >= 2.70
> +
> +On some embedded toolchains, glob.h detection fails because -g is
> +wrongly added (even when CFLAGS is overwritten):
> +
> +configure:5881: checking for glob.h
> +configure:5904: /home/giuliobenetti/autobuild/run/instance-2/output-1/host/bin/mips64el-linux-gcc -o conftest -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64  -Os -g0  -pthread -fno-strict-aliasing -fno-strict-overflow -flto -Wall -Wextra -Wstrict-prototypes -Wno-parentheses -Wno-pointer-sign -Wno-missing-field-initializers -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64  -pthread -flto=4 -g conftest.c  >&5
> +/home/giuliobenetti/autobuild/run/instance-2/output-1/host/opt/ext-toolchain/bin/../lib/gcc/mips64el-buildroot-linux-uclibc/8.4.0/../../../../mips64el-buildroot-linux-uclibc/bin/ld: /tmp/ccldlED9.ltrans0.ltrans.o:(.debug_info+0x2a): undefined reference to `conftest.c.fb729d13'
> +/home/giuliobenetti/autobuild/run/instance-2/output-1/host/opt/ext-toolchain/bin/../lib/gcc/mips64el-buildroot-linux-uclibc/8.4.0/../../../../mips64el-buildroot-linux-uclibc/bin/ld: /tmp/ccldlED9.ltrans0.ltrans.o:(.debug_info+0x2f): undefined reference to `conftest.c.fb729d13'

  Since this is involving functions that are generated by LTO, I think it's more 
likely that the issue is triggered by the -flto=4 rather than the -g.

  Also, I saw that it only occurs on GCC8, not on any of the other myriad GCC 
versions that we run in the autobuilders. So it's clearly a compiler bug.

  Regardless, this patch does fix it, so I applied to master, thanks. I largely 
rewrote the commit message (both of the patch and the buildroot commit) and I 
added the quotes that I suggested earlier. I've also added a comment in the .mk 
file to explain the AUTORECONF (just pointing to the patch since the earlier 
reason is no longer valid).

  Perhaps you could do another attempt to send the patch upstream?

  Regards,
  Arnout

> +
> +This build failure is raised since autoconf 2.70 and
> +https://git.savannah.gnu.org/cgit/autoconf.git/commit/?id=76754e04fce5f6a7701bec57b057020585df2ae3
> +because ac_test_CFLAGS is now set to ${CFLAGS+y} instead of
> +${CFLAGS+set}
> +
> +Fixes:
> + - http://autobuild.buildroot.org/results/d7aab7df196e0f6d6389b87ff29da7c2971e6b6d
> +
> +Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> +[Upstream status: sent to bird-users@network.cz]
> +---
> + configure.ac | 2 +-
> + 1 file changed, 1 insertion(+), 1 deletion(-)
> +
> +diff --git a/configure.ac b/configure.ac
> +index 64181d29..b4b3fcfb 100644
> +--- a/configure.ac
> ++++ b/configure.ac
> +@@ -114,7 +114,7 @@ AC_SEARCH_LIBS([clock_gettime], [rt posix4],
> + AC_CANONICAL_HOST
> +
> + # Store this value because ac_test_CFLAGS is overwritten by AC_PROG_CC
> +-if test "$ac_test_CFLAGS" != set ; then
> ++if ! test $ac_test_CFLAGS ; then
> +   bird_cflags_default=yes
> + fi
> +
> +--
> +2.33.0
> +
Peter Korsgaard Aug. 18, 2022, 5:55 a.m. UTC | #6
>>>>> "Arnout" == Arnout Vandecappelle <arnout@mind.be> writes:

Hi,

 > On 05/11/2021 21:12, Fabrice Fontaine wrote:
 >> Fix the following build failure raised since bump of autoconf to version
 >> 2.71 in commit ecd54b65c1f998a7ccd91f7c523e4ff38c4781da:
 >> checking for glob.h... no
 >> configure: error: glob.h not found.
 >> Fixes:
 >> - http://autobuild.buildroot.org/results/d7aab7df196e0f6d6389b87ff29da7c2971e6b6d
 >> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
 >> ---
 >> ...gure.ac-fix-build-with-autoconf-2.70.patch | 43 +++++++++++++++++++
 >> 1 file changed, 43 insertions(+)
 >> create mode 100644 package/bird/0001-configure.ac-fix-build-with-autoconf-2.70.patch
 >> diff --git
 >> a/package/bird/0001-configure.ac-fix-build-with-autoconf-2.70.patch
 >> b/package/bird/0001-configure.ac-fix-build-with-autoconf-2.70.patch
 >> new file mode 100644
 >> index 0000000000..b412a55ead
 >> --- /dev/null
 >> +++ b/package/bird/0001-configure.ac-fix-build-with-autoconf-2.70.patch
 >> @@ -0,0 +1,43 @@
 >> +From aa5bc6d2e59c5257d777a45ee4a0e0a784c44244 Mon Sep 17 00:00:00 2001
 >> +From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
 >> +Date: Fri, 5 Nov 2021 20:58:41 +0100
 >> +Subject: [PATCH] configure.ac: fix build with autoconf >= 2.70
 >> +
 >> +On some embedded toolchains, glob.h detection fails because -g is
 >> +wrongly added (even when CFLAGS is overwritten):
 >> +
 >> +configure:5881: checking for glob.h
 >> +configure:5904:
 >> /home/giuliobenetti/autobuild/run/instance-2/output-1/host/bin/mips64el-linux-gcc
 >> -o conftest -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
 >> -D_FILE_OFFSET_BITS=64 -Os -g0 -pthread -fno-strict-aliasing
 >> -fno-strict-overflow -flto -Wall -Wextra -Wstrict-prototypes
 >> -Wno-parentheses -Wno-pointer-sign -Wno-missing-field-initializers
 >> -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
 >> -pthread -flto=4 -g conftest.c >&5
 >> +/home/giuliobenetti/autobuild/run/instance-2/output-1/host/opt/ext-toolchain/bin/../lib/gcc/mips64el-buildroot-linux-uclibc/8.4.0/../../../../mips64el-buildroot-linux-uclibc/bin/ld:
 >> /tmp/ccldlED9.ltrans0.ltrans.o:(.debug_info+0x2a): undefined
 >> reference to `conftest.c.fb729d13'
 >> +/home/giuliobenetti/autobuild/run/instance-2/output-1/host/opt/ext-toolchain/bin/../lib/gcc/mips64el-buildroot-linux-uclibc/8.4.0/../../../../mips64el-buildroot-linux-uclibc/bin/ld:
 >> /tmp/ccldlED9.ltrans0.ltrans.o:(.debug_info+0x2f): undefined
 >> reference to `conftest.c.fb729d13'

 >  Since this is involving functions that are generated by LTO, I think
 >  it's more likely that the issue is triggered by the -flto=4 rather
 > than the -g.

 >  Also, I saw that it only occurs on GCC8, not on any of the other
 >  myriad GCC versions that we run in the autobuilders. So it's clearly
 > a compiler bug.

 >  Regardless, this patch does fix it, so I applied to master, thanks. I
 >  largely rewrote the commit message (both of the patch and the
 > buildroot commit) and I added the quotes that I suggested
 > earlier. I've also added a comment in the .mk file to explain the
 > AUTORECONF (just pointing to the patch since the earlier reason is no
 > longer valid).

 >  Perhaps you could do another attempt to send the patch upstream?

Committed to 2022.05.x and 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/package/bird/0001-configure.ac-fix-build-with-autoconf-2.70.patch b/package/bird/0001-configure.ac-fix-build-with-autoconf-2.70.patch
new file mode 100644
index 0000000000..b412a55ead
--- /dev/null
+++ b/package/bird/0001-configure.ac-fix-build-with-autoconf-2.70.patch
@@ -0,0 +1,43 @@ 
+From aa5bc6d2e59c5257d777a45ee4a0e0a784c44244 Mon Sep 17 00:00:00 2001
+From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+Date: Fri, 5 Nov 2021 20:58:41 +0100
+Subject: [PATCH] configure.ac: fix build with autoconf >= 2.70
+
+On some embedded toolchains, glob.h detection fails because -g is
+wrongly added (even when CFLAGS is overwritten):
+
+configure:5881: checking for glob.h
+configure:5904: /home/giuliobenetti/autobuild/run/instance-2/output-1/host/bin/mips64el-linux-gcc -o conftest -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64  -Os -g0  -pthread -fno-strict-aliasing -fno-strict-overflow -flto -Wall -Wextra -Wstrict-prototypes -Wno-parentheses -Wno-pointer-sign -Wno-missing-field-initializers -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64  -pthread -flto=4 -g conftest.c  >&5
+/home/giuliobenetti/autobuild/run/instance-2/output-1/host/opt/ext-toolchain/bin/../lib/gcc/mips64el-buildroot-linux-uclibc/8.4.0/../../../../mips64el-buildroot-linux-uclibc/bin/ld: /tmp/ccldlED9.ltrans0.ltrans.o:(.debug_info+0x2a): undefined reference to `conftest.c.fb729d13'
+/home/giuliobenetti/autobuild/run/instance-2/output-1/host/opt/ext-toolchain/bin/../lib/gcc/mips64el-buildroot-linux-uclibc/8.4.0/../../../../mips64el-buildroot-linux-uclibc/bin/ld: /tmp/ccldlED9.ltrans0.ltrans.o:(.debug_info+0x2f): undefined reference to `conftest.c.fb729d13'
+
+This build failure is raised since autoconf 2.70 and
+https://git.savannah.gnu.org/cgit/autoconf.git/commit/?id=76754e04fce5f6a7701bec57b057020585df2ae3
+because ac_test_CFLAGS is now set to ${CFLAGS+y} instead of
+${CFLAGS+set}
+
+Fixes:
+ - http://autobuild.buildroot.org/results/d7aab7df196e0f6d6389b87ff29da7c2971e6b6d
+
+Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+[Upstream status: sent to bird-users@network.cz]
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 64181d29..b4b3fcfb 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -114,7 +114,7 @@ AC_SEARCH_LIBS([clock_gettime], [rt posix4],
+ AC_CANONICAL_HOST
+ 
+ # Store this value because ac_test_CFLAGS is overwritten by AC_PROG_CC
+-if test "$ac_test_CFLAGS" != set ; then
++if ! test $ac_test_CFLAGS ; then
+   bird_cflags_default=yes
+ fi
+ 
+-- 
+2.33.0
+