diff mbox series

[vRFC,3/4] package/libpeas: new package

Message ID 20211104003607.2022984-4-aduskett@gmail.com
State Accepted
Headers show
Series package/midori: bump to version 9.0 | expand

Commit Message

Adam Duskett Nov. 4, 2021, 12:36 a.m. UTC
midori 9.0 requires libpeas.

Signed-off-by: Adam Duskett <aduskett@gmail.com>
---
 package/Config.in            |  1 +
 package/libpeas/Config.in    | 45 ++++++++++++++++++++++++++++++++++++
 package/libpeas/libpeas.hash |  4 ++++
 package/libpeas/libpeas.mk   | 38 ++++++++++++++++++++++++++++++
 4 files changed, 88 insertions(+)
 create mode 100644 package/libpeas/Config.in
 create mode 100644 package/libpeas/libpeas.hash
 create mode 100644 package/libpeas/libpeas.mk

Comments

Arnout Vandecappelle Nov. 22, 2021, 10:16 p.m. UTC | #1
On 04/11/2021 01:36, Adam Duskett wrote:
> midori 9.0 requires libpeas.
> 
> Signed-off-by: Adam Duskett <aduskett@gmail.com>
> ---
>   package/Config.in            |  1 +
>   package/libpeas/Config.in    | 45 ++++++++++++++++++++++++++++++++++++
>   package/libpeas/libpeas.hash |  4 ++++
>   package/libpeas/libpeas.mk   | 38 ++++++++++++++++++++++++++++++
>   4 files changed, 88 insertions(+)
>   create mode 100644 package/libpeas/Config.in
>   create mode 100644 package/libpeas/libpeas.hash
>   create mode 100644 package/libpeas/libpeas.mk
> 
> diff --git a/package/Config.in b/package/Config.in
> index c23755a421..0e2cc78d85 100644
> --- a/package/Config.in
> +++ b/package/Config.in
> @@ -1957,6 +1957,7 @@ menu "Other"
>   	source "package/libnpth/Config.in"
>   	source "package/libnspr/Config.in"
>   	source "package/libosmium/Config.in"
> +	source "package/libpeas/Config.in"
>   	source "package/libpfm4/Config.in"
>   	source "package/libplatform/Config.in"
>   	source "package/libplist/Config.in"
> diff --git a/package/libpeas/Config.in b/package/libpeas/Config.in
> new file mode 100644
> index 0000000000..430e668ee7
> --- /dev/null
> +++ b/package/libpeas/Config.in
> @@ -0,0 +1,45 @@
> +config BR2_PACKAGE_LIBPEAS
> +	bool "libpeas"
> +	depends on BR2_USE_MMU # gobject-introspection
> +	depends on BR2_PACKAGE_GOBJECT_INTROSPECTION_ARCH_SUPPORTS
> +	depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 # gobject-introspection
> +	depends on BR2_HOST_GCC_AT_LEAST_8 # gobject-introspection -> host-qemu
> +	depends on BR2_TOOLCHAIN_USES_GLIBC # gobject-introspection
> +	depends on BR2_PACKAGE_PYTHON3 # gobject-introspection
> +	select BR2_PACKAGE_GOBJECT_INTROSPECTION
> +	select BR2_PACKAGE_LIBGLIB2
> +	help
> +	  libpeas is a gobject-based plugins engine, and is targetted at
> +	  giving every application the chance to assume its own
> +	  extensibility. It also has a set of features including, but
> +	  not limited to:
> +	    - multiple extension points
> +	    - On demand (lazy) programming language support for C,
> +	      Python and Lua
> +	    - Simplicity of the API
> +
> +	  https://wiki.gnome.org/Projects/Libpeas
> +
> +if BR2_PACKAGE_LIBPEAS
> +
> +config BR2_PACKAGE_LIBPEAS_WIDGETS
> +	bool "widgets"
> +	depends on BR2_PACKAGE_LIBGTK3
> +	help
> +	  Build GTK+ widgetry
> +
> +comment "widget support needs libgtk3"
> +	depends on !BR2_PACKAGE_LIBGTK3
> +
> +endif
> +
> +comment "libpeas needs python3"
> +	depends on BR2_PACKAGE_GOBJECT_INTROSPECTION_ARCH_SUPPORTS
> +	depends on BR2_USE_MMU
> +	depends on !BR2_PACKAGE_PYTHON3
> +
> +comment "libpeas needs a glibc toolchain, gcc >= 4.9, host gcc >= 8"
> +	depends on BR2_PACKAGE_GOBJECT_INTROSPECTION_ARCH_SUPPORTS
> +	depends on BR2_USE_MMU
> +	depends on !BR2_TOOLCHAIN_USES_GLIBC || \
> +		!BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 || !BR2_HOST_GCC_AT_LEAST_8
> diff --git a/package/libpeas/libpeas.hash b/package/libpeas/libpeas.hash
> new file mode 100644
> index 0000000000..2b030c01c5
> --- /dev/null
> +++ b/package/libpeas/libpeas.hash
> @@ -0,0 +1,4 @@
> +# From https://ftp.gnome.org/pub/GNOME/sources/libpeas/1.30/libpeas-1.30.0.sha256sum
> +sha256  0bf5562e9bfc0382a9dcb81f64340787542568762a3a367d9d90f6185898b9a3  libpeas-1.30.0.tar.xz
> +# Locally calculated
> +sha256  592987e8510228d546540b84a22444bde98e48d03078d3b2eefcd889bec5ce8c  COPYING
> diff --git a/package/libpeas/libpeas.mk b/package/libpeas/libpeas.mk
> new file mode 100644
> index 0000000000..4f1ab1216a
> --- /dev/null
> +++ b/package/libpeas/libpeas.mk
> @@ -0,0 +1,38 @@
> +################################################################################
> +#
> +# libpeas
> +#
> +################################################################################
> +
> +LIBPEAS_VERSION_MAJOR = 1.30
> +LIBPEAS_VERSION = $(LIBPEAS_VERSION_MAJOR).0
> +LIBPEAS_SOURCE = libpeas-$(LIBPEAS_VERSION).tar.xz
> +LIBPEAS_SITE = http://ftp.gnome.org/pub/gnome/sources/libpeas/$(LIBPEAS_VERSION_MAJOR)
> +LIBPEAS_LICENSE = LGPL-2.1+
> +LIBPEAS_LICENSE_FILES = COPYING
> +LIBPEAS_CPE_ID_VENDOR = gnome
> +LIBPEAS_INSTALL_STAGING = YES
> +LIBPEAS_DEPENDENCIES = \
> +	host-libglib2 \
> +	host-pkgconf \
> +	gobject-introspection \
> +	libglib2 \
> +	$(TARGET_NLS_DEPENDENCIES)
> +
> +LIBPEAS_LDFLAGS = $(TARGET_LDFLAGS) $(TARGET_NLS_LIBS)
> +
> +LIBPEAS_CONF_OPTS = \
> +	-Ddemos=false \
> +	-Dglade_catalog=false \
> +	-Dintrospection=true \
> +	-Dlua51=false \

  I've also explicitly disabled python2 and python3, and added a comment in the 
commit message that this is because they're not tested.

  I noticed that even before that change, the python3 loader wasn't built. Weird.


  Applied to next, thanks.

  Regards,
  Arnout

> +	-Dvapi=false
> +
> +ifeq ($(BR2_PACKAGE_LIBPEAS_WIDGETS),y)
> +LIBPEAS_DEPENDENCIES += libgtk3
> +LIBPEAS_CONF_OPTS += -Dwidgetry=true
> +else
> +LIBPEAS_CONF_OPTS += -Dwidgetry=false
> +endif
> +
> +$(eval $(meson-package))
>
diff mbox series

Patch

diff --git a/package/Config.in b/package/Config.in
index c23755a421..0e2cc78d85 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -1957,6 +1957,7 @@  menu "Other"
 	source "package/libnpth/Config.in"
 	source "package/libnspr/Config.in"
 	source "package/libosmium/Config.in"
+	source "package/libpeas/Config.in"
 	source "package/libpfm4/Config.in"
 	source "package/libplatform/Config.in"
 	source "package/libplist/Config.in"
diff --git a/package/libpeas/Config.in b/package/libpeas/Config.in
new file mode 100644
index 0000000000..430e668ee7
--- /dev/null
+++ b/package/libpeas/Config.in
@@ -0,0 +1,45 @@ 
+config BR2_PACKAGE_LIBPEAS
+	bool "libpeas"
+	depends on BR2_USE_MMU # gobject-introspection
+	depends on BR2_PACKAGE_GOBJECT_INTROSPECTION_ARCH_SUPPORTS
+	depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 # gobject-introspection
+	depends on BR2_HOST_GCC_AT_LEAST_8 # gobject-introspection -> host-qemu
+	depends on BR2_TOOLCHAIN_USES_GLIBC # gobject-introspection
+	depends on BR2_PACKAGE_PYTHON3 # gobject-introspection
+	select BR2_PACKAGE_GOBJECT_INTROSPECTION
+	select BR2_PACKAGE_LIBGLIB2
+	help
+	  libpeas is a gobject-based plugins engine, and is targetted at
+	  giving every application the chance to assume its own
+	  extensibility. It also has a set of features including, but
+	  not limited to:
+	    - multiple extension points
+	    - On demand (lazy) programming language support for C,
+	      Python and Lua
+	    - Simplicity of the API
+
+	  https://wiki.gnome.org/Projects/Libpeas
+
+if BR2_PACKAGE_LIBPEAS
+
+config BR2_PACKAGE_LIBPEAS_WIDGETS
+	bool "widgets"
+	depends on BR2_PACKAGE_LIBGTK3
+	help
+	  Build GTK+ widgetry
+
+comment "widget support needs libgtk3"
+	depends on !BR2_PACKAGE_LIBGTK3
+
+endif
+
+comment "libpeas needs python3"
+	depends on BR2_PACKAGE_GOBJECT_INTROSPECTION_ARCH_SUPPORTS
+	depends on BR2_USE_MMU
+	depends on !BR2_PACKAGE_PYTHON3
+
+comment "libpeas needs a glibc toolchain, gcc >= 4.9, host gcc >= 8"
+	depends on BR2_PACKAGE_GOBJECT_INTROSPECTION_ARCH_SUPPORTS
+	depends on BR2_USE_MMU
+	depends on !BR2_TOOLCHAIN_USES_GLIBC || \
+		!BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 || !BR2_HOST_GCC_AT_LEAST_8
diff --git a/package/libpeas/libpeas.hash b/package/libpeas/libpeas.hash
new file mode 100644
index 0000000000..2b030c01c5
--- /dev/null
+++ b/package/libpeas/libpeas.hash
@@ -0,0 +1,4 @@ 
+# From https://ftp.gnome.org/pub/GNOME/sources/libpeas/1.30/libpeas-1.30.0.sha256sum
+sha256  0bf5562e9bfc0382a9dcb81f64340787542568762a3a367d9d90f6185898b9a3  libpeas-1.30.0.tar.xz
+# Locally calculated
+sha256  592987e8510228d546540b84a22444bde98e48d03078d3b2eefcd889bec5ce8c  COPYING
diff --git a/package/libpeas/libpeas.mk b/package/libpeas/libpeas.mk
new file mode 100644
index 0000000000..4f1ab1216a
--- /dev/null
+++ b/package/libpeas/libpeas.mk
@@ -0,0 +1,38 @@ 
+################################################################################
+#
+# libpeas
+#
+################################################################################
+
+LIBPEAS_VERSION_MAJOR = 1.30
+LIBPEAS_VERSION = $(LIBPEAS_VERSION_MAJOR).0
+LIBPEAS_SOURCE = libpeas-$(LIBPEAS_VERSION).tar.xz
+LIBPEAS_SITE = http://ftp.gnome.org/pub/gnome/sources/libpeas/$(LIBPEAS_VERSION_MAJOR)
+LIBPEAS_LICENSE = LGPL-2.1+
+LIBPEAS_LICENSE_FILES = COPYING
+LIBPEAS_CPE_ID_VENDOR = gnome
+LIBPEAS_INSTALL_STAGING = YES
+LIBPEAS_DEPENDENCIES = \
+	host-libglib2 \
+	host-pkgconf \
+	gobject-introspection \
+	libglib2 \
+	$(TARGET_NLS_DEPENDENCIES)
+
+LIBPEAS_LDFLAGS = $(TARGET_LDFLAGS) $(TARGET_NLS_LIBS)
+
+LIBPEAS_CONF_OPTS = \
+	-Ddemos=false \
+	-Dglade_catalog=false \
+	-Dintrospection=true \
+	-Dlua51=false \
+	-Dvapi=false
+
+ifeq ($(BR2_PACKAGE_LIBPEAS_WIDGETS),y)
+LIBPEAS_DEPENDENCIES += libgtk3
+LIBPEAS_CONF_OPTS += -Dwidgetry=true
+else
+LIBPEAS_CONF_OPTS += -Dwidgetry=false
+endif
+
+$(eval $(meson-package))