diff mbox series

package/fastd: bump version to 22

Message ID 20211017152511.32136-1-post@lespocky.de
State Accepted
Headers show
Series package/fastd: bump version to 22 | expand

Commit Message

Alexander Dahl Oct. 17, 2021, 3:25 p.m. UTC
There's a new feature to offload L2TP to the Linux kernel, which depends
on libmnl.  A new menu option was introduced for that.

It's possible to link an internal version of libmnl
statically for smaller binary size on constraint targets, but this was
not added to the buildroot package for complexity reasons (both build
and licensing).

The COPYING file gained an additional paragraph for internal libmnl
which does not apply, because internal libmnl is not used in the
package.

Link: https://fastd.readthedocs.io/en/latest/releases/v22.html
Signed-off-by: Alexander Dahl <post@lespocky.de>
---
 package/fastd/Config.in  | 8 ++++++++
 package/fastd/fastd.hash | 4 ++--
 package/fastd/fastd.mk   | 9 ++++++++-
 3 files changed, 18 insertions(+), 3 deletions(-)


base-commit: 55ae6b59d48dd75f4e432b63e5b8a4655b76305c

Comments

Thomas Petazzoni Oct. 18, 2021, 7:22 p.m. UTC | #1
On Sun, 17 Oct 2021 17:25:11 +0200
Alexander Dahl <post@lespocky.de> wrote:

> There's a new feature to offload L2TP to the Linux kernel, which depends
> on libmnl.  A new menu option was introduced for that.
> 
> It's possible to link an internal version of libmnl
> statically for smaller binary size on constraint targets, but this was
> not added to the buildroot package for complexity reasons (both build
> and licensing).
> 
> The COPYING file gained an additional paragraph for internal libmnl
> which does not apply, because internal libmnl is not used in the
> package.

Thanks for providing this explanation, very good!

> +config BR2_PACKAGE_FASTD_OFFLOAD_L2TP
> +	bool "l2tp offload support"
> +	default y

I don't think there was much reason for this option to be enabled by
default, and we try to not enable optional features by default in
Buildroot, so I dropped this "default y" when applying.

Applied to master this change. Thanks!

Best regards,

Thomas
diff mbox series

Patch

diff --git a/package/fastd/Config.in b/package/fastd/Config.in
index 5319d68503..0214786470 100644
--- a/package/fastd/Config.in
+++ b/package/fastd/Config.in
@@ -21,6 +21,14 @@  config BR2_PACKAGE_FASTD_STATUS_SOCKET
 	help
 	  Enable support for a socket to get fastd's status.
 
+config BR2_PACKAGE_FASTD_OFFLOAD_L2TP
+	bool "l2tp offload support"
+	default y
+	select BR2_PACKAGE_LIBMNL
+	help
+	  L2TP can be offloaded to the Linux kernel, significantly
+	  increasing throughput.
+
 endif
 
 comment "fastd needs a toolchain w/ threads, dynamic library"
diff --git a/package/fastd/fastd.hash b/package/fastd/fastd.hash
index b59085e0ee..5f7f966533 100644
--- a/package/fastd/fastd.hash
+++ b/package/fastd/fastd.hash
@@ -1,3 +1,3 @@ 
 # computed locally
-sha256  942f33bcd794bcb8e19da4c30c875bdfd4d0f1c24ec4dcdf51237791bbfb0d4c  fastd-21.tar.xz
-sha256  1f5acece57466eac89108f934a196be09b7676fa2d637e78d6657ee1a7d644ac  COPYRIGHT
+sha256  19750b88705d66811b7c21b672537909c19ae6b21350688cbd1a3a54d08a8951  fastd-22.tar.xz
+sha256  adf08b42f1b890b89e998360a864cb4f8441a0a57c9e95e2ce1bfdfc24c49976  COPYRIGHT
diff --git a/package/fastd/fastd.mk b/package/fastd/fastd.mk
index c1db1cc472..5cd6a909c3 100644
--- a/package/fastd/fastd.mk
+++ b/package/fastd/fastd.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-FASTD_VERSION = 21
+FASTD_VERSION = 22
 FASTD_SITE = https://github.com/NeoRaider/fastd/releases/download/v$(FASTD_VERSION)
 FASTD_SOURCE = fastd-$(FASTD_VERSION).tar.xz
 FASTD_LICENSE = BSD-2-Clause
@@ -33,6 +33,13 @@  else
 FASTD_CONF_OPTS += -Dstatus_socket=disabled
 endif
 
+ifeq ($(BR2_PACKAGE_FASTD_OFFLOAD_L2TP),y)
+FASTD_CONF_OPTS += -Doffload_l2tp=enabled -Dlibmnl_builtin=false
+FASTD_DEPENDENCIES += libmnl
+else
+FASTD_CONF_OPTS += -Doffload_l2tp=disabled
+endif
+
 ifeq ($(BR2_INIT_SYSTEMD),y)
 FASTD_CONF_OPTS += -Dsystemd=enabled
 else