diff mbox series

[1/1] package/tinydtls: fix build with automake >= 1.16.4

Message ID 20211013184307.1869426-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/tinydtls: fix build with automake >= 1.16.4 | expand

Commit Message

Fabrice Fontaine Oct. 13, 2021, 6:43 p.m. UTC
Touch ar-lib as suggested by upstream in
https://github.com/eclipse/tinydtls/pull/103 and
https://github.com/eclipse/tinydtls/commit/5c6fd178e83cec7ccc40ac3ab13a15ce611da8a8
to avoid the following build failure since bump of automake to version
1.16.4 in commit fe90272b5128987ee7492fff950660e05324838d:

configure.ac: error: required file 'ar-lib' not found

Fixes:
 - http://autobuild.buildroot.org/results/fa23cdf0d454c2ad11af3cdcc2810cd442918667

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/tinydtls/tinydtls.mk | 6 ++++++
 1 file changed, 6 insertions(+)
diff mbox series

Patch

diff --git a/package/tinydtls/tinydtls.mk b/package/tinydtls/tinydtls.mk
index 6d839bc05a..bba9e5f6fa 100644
--- a/package/tinydtls/tinydtls.mk
+++ b/package/tinydtls/tinydtls.mk
@@ -16,4 +16,10 @@  TINYDTLS_AUTORECONF = YES
 # use inttypes.h data types instead of u_intXX_t for musl compatibility
 TINYDTLS_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -DSHA2_USE_INTTYPES_H"
 
+# Fix build with automake >= 1.16.4
+define TINYDTLS_TOUCH_AR_LIB
+	touch $(@D)/ar-lib
+endef
+TINYDTLS_PRE_CONFIGURE_HOOKS += TINYDTLS_TOUCH_AR_LIB
+
 $(eval $(autotools-package))