diff mbox series

package/mesa3d: remove unnecessary passing of CFLAGS

Message ID 20211004203535.923467-1-giulio.benetti@benettiengineering.com
State Accepted
Headers show
Series package/mesa3d: remove unnecessary passing of CFLAGS | expand

Commit Message

Giulio Benetti Oct. 4, 2021, 8:35 p.m. UTC
This package uses meson-package infrastracture, so we don't need to
explicitly pass its additional CFLAGS to some variable. The only thing we
need to pass them is to use MESA3D_CFLAGS, because in package/pkg-meson.mk
we have:
$(2)_CFLAGS ?= $$(TARGET_CFLAGS)
that makes the work automatically, where $(2) is exactly the package name,
though $(2)_CFLAGS expands to MESA3D_CFLAGS.
So let's remove the MESA3D_CONF_OPTS += -DCMAKE_C_FLAGS="$(MESA3D_CFLAGS)"
line that has been added by mistake.

Note: this doesn't fix any bug, but remove an unnecessary and ambiguos line

Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
---
 package/mesa3d/mesa3d.mk | 2 --
 1 file changed, 2 deletions(-)

Comments

Peter Korsgaard Oct. 7, 2021, 8:13 p.m. UTC | #1
>>>>> "Giulio" == Giulio Benetti <giulio.benetti@benettiengineering.com> writes:

 > This package uses meson-package infrastracture, so we don't need to
 > explicitly pass its additional CFLAGS to some variable. The only thing we
 > need to pass them is to use MESA3D_CFLAGS, because in package/pkg-meson.mk
 > we have:
 > $(2)_CFLAGS ?= $$(TARGET_CFLAGS)
 > that makes the work automatically, where $(2) is exactly the package name,
 > though $(2)_CFLAGS expands to MESA3D_CFLAGS.
 > So let's remove the MESA3D_CONF_OPTS += -DCMAKE_C_FLAGS="$(MESA3D_CFLAGS)"
 > line that has been added by mistake.

 > Note: this doesn't fix any bug, but remove an unnecessary and ambiguos line

 > Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>

Committed, thanks.
Peter Korsgaard Oct. 9, 2021, 11:46 a.m. UTC | #2
>>>>> "Giulio" == Giulio Benetti <giulio.benetti@benettiengineering.com> writes:

 > This package uses meson-package infrastracture, so we don't need to
 > explicitly pass its additional CFLAGS to some variable. The only thing we
 > need to pass them is to use MESA3D_CFLAGS, because in package/pkg-meson.mk
 > we have:
 > $(2)_CFLAGS ?= $$(TARGET_CFLAGS)
 > that makes the work automatically, where $(2) is exactly the package name,
 > though $(2)_CFLAGS expands to MESA3D_CFLAGS.
 > So let's remove the MESA3D_CONF_OPTS += -DCMAKE_C_FLAGS="$(MESA3D_CFLAGS)"
 > line that has been added by mistake.

 > Note: this doesn't fix any bug, but remove an unnecessary and ambiguos line

 > Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>

Committed to 2021.02.x, 2021.05.x and 2021.08.x, thanks (together with
'package/mesa3d: fix build on m68k').
diff mbox series

Patch

diff --git a/package/mesa3d/mesa3d.mk b/package/mesa3d/mesa3d.mk
index f1862aed69..dc63d8c9f4 100644
--- a/package/mesa3d/mesa3d.mk
+++ b/package/mesa3d/mesa3d.mk
@@ -266,6 +266,4 @@  ifeq ($(BR2_m68k),y)
 MESA3D_CFLAGS += -mlong-jump-table-offsets
 endif
 
-MESA3D_CONF_OPTS += -DCMAKE_C_FLAGS="$(MESA3D_CFLAGS)"
-
 $(eval $(meson-package))