diff mbox series

[1/1] package/python-prompt-toolkit: bump to version 3.0.20

Message ID 20210928110212.596939-4-asafka7@gmail.com
State Accepted
Headers show
Series [1/1] package/python-prompt-toolkit: bump to version 3.0.20 | expand

Commit Message

Asaf Kahlon Sept. 28, 2021, 11:02 a.m. UTC
* The package doesn't support python2 anymore.
* Update URL in Config.in.
* Indent with two spaces in the hash file.

Signed-off-by: Asaf Kahlon <asafka7@gmail.com>
---
 package/python-prompt-toolkit/Config.in                  | 5 ++---
 package/python-prompt-toolkit/python-prompt-toolkit.hash | 6 +++---
 package/python-prompt-toolkit/python-prompt-toolkit.mk   | 4 ++--
 3 files changed, 7 insertions(+), 8 deletions(-)

Comments

Yann E. MORIN Oct. 3, 2021, 7:59 p.m. UTC | #1
Asaf, All

On 2021-09-28 14:02 +0300, Asaf Kahlon spake thusly:
> * The package doesn't support python2 anymore.

You forgot to add the proper "depends on BR2_PACKAGE_PYTHON3", so I've
done that.

I've also added a note about the reverse dependency, ipython, which
already depends on python3.

Applied to master, thanks.

Regards,
Yann E. MORIN.

> * Update URL in Config.in.
> * Indent with two spaces in the hash file.
> 
> Signed-off-by: Asaf Kahlon <asafka7@gmail.com>
> ---
>  package/python-prompt-toolkit/Config.in                  | 5 ++---
>  package/python-prompt-toolkit/python-prompt-toolkit.hash | 6 +++---
>  package/python-prompt-toolkit/python-prompt-toolkit.mk   | 4 ++--
>  3 files changed, 7 insertions(+), 8 deletions(-)
> 
> diff --git a/package/python-prompt-toolkit/Config.in b/package/python-prompt-toolkit/Config.in
> index 1066e166d9..ad4f8162de 100644
> --- a/package/python-prompt-toolkit/Config.in
> +++ b/package/python-prompt-toolkit/Config.in
> @@ -2,10 +2,9 @@ config BR2_PACKAGE_PYTHON_PROMPT_TOOLKIT
>  	bool "python-prompt-toolkit"
>  	select BR2_PACKAGE_PYTHON_SIX # runtime
>  	select BR2_PACKAGE_PYTHON_WCWIDTH # runtime
> -	select BR2_PACKAGE_PYTHON_PYEXPAT if BR2_PACKAGE_PYTHON # runtime
> -	select BR2_PACKAGE_PYTHON3_PYEXPAT if BR2_PACKAGE_PYTHON3 # runtime
> +	select BR2_PACKAGE_PYTHON3_PYEXPAT # runtime
>  	help
>  	  Library for building powerful interactive command lines in
>  	  Python.
>  
> -	  https://github.com/jonathanslenders/python-prompt-toolkit
> +	  https://github.com/prompt-toolkit/python-prompt-toolkit
> diff --git a/package/python-prompt-toolkit/python-prompt-toolkit.hash b/package/python-prompt-toolkit/python-prompt-toolkit.hash
> index 2d0c7ec95e..5a24634a56 100644
> --- a/package/python-prompt-toolkit/python-prompt-toolkit.hash
> +++ b/package/python-prompt-toolkit/python-prompt-toolkit.hash
> @@ -1,5 +1,5 @@
>  # md5, sha256 from https://pypi.org/pypi/prompt-toolkit/json
> -md5	5016c523e603cd7119644fbc0f00ce53  prompt_toolkit-2.0.10.tar.gz
> -sha256	f15af68f66e664eaa559d4ac8a928111eebd5feda0c11738b5998045224829db  prompt_toolkit-2.0.10.tar.gz
> +md5  ba9e63c3e7e5a4f4ce4e4770a4daba96  prompt_toolkit-3.0.20.tar.gz
> +sha256  eb71d5a6b72ce6db177af4a7d4d7085b99756bf656d98ffcc4fecd36850eea6c  prompt_toolkit-3.0.20.tar.gz
>  # Locally computed sha256 checksums
> -sha256	303574d9bdd85c757d6025017942bf17baeedf2778f62bd7f425d07d880f4c4a  LICENSE
> +sha256  303574d9bdd85c757d6025017942bf17baeedf2778f62bd7f425d07d880f4c4a  LICENSE
> diff --git a/package/python-prompt-toolkit/python-prompt-toolkit.mk b/package/python-prompt-toolkit/python-prompt-toolkit.mk
> index 183c7d258b..b575783f96 100644
> --- a/package/python-prompt-toolkit/python-prompt-toolkit.mk
> +++ b/package/python-prompt-toolkit/python-prompt-toolkit.mk
> @@ -4,9 +4,9 @@
>  #
>  ################################################################################
>  
> -PYTHON_PROMPT_TOOLKIT_VERSION = 2.0.10
> +PYTHON_PROMPT_TOOLKIT_VERSION = 3.0.20
>  PYTHON_PROMPT_TOOLKIT_SOURCE = prompt_toolkit-$(PYTHON_PROMPT_TOOLKIT_VERSION).tar.gz
> -PYTHON_PROMPT_TOOLKIT_SITE = https://files.pythonhosted.org/packages/0c/37/7ad3bf3c6dbe96facf9927ddf066fdafa0f86766237cff32c3c7355d3b7c
> +PYTHON_PROMPT_TOOLKIT_SITE = https://files.pythonhosted.org/packages/b4/56/9ab5868f34ab2657fba7e2192f41316252ab04edbbeb2a8583759960a1a7
>  PYTHON_PROMPT_TOOLKIT_SETUP_TYPE = setuptools
>  PYTHON_PROMPT_TOOLKIT_LICENSE = BSD-3-Clause
>  PYTHON_PROMPT_TOOLKIT_LICENSE_FILES = LICENSE
> -- 
> 2.33.0
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/python-prompt-toolkit/Config.in b/package/python-prompt-toolkit/Config.in
index 1066e166d9..ad4f8162de 100644
--- a/package/python-prompt-toolkit/Config.in
+++ b/package/python-prompt-toolkit/Config.in
@@ -2,10 +2,9 @@  config BR2_PACKAGE_PYTHON_PROMPT_TOOLKIT
 	bool "python-prompt-toolkit"
 	select BR2_PACKAGE_PYTHON_SIX # runtime
 	select BR2_PACKAGE_PYTHON_WCWIDTH # runtime
-	select BR2_PACKAGE_PYTHON_PYEXPAT if BR2_PACKAGE_PYTHON # runtime
-	select BR2_PACKAGE_PYTHON3_PYEXPAT if BR2_PACKAGE_PYTHON3 # runtime
+	select BR2_PACKAGE_PYTHON3_PYEXPAT # runtime
 	help
 	  Library for building powerful interactive command lines in
 	  Python.
 
-	  https://github.com/jonathanslenders/python-prompt-toolkit
+	  https://github.com/prompt-toolkit/python-prompt-toolkit
diff --git a/package/python-prompt-toolkit/python-prompt-toolkit.hash b/package/python-prompt-toolkit/python-prompt-toolkit.hash
index 2d0c7ec95e..5a24634a56 100644
--- a/package/python-prompt-toolkit/python-prompt-toolkit.hash
+++ b/package/python-prompt-toolkit/python-prompt-toolkit.hash
@@ -1,5 +1,5 @@ 
 # md5, sha256 from https://pypi.org/pypi/prompt-toolkit/json
-md5	5016c523e603cd7119644fbc0f00ce53  prompt_toolkit-2.0.10.tar.gz
-sha256	f15af68f66e664eaa559d4ac8a928111eebd5feda0c11738b5998045224829db  prompt_toolkit-2.0.10.tar.gz
+md5  ba9e63c3e7e5a4f4ce4e4770a4daba96  prompt_toolkit-3.0.20.tar.gz
+sha256  eb71d5a6b72ce6db177af4a7d4d7085b99756bf656d98ffcc4fecd36850eea6c  prompt_toolkit-3.0.20.tar.gz
 # Locally computed sha256 checksums
-sha256	303574d9bdd85c757d6025017942bf17baeedf2778f62bd7f425d07d880f4c4a  LICENSE
+sha256  303574d9bdd85c757d6025017942bf17baeedf2778f62bd7f425d07d880f4c4a  LICENSE
diff --git a/package/python-prompt-toolkit/python-prompt-toolkit.mk b/package/python-prompt-toolkit/python-prompt-toolkit.mk
index 183c7d258b..b575783f96 100644
--- a/package/python-prompt-toolkit/python-prompt-toolkit.mk
+++ b/package/python-prompt-toolkit/python-prompt-toolkit.mk
@@ -4,9 +4,9 @@ 
 #
 ################################################################################
 
-PYTHON_PROMPT_TOOLKIT_VERSION = 2.0.10
+PYTHON_PROMPT_TOOLKIT_VERSION = 3.0.20
 PYTHON_PROMPT_TOOLKIT_SOURCE = prompt_toolkit-$(PYTHON_PROMPT_TOOLKIT_VERSION).tar.gz
-PYTHON_PROMPT_TOOLKIT_SITE = https://files.pythonhosted.org/packages/0c/37/7ad3bf3c6dbe96facf9927ddf066fdafa0f86766237cff32c3c7355d3b7c
+PYTHON_PROMPT_TOOLKIT_SITE = https://files.pythonhosted.org/packages/b4/56/9ab5868f34ab2657fba7e2192f41316252ab04edbbeb2a8583759960a1a7
 PYTHON_PROMPT_TOOLKIT_SETUP_TYPE = setuptools
 PYTHON_PROMPT_TOOLKIT_LICENSE = BSD-3-Clause
 PYTHON_PROMPT_TOOLKIT_LICENSE_FILES = LICENSE