diff mbox series

package/refpolicy: make sure xmllint is used

Message ID 20210923092136.141553-1-atenart@kernel.org
State Accepted
Headers show
Series package/refpolicy: make sure xmllint is used | expand

Commit Message

Antoine Tenart Sept. 23, 2021, 9:21 a.m. UTC
When parsing and adding modules the refpolicy build system checks their
validity using xmllint. By default the host system version is used and
if not found an error is displayed but the build is not stopped. This
leads to interesting issues where modules are not added correctly to
modules.conf[1] (other possible issues are likely).

Fix this by adding a dependency on host-libxml2 and explicitly use the
xmllint binary built by Buildroot.

[1] https://lore.kernel.org/buildroot/20210830114531.2285178-1-jose.pekkarinen@unikie.com/

Tested-by: José Pekkarinen <jose.pekkarinen@unikie.com>
Signed-off-by: Antoine Tenart <atenart@kernel.org>
---
 package/refpolicy/refpolicy.mk | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

Peter Korsgaard Oct. 6, 2021, 2:32 p.m. UTC | #1
>>>>> "Antoine" == Antoine Tenart <atenart@kernel.org> writes:

 > When parsing and adding modules the refpolicy build system checks their
 > validity using xmllint. By default the host system version is used and
 > if not found an error is displayed but the build is not stopped. This
 > leads to interesting issues where modules are not added correctly to
 > modules.conf[1] (other possible issues are likely).

 > Fix this by adding a dependency on host-libxml2 and explicitly use the
 > xmllint binary built by Buildroot.

 > [1] https://lore.kernel.org/buildroot/20210830114531.2285178-1-jose.pekkarinen@unikie.com/

 > Tested-by: José Pekkarinen <jose.pekkarinen@unikie.com>
 > Signed-off-by: Antoine Tenart <atenart@kernel.org>

Committed to 2021.02.x, 2021.05.x and 2021.08.x, thanks.
diff mbox series

Patch

diff --git a/package/refpolicy/refpolicy.mk b/package/refpolicy/refpolicy.mk
index eb345d0f98c9..975c3b584c42 100644
--- a/package/refpolicy/refpolicy.mk
+++ b/package/refpolicy/refpolicy.mk
@@ -14,7 +14,8 @@  REFPOLICY_DEPENDENCIES = \
 	host-policycoreutils \
 	host-python3 \
 	host-setools \
-	host-gawk
+	host-gawk \
+	host-libxml2
 
 ifeq ($(BR2_PACKAGE_REFPOLICY_CUSTOM_GIT),y)
 REFPOLICY_VERSION = $(call qstrip,$(BR2_PACKAGE_REFPOLICY_CUSTOM_REPO_VERSION))
@@ -30,6 +31,7 @@  endif
 # Cannot use multiple threads to build the reference policy
 REFPOLICY_MAKE = \
 	PYTHON=$(HOST_DIR)/usr/bin/python3 \
+	XMLLINT=$(LIBXML2_HOST_BINARY) \
 	TEST_TOOLCHAIN=$(HOST_DIR) \
 	$(TARGET_MAKE_ENV) \
 	$(MAKE1)