diff mbox series

[v2] package/ffmpeg: fix build on mips

Message ID 20210922210959.3604227-1-giulio.benetti@benettiengineering.com
State Accepted
Headers show
Series [v2] package/ffmpeg: fix build on mips | expand

Commit Message

Giulio Benetti Sept. 22, 2021, 9:09 p.m. UTC
mips_32 is not supported by ffmpeg and it tries to build with loongson3
SIMD support that leads to build failure due to:
/tmp/ccFO2LRa.s: Assembler messages:
/tmp/ccFO2LRa.s:15314: Error: opcode not supported on this processor: mips32 (mips32) `dmult $2,$6'
/tmp/ccFO2LRa.s:15316: Error: opcode not supported on this processor: mips32 (mips32) `dsrl $2,$2,32'

So let's --disable-asm to prevent using those unsupported opcodes for every
mips architecture according to Arnout.

Fixes:
http://autobuild.buildroot.net/results/f01/f01d9cedec8e1b371308d0f7af561a75883fa27c/

Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
---
 package/ffmpeg/ffmpeg.mk | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)

Comments

Arnout Vandecappelle Oct. 6, 2021, 7:24 p.m. UTC | #1
On 22/09/2021 23:09, Giulio Benetti wrote:
> mips_32 is not supported by ffmpeg and it tries to build with loongson3
> SIMD support that leads to build failure due to:
> /tmp/ccFO2LRa.s: Assembler messages:
> /tmp/ccFO2LRa.s:15314: Error: opcode not supported on this processor: mips32 (mips32) `dmult $2,$6'
> /tmp/ccFO2LRa.s:15316: Error: opcode not supported on this processor: mips32 (mips32) `dsrl $2,$2,32'
> 
> So let's --disable-asm to prevent using those unsupported opcodes for every
> mips architecture according to Arnout.
> 
> Fixes:
> http://autobuild.buildroot.net/results/f01/f01d9cedec8e1b371308d0f7af561a75883fa27c/
> 
> Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>

  Applied to master, thanks.

  Regards,
  Arnout

> ---
>   package/ffmpeg/ffmpeg.mk | 4 +---
>   1 file changed, 1 insertion(+), 3 deletions(-)
> 
> diff --git a/package/ffmpeg/ffmpeg.mk b/package/ffmpeg/ffmpeg.mk
> index 8ff8ea8c6c..b3ce4c0656 100644
> --- a/package/ffmpeg/ffmpeg.mk
> +++ b/package/ffmpeg/ffmpeg.mk
> @@ -507,10 +507,8 @@ else
>   FFMPEG_CONF_OPTS += --enable-mipsfpu
>   endif
>   
> -# Fix build failure on "addi opcode not supported"
> -ifeq ($(BR2_mips_32r6)$(BR2_mips_64r6),y)
> +# Fix build failure on several missing assembly instructions
>   FFMPEG_CONF_OPTS += --disable-asm
> -endif
>   endif # MIPS
>   
>   ifeq ($(BR2_POWERPC_CPU_HAS_ALTIVEC),y)
>
Peter Korsgaard Oct. 7, 2021, 7:37 a.m. UTC | #2
>>>>> "Giulio" == Giulio Benetti <giulio.benetti@benettiengineering.com> writes:

 > mips_32 is not supported by ffmpeg and it tries to build with loongson3
 > SIMD support that leads to build failure due to:
 > /tmp/ccFO2LRa.s: Assembler messages:
 > /tmp/ccFO2LRa.s:15314: Error: opcode not supported on this processor: mips32 (mips32) `dmult $2,$6'
 > /tmp/ccFO2LRa.s:15316: Error: opcode not supported on this processor: mips32 (mips32) `dsrl $2,$2,32'

 > So let's --disable-asm to prevent using those unsupported opcodes for every
 > mips architecture according to Arnout.

 > Fixes:
 > http://autobuild.buildroot.net/results/f01/f01d9cedec8e1b371308d0f7af561a75883fa27c/

 > Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>

Committed to 2021.05.x and 2021.08.x, thanks. We don't have any
autobuilder failues on 2021.02.x, and I cannot reproduce it either here
so it may be related to ffmpeg 4.4.x.
diff mbox series

Patch

diff --git a/package/ffmpeg/ffmpeg.mk b/package/ffmpeg/ffmpeg.mk
index 8ff8ea8c6c..b3ce4c0656 100644
--- a/package/ffmpeg/ffmpeg.mk
+++ b/package/ffmpeg/ffmpeg.mk
@@ -507,10 +507,8 @@  else
 FFMPEG_CONF_OPTS += --enable-mipsfpu
 endif
 
-# Fix build failure on "addi opcode not supported"
-ifeq ($(BR2_mips_32r6)$(BR2_mips_64r6),y)
+# Fix build failure on several missing assembly instructions
 FFMPEG_CONF_OPTS += --disable-asm
-endif
 endif # MIPS
 
 ifeq ($(BR2_POWERPC_CPU_HAS_ALTIVEC),y)