diff mbox series

package/wpa_supplicant: Allow mesh configuration

Message ID 20210922095216.2388856-1-jose.pekkarinen@unikie.com
State Superseded
Headers show
Series package/wpa_supplicant: Allow mesh configuration | expand

Commit Message

José Pekkarinen Sept. 22, 2021, 9:52 a.m. UTC
wpa_supplicant defconfig doesn't enable CONFIG_MESH
by default, and currently there is only a path to
disable it in buildroot. This patch will restore
the logic to enable it.

Signed-off-by: José Pekkarinen <jose.pekkarinen@unikie.com>
---
 package/wpa_supplicant/wpa_supplicant.mk | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

Nicolas Cavallari Sept. 22, 2021, 10:42 a.m. UTC | #1
On 22/09/2021 11:52, José Pekkarinen wrote:
> wpa_supplicant defconfig doesn't enable CONFIG_MESH
> by default, and currently there is only a path to
> disable it in buildroot. This patch will restore
> the logic to enable it.
> 
> Signed-off-by: José Pekkarinen <jose.pekkarinen@unikie.com>
> ---
>   package/wpa_supplicant/wpa_supplicant.mk | 4 +++-
>   1 file changed, 3 insertions(+), 1 deletion(-)
> 
> diff --git a/package/wpa_supplicant/wpa_supplicant.mk b/package/wpa_supplicant/wpa_supplicant.mk
> index e9078b9f89..3e632d7247 100644
> --- a/package/wpa_supplicant/wpa_supplicant.mk
> +++ b/package/wpa_supplicant/wpa_supplicant.mk
> @@ -104,7 +104,9 @@ else
>   WPA_SUPPLICANT_CONFIG_DISABLE += CONFIG_WIFI_DISPLAY
>   endif
>   
> -ifeq ($(BR2_PACKAGE_WPA_SUPPLICANT_MESH_NETWORKING),)
> +ifeq ($(BR2_PACKAGE_WPA_SUPPLICANT_MESH_NETWORKING),y)
> +WPA_SUPPLICANT_CONFIG_ENABLE += CONFIG__MESH

typo ?

> +else
>   WPA_SUPPLICANT_CONFIG_DISABLE += CONFIG_MESH
>   endif
>   
>
José Pekkarinen Sept. 22, 2021, 11:36 a.m. UTC | #2
On Wed, Sep 22, 2021 at 1:42 PM Nicolas Cavallari <
nicolas.cavallari@green-communications.fr> wrote:

> On 22/09/2021 11:52, José Pekkarinen wrote:
> > wpa_supplicant defconfig doesn't enable CONFIG_MESH
> > by default, and currently there is only a path to
> > disable it in buildroot. This patch will restore
> > the logic to enable it.
> >
> > Signed-off-by: José Pekkarinen <jose.pekkarinen@unikie.com>
> > ---
> >   package/wpa_supplicant/wpa_supplicant.mk | 4 +++-
> >   1 file changed, 3 insertions(+), 1 deletion(-)
> >
> > diff --git a/package/wpa_supplicant/wpa_supplicant.mk
> b/package/wpa_supplicant/wpa_supplicant.mk
> > index e9078b9f89..3e632d7247 100644
> > --- a/package/wpa_supplicant/wpa_supplicant.mk
> > +++ b/package/wpa_supplicant/wpa_supplicant.mk
> > @@ -104,7 +104,9 @@ else
> >   WPA_SUPPLICANT_CONFIG_DISABLE += CONFIG_WIFI_DISPLAY
> >   endif
> >
> > -ifeq ($(BR2_PACKAGE_WPA_SUPPLICANT_MESH_NETWORKING),)
> > +ifeq ($(BR2_PACKAGE_WPA_SUPPLICANT_MESH_NETWORKING),y)
> > +WPA_SUPPLICANT_CONFIG_ENABLE += CONFIG__MESH
>
> typo ?
>

Yep, sorry, I'll resend.

José.


> > +else
> >   WPA_SUPPLICANT_CONFIG_DISABLE += CONFIG_MESH
> >   endif
> >
> >
>
>
diff mbox series

Patch

diff --git a/package/wpa_supplicant/wpa_supplicant.mk b/package/wpa_supplicant/wpa_supplicant.mk
index e9078b9f89..3e632d7247 100644
--- a/package/wpa_supplicant/wpa_supplicant.mk
+++ b/package/wpa_supplicant/wpa_supplicant.mk
@@ -104,7 +104,9 @@  else
 WPA_SUPPLICANT_CONFIG_DISABLE += CONFIG_WIFI_DISPLAY
 endif
 
-ifeq ($(BR2_PACKAGE_WPA_SUPPLICANT_MESH_NETWORKING),)
+ifeq ($(BR2_PACKAGE_WPA_SUPPLICANT_MESH_NETWORKING),y)
+WPA_SUPPLICANT_CONFIG_ENABLE += CONFIG__MESH
+else
 WPA_SUPPLICANT_CONFIG_DISABLE += CONFIG_MESH
 endif