diff mbox series

[2/8] package/xorriso: build host variant with zlib support

Message ID 20210914093457.1389174-3-kory.maincent@bootlin.com
State Accepted
Headers show
Series Add support for ISO9660 image compatible with Legacy and EFI BIOS | expand

Commit Message

Kory Maincent Sept. 14, 2021, 9:34 a.m. UTC
We will soon use xorriso in the ISO9660 image generation support, and
this requires having zlib support in host-xorriso.

Signed-off-by: Kory Maincent <kory.maincent@bootlin.com>
---
 package/xorriso/xorriso.mk | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

Yann E. MORIN Sept. 17, 2021, 7:52 p.m. UTC | #1
Köry, All,

On 2021-09-14 11:34 +0200, Kory Maincent spake thusly:
> We will soon use xorriso in the ISO9660 image generation support, and
> this requires having zlib support in host-xorriso.
> 
> Signed-off-by: Kory Maincent <kory.maincent@bootlin.com>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  package/xorriso/xorriso.mk | 4 +++-
>  1 file changed, 3 insertions(+), 1 deletion(-)
> 
> diff --git a/package/xorriso/xorriso.mk b/package/xorriso/xorriso.mk
> index 7b38f268bb..ff3414fd8a 100644
> --- a/package/xorriso/xorriso.mk
> +++ b/package/xorriso/xorriso.mk
> @@ -12,14 +12,16 @@ XORRISO_LICENSE_FILES = COPYING COPYRIGHT
>  # Disable everything until we actually need those features, and add the correct
>  # host libraries
>  HOST_XORRISO_CONF_OPTS = \
> +	--enable-zlib \
>  	--disable-xattr-h-pref-attr \
> -	--disable-zlib \
>  	--disable-libbz2 \
>  	--disable-libcdio \
>  	--disable-libreadline \
>  	--disable-libedit \
>  	--disable-libacl
>  
> +HOST_XORRISO_DEPENDENCIES = host-zlib
> +
>  # libcdio doesn't make sense for Linux
>  # http://lists.gnu.org/archive/html/bug-xorriso/2017-04/msg00004.html
>  XORRISO_CONF_OPTS = --disable-libcdio
> -- 
> 2.25.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@lists.buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/xorriso/xorriso.mk b/package/xorriso/xorriso.mk
index 7b38f268bb..ff3414fd8a 100644
--- a/package/xorriso/xorriso.mk
+++ b/package/xorriso/xorriso.mk
@@ -12,14 +12,16 @@  XORRISO_LICENSE_FILES = COPYING COPYRIGHT
 # Disable everything until we actually need those features, and add the correct
 # host libraries
 HOST_XORRISO_CONF_OPTS = \
+	--enable-zlib \
 	--disable-xattr-h-pref-attr \
-	--disable-zlib \
 	--disable-libbz2 \
 	--disable-libcdio \
 	--disable-libreadline \
 	--disable-libedit \
 	--disable-libacl
 
+HOST_XORRISO_DEPENDENCIES = host-zlib
+
 # libcdio doesn't make sense for Linux
 # http://lists.gnu.org/archive/html/bug-xorriso/2017-04/msg00004.html
 XORRISO_CONF_OPTS = --disable-libcdio