diff mbox series

[1/1] package/libfuse: fix build with glibc >= 2.34

Message ID 20210912194057.2556882-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/libfuse: fix build with glibc >= 2.34 | expand

Commit Message

Fabrice Fontaine Sept. 12, 2021, 7:40 p.m. UTC
Fix the following build failure with glibc >= 2.34:

ulockmgr_server.c:127:12: error: conflicting types for 'closefrom'; have 'int(int)'
  127 | static int closefrom(int minfd)
      |            ^~~~~~~~~
In file included from ulockmgr_server.c:14:
/home/buildroot/autobuild/instance-1/output-1/host/arm-buildroot-linux-gnueabihf/sysroot/usr/include/unistd.h:363:13: note: previous declaration of 'closefrom' with type 'void(int)'
  363 | extern void closefrom (int __lowfd) __THROW;
      |             ^~~~~~~~~

Fixes:
 - http://autobuild.buildroot.org/results/3769b18ca804fba3b5974af799972a7d889b39a6

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 ...ally-define-closefrom-fix-glibc-2-34.patch | 64 +++++++++++++++++++
 package/libfuse/libfuse.mk                    |  7 +-
 2 files changed, 70 insertions(+), 1 deletion(-)
 create mode 100644 package/libfuse/0002-util-ulockmgr_server-c-conditionally-define-closefrom-fix-glibc-2-34.patch

Comments

Yann E. MORIN Sept. 19, 2021, 7:15 a.m. UTC | #1
Fabrice, All,

On 2021-09-12 21:40 +0200, Fabrice Fontaine spake thusly:
> Fix the following build failure with glibc >= 2.34:
> 
> ulockmgr_server.c:127:12: error: conflicting types for 'closefrom'; have 'int(int)'
>   127 | static int closefrom(int minfd)
>       |            ^~~~~~~~~
> In file included from ulockmgr_server.c:14:
> /home/buildroot/autobuild/instance-1/output-1/host/arm-buildroot-linux-gnueabihf/sysroot/usr/include/unistd.h:363:13: note: previous declaration of 'closefrom' with type 'void(int)'
>   363 | extern void closefrom (int __lowfd) __THROW;
>       |             ^~~~~~~~~
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/3769b18ca804fba3b5974af799972a7d889b39a6
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  ...ally-define-closefrom-fix-glibc-2-34.patch | 64 +++++++++++++++++++
>  package/libfuse/libfuse.mk                    |  7 +-
>  2 files changed, 70 insertions(+), 1 deletion(-)
>  create mode 100644 package/libfuse/0002-util-ulockmgr_server-c-conditionally-define-closefrom-fix-glibc-2-34.patch
> 
> diff --git a/package/libfuse/0002-util-ulockmgr_server-c-conditionally-define-closefrom-fix-glibc-2-34.patch b/package/libfuse/0002-util-ulockmgr_server-c-conditionally-define-closefrom-fix-glibc-2-34.patch
> new file mode 100644
> index 0000000000..7c3346e47b
> --- /dev/null
> +++ b/package/libfuse/0002-util-ulockmgr_server-c-conditionally-define-closefrom-fix-glibc-2-34.patch
> @@ -0,0 +1,64 @@
> +From 5a43d0f724c56f8836f3f92411e0de1b5f82db32 Mon Sep 17 00:00:00 2001
> +From: Sam James <sam@gentoo.org>
> +Date: Sat, 24 Jul 2021 22:02:45 +0100
> +Subject: [PATCH] util/ulockmgr_server.c: conditionally define closefrom (fix
> + glibc-2.34+)
> +
> +closefrom(3) has joined us in glibc-land from *BSD and Solaris. Since
> +it's available in glibc 2.34+, we want to detect it and only define our
> +fallback if the libc doesn't provide it.
> +
> +Bug: https://bugs.gentoo.org/803923
> +Signed-off-by: Sam James <sam@gentoo.org>
> +
> +[Retrieved from:
> +https://github.com/libfuse/libfuse/commit/5a43d0f724c56f8836f3f92411e0de1b5f82db32]
> +Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> +---
> + configure.ac           | 1 +
> + util/ulockmgr_server.c | 6 ++++++
> + 2 files changed, 7 insertions(+)
> +
> +diff --git a/configure.ac b/configure.ac
> +index 9946a0efa..a2d481aa9 100644
> +--- a/configure.ac
> ++++ b/configure.ac
> +@@ -55,6 +55,7 @@ fi
> + 
> + AC_CHECK_FUNCS([fork setxattr fdatasync splice vmsplice utimensat])
> + AC_CHECK_FUNCS([posix_fallocate])
> ++AC_CHECK_FUNCS([closefrom])
> + AC_CHECK_MEMBERS([struct stat.st_atim])
> + AC_CHECK_MEMBERS([struct stat.st_atimespec])
> + 
> +diff --git a/util/ulockmgr_server.c b/util/ulockmgr_server.c
> +index 273c7d923..a04dac5c6 100644
> +--- a/util/ulockmgr_server.c
> ++++ b/util/ulockmgr_server.c
> +@@ -22,6 +22,10 @@
> + #include <sys/socket.h>
> + #include <sys/wait.h>
> + 
> ++#ifdef HAVE_CONFIG_H
> ++	#include "config.h"
> ++#endif
> ++
> + struct message {
> + 	unsigned intr : 1;
> + 	unsigned nofd : 1;
> +@@ -124,6 +128,7 @@ static int receive_message(int sock, void *buf, size_t buflen, int *fdp,
> + 	return res;
> + }
> + 
> ++#if !defined(HAVE_CLOSEFROM)
> + static int closefrom(int minfd)
> + {
> + 	DIR *dir = opendir("/proc/self/fd");
> +@@ -141,6 +146,7 @@ static int closefrom(int minfd)
> + 	}
> + 	return 0;
> + }
> ++#endif
> + 
> + static void send_reply(int cfd, struct message *msg)
> + {
> diff --git a/package/libfuse/libfuse.mk b/package/libfuse/libfuse.mk
> index 2677e46853..6dce641f7f 100644
> --- a/package/libfuse/libfuse.mk
> +++ b/package/libfuse/libfuse.mk
> @@ -11,7 +11,12 @@ LIBFUSE_LICENSE = GPL-2.0, LGPL-2.1
>  LIBFUSE_LICENSE_FILES = COPYING COPYING.LIB
>  LIBFUSE_CPE_ID_VENDOR = libfuse_project
>  LIBFUSE_INSTALL_STAGING = YES
> -LIBFUSE_DEPENDENCIES = $(if $(BR2_PACKAGE_LIBICONV),libiconv)
> +# We're patching configure.ac
> +LIBFUSE_AUTORECONF = YES
> +# add host-gettext for AM_ICONV macro
> +LIBFUSE_DEPENDENCIES = \
> +	host-gettext \
> +	$(if $(BR2_PACKAGE_LIBICONV),libiconv)
>  LIBFUSE_CONF_OPTS = \
>  	--disable-example \
>  	--enable-lib \
> -- 
> 2.33.0
> 
> _______________________________________________
> buildroot mailing list
> buildroot@lists.buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/libfuse/0002-util-ulockmgr_server-c-conditionally-define-closefrom-fix-glibc-2-34.patch b/package/libfuse/0002-util-ulockmgr_server-c-conditionally-define-closefrom-fix-glibc-2-34.patch
new file mode 100644
index 0000000000..7c3346e47b
--- /dev/null
+++ b/package/libfuse/0002-util-ulockmgr_server-c-conditionally-define-closefrom-fix-glibc-2-34.patch
@@ -0,0 +1,64 @@ 
+From 5a43d0f724c56f8836f3f92411e0de1b5f82db32 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sat, 24 Jul 2021 22:02:45 +0100
+Subject: [PATCH] util/ulockmgr_server.c: conditionally define closefrom (fix
+ glibc-2.34+)
+
+closefrom(3) has joined us in glibc-land from *BSD and Solaris. Since
+it's available in glibc 2.34+, we want to detect it and only define our
+fallback if the libc doesn't provide it.
+
+Bug: https://bugs.gentoo.org/803923
+Signed-off-by: Sam James <sam@gentoo.org>
+
+[Retrieved from:
+https://github.com/libfuse/libfuse/commit/5a43d0f724c56f8836f3f92411e0de1b5f82db32]
+Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+---
+ configure.ac           | 1 +
+ util/ulockmgr_server.c | 6 ++++++
+ 2 files changed, 7 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index 9946a0efa..a2d481aa9 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -55,6 +55,7 @@ fi
+ 
+ AC_CHECK_FUNCS([fork setxattr fdatasync splice vmsplice utimensat])
+ AC_CHECK_FUNCS([posix_fallocate])
++AC_CHECK_FUNCS([closefrom])
+ AC_CHECK_MEMBERS([struct stat.st_atim])
+ AC_CHECK_MEMBERS([struct stat.st_atimespec])
+ 
+diff --git a/util/ulockmgr_server.c b/util/ulockmgr_server.c
+index 273c7d923..a04dac5c6 100644
+--- a/util/ulockmgr_server.c
++++ b/util/ulockmgr_server.c
+@@ -22,6 +22,10 @@
+ #include <sys/socket.h>
+ #include <sys/wait.h>
+ 
++#ifdef HAVE_CONFIG_H
++	#include "config.h"
++#endif
++
+ struct message {
+ 	unsigned intr : 1;
+ 	unsigned nofd : 1;
+@@ -124,6 +128,7 @@ static int receive_message(int sock, void *buf, size_t buflen, int *fdp,
+ 	return res;
+ }
+ 
++#if !defined(HAVE_CLOSEFROM)
+ static int closefrom(int minfd)
+ {
+ 	DIR *dir = opendir("/proc/self/fd");
+@@ -141,6 +146,7 @@ static int closefrom(int minfd)
+ 	}
+ 	return 0;
+ }
++#endif
+ 
+ static void send_reply(int cfd, struct message *msg)
+ {
diff --git a/package/libfuse/libfuse.mk b/package/libfuse/libfuse.mk
index 2677e46853..6dce641f7f 100644
--- a/package/libfuse/libfuse.mk
+++ b/package/libfuse/libfuse.mk
@@ -11,7 +11,12 @@  LIBFUSE_LICENSE = GPL-2.0, LGPL-2.1
 LIBFUSE_LICENSE_FILES = COPYING COPYING.LIB
 LIBFUSE_CPE_ID_VENDOR = libfuse_project
 LIBFUSE_INSTALL_STAGING = YES
-LIBFUSE_DEPENDENCIES = $(if $(BR2_PACKAGE_LIBICONV),libiconv)
+# We're patching configure.ac
+LIBFUSE_AUTORECONF = YES
+# add host-gettext for AM_ICONV macro
+LIBFUSE_DEPENDENCIES = \
+	host-gettext \
+	$(if $(BR2_PACKAGE_LIBICONV),libiconv)
 LIBFUSE_CONF_OPTS = \
 	--disable-example \
 	--enable-lib \