diff mbox series

[1/1] package/libgit2: bump to version 1.2.0

Message ID 20210908133010.31005-1-nicolas.cavallari@green-communications.fr
State Accepted
Headers show
Series [1/1] package/libgit2: bump to version 1.2.0 | expand

Commit Message

Nicolas Cavallari Sept. 8, 2021, 1:30 p.m. UTC
COPYING was updated with a copy of the openssl licence since libgit2 now
include openssl headers so it can dlopen it:

    openssl: dynamically load libssl and symbols (optionally)

    Provide an interface around OpenSSL to dynamically load the
    libraries and symbols, so that users can distribute a libgit2
    library that is not linked directly against OpenSSL.  This enables
    users to target multiple distributions with a single binary.

    This mechanism is optional and disabled by default.  Configure cmake
    with -DUSE_HTTPS=OpenSSL-Dynamic to use it.

We do not use that option so the headers are not even used, plus the
headers are not installed on the target anyway, so this patch includes
no license changes.

Upstream also stopped providing release tarballs, relying on
github-generated tarballs instead.

Signed-off-by: Nicolas Cavallari <nicolas.cavallari@green-communications.fr>
---
 package/libgit2/libgit2.hash | 4 ++--
 package/libgit2/libgit2.mk   | 4 ++--
 2 files changed, 4 insertions(+), 4 deletions(-)

Comments

Arnout Vandecappelle Sept. 20, 2021, 7:04 p.m. UTC | #1
On 08/09/2021 15:30, Nicolas Cavallari wrote:
> COPYING was updated with a copy of the openssl licence since libgit2 now
> include openssl headers so it can dlopen it:
> 
>      openssl: dynamically load libssl and symbols (optionally)
> 
>      Provide an interface around OpenSSL to dynamically load the
>      libraries and symbols, so that users can distribute a libgit2
>      library that is not linked directly against OpenSSL.  This enables
>      users to target multiple distributions with a single binary.
> 
>      This mechanism is optional and disabled by default.  Configure cmake
>      with -DUSE_HTTPS=OpenSSL-Dynamic to use it.
> 
> We do not use that option so the headers are not even used, plus the
> headers are not installed on the target anyway, so this patch includes
> no license changes.

  Thank you for the *excellent* explanation!

  Applied to master, thanks.

  Regards,
  Arnout

> 
> Upstream also stopped providing release tarballs, relying on
> github-generated tarballs instead.
> 
> Signed-off-by: Nicolas Cavallari <nicolas.cavallari@green-communications.fr>
> ---
>   package/libgit2/libgit2.hash | 4 ++--
>   package/libgit2/libgit2.mk   | 4 ++--
>   2 files changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/package/libgit2/libgit2.hash b/package/libgit2/libgit2.hash
> index 367ade3afe..5522f5fe45 100644
> --- a/package/libgit2/libgit2.hash
> +++ b/package/libgit2/libgit2.hash
> @@ -1,3 +1,3 @@
>   # Locally calculated
> -sha256  ad73f845965cfd528e70f654e428073121a3fa0dc23caac81a1b1300277d4dba  libgit2-1.1.0.tar.gz
> -sha256  afc8bde99ba630012107c25d3c42dde628ec5f0cd3f428131f7e3a0f7d58ff42  COPYING
> +sha256  701a5086a968a46f25e631941b99fc23e4755ca2c56f59371ce1d94b9a0cc643  libgit2-1.2.0.tar.gz
> +sha256  8b7e4f54f8bf210c8fe010a49571a1ee57463ef020cc43f051d4d3fbb74942af  COPYING
> diff --git a/package/libgit2/libgit2.mk b/package/libgit2/libgit2.mk
> index 668fa758f8..4c715302d1 100644
> --- a/package/libgit2/libgit2.mk
> +++ b/package/libgit2/libgit2.mk
> @@ -4,8 +4,8 @@
>   #
>   ################################################################################
>   
> -LIBGIT2_VERSION = 1.1.0
> -LIBGIT2_SITE = https://github.com/libgit2/libgit2/releases/download/v$(LIBGIT2_VERSION)
> +LIBGIT2_VERSION = 1.2.0
> +LIBGIT2_SITE = $(call github,libgit2,libgit2,v$(LIBGIT2_VERSION))
>   LIBGIT2_LICENSE = GPL-2.0 with linking exception, MIT (sha1), wildmatch license (wildmatch)
>   LIBGIT2_LICENSE_FILES = COPYING
>   LIBGIT2_CPE_ID_VENDOR = libgit2_project
>
diff mbox series

Patch

diff --git a/package/libgit2/libgit2.hash b/package/libgit2/libgit2.hash
index 367ade3afe..5522f5fe45 100644
--- a/package/libgit2/libgit2.hash
+++ b/package/libgit2/libgit2.hash
@@ -1,3 +1,3 @@ 
 # Locally calculated
-sha256  ad73f845965cfd528e70f654e428073121a3fa0dc23caac81a1b1300277d4dba  libgit2-1.1.0.tar.gz
-sha256  afc8bde99ba630012107c25d3c42dde628ec5f0cd3f428131f7e3a0f7d58ff42  COPYING
+sha256  701a5086a968a46f25e631941b99fc23e4755ca2c56f59371ce1d94b9a0cc643  libgit2-1.2.0.tar.gz
+sha256  8b7e4f54f8bf210c8fe010a49571a1ee57463ef020cc43f051d4d3fbb74942af  COPYING
diff --git a/package/libgit2/libgit2.mk b/package/libgit2/libgit2.mk
index 668fa758f8..4c715302d1 100644
--- a/package/libgit2/libgit2.mk
+++ b/package/libgit2/libgit2.mk
@@ -4,8 +4,8 @@ 
 #
 ################################################################################
 
-LIBGIT2_VERSION = 1.1.0
-LIBGIT2_SITE = https://github.com/libgit2/libgit2/releases/download/v$(LIBGIT2_VERSION)
+LIBGIT2_VERSION = 1.2.0
+LIBGIT2_SITE = $(call github,libgit2,libgit2,v$(LIBGIT2_VERSION))
 LIBGIT2_LICENSE = GPL-2.0 with linking exception, MIT (sha1), wildmatch license (wildmatch)
 LIBGIT2_LICENSE_FILES = COPYING
 LIBGIT2_CPE_ID_VENDOR = libgit2_project