diff mbox series

[1/1] package/alsa-utils: Fix alsa-plugins compatibility

Message ID 20210825151659.59671-1-glex.spb@gmail.com
State Accepted
Headers show
Series [1/1] package/alsa-utils: Fix alsa-plugins compatibility | expand

Commit Message

Gleb Mazovetskiy Aug. 25, 2021, 3:16 p.m. UTC
Previously, alsa-plugins would not work if alsa-utils was installed
after it. This happened because:

1. alsa-plugins copies some files $(TARGET_DIR)/usr/share/alsa/alsa.conf.d
2. alsa-utils removes these files during installation ( rm -rf $(TARGET_DIR)/usr/share/alsa/;)

The `rm -rf` command was originally added as part of the fix for
https://bugs.buildroot.org/show_bug.cgi?id=1573 11 years ago.

The intention might have been to allow for unconfiguring some options
and then rebuilding alsa-utils. However, this is a scenario that does
not work anyway.

The simplest fix for the `alsa-plugins` compatibility issue appears to
be to remove the `rm -rf` command.

Signed-off-by: Gleb Mazovetskiy <glex.spb@gmail.com>
---
 package/alsa-utils/alsa-utils.mk | 1 -
 1 file changed, 1 deletion(-)

Comments

Arnout Vandecappelle Aug. 25, 2021, 8:13 p.m. UTC | #1
On 25/08/2021 17:16, Gleb Mazovetskiy wrote:
> Previously, alsa-plugins would not work if alsa-utils was installed
> after it. This happened because:
> 
> 1. alsa-plugins copies some files $(TARGET_DIR)/usr/share/alsa/alsa.conf.d
> 2. alsa-utils removes these files during installation ( rm -rf $(TARGET_DIR)/usr/share/alsa/;)
> 
> The `rm -rf` command was originally added as part of the fix for
> https://bugs.buildroot.org/show_bug.cgi?id=1573 11 years ago.
> 
> The intention might have been to allow for unconfiguring some options
> and then rebuilding alsa-utils. However, this is a scenario that does
> not work anyway.
> 
> The simplest fix for the `alsa-plugins` compatibility issue appears to
> be to remove the `rm -rf` command.
> 
> Signed-off-by: Gleb Mazovetskiy <glex.spb@gmail.com>

 Applied to master, thanks.

 Excellent commit message!

 Regards,
 Arnout

> ---
>  package/alsa-utils/alsa-utils.mk | 1 -
>  1 file changed, 1 deletion(-)
> 
> diff --git a/package/alsa-utils/alsa-utils.mk b/package/alsa-utils/alsa-utils.mk
> index 2658c827a0..427280c1e6 100644
> --- a/package/alsa-utils/alsa-utils.mk
> +++ b/package/alsa-utils/alsa-utils.mk
> @@ -77,7 +77,6 @@ define ALSA_UTILS_INSTALL_TARGET_CMDS
>  	fi
>  	if [ -x "$(TARGET_DIR)/usr/sbin/alsactl" ]; then \
>  		mkdir -p $(TARGET_DIR)/usr/share/; \
> -		rm -rf $(TARGET_DIR)/usr/share/alsa/; \
>  		cp -rdpf $(STAGING_DIR)/usr/share/alsa/ $(TARGET_DIR)/usr/share/alsa/; \
>  	fi
>  endef
>
Peter Korsgaard Sept. 7, 2021, 10:07 a.m. UTC | #2
>>>>> "Gleb" == Gleb Mazovetskiy <glex.spb@gmail.com> writes:

 > Previously, alsa-plugins would not work if alsa-utils was installed
 > after it. This happened because:

 > 1. alsa-plugins copies some files $(TARGET_DIR)/usr/share/alsa/alsa.conf.d
 > 2. alsa-utils removes these files during installation ( rm -rf $(TARGET_DIR)/usr/share/alsa/;)

 > The `rm -rf` command was originally added as part of the fix for
 > https://bugs.buildroot.org/show_bug.cgi?id=1573 11 years ago.

 > The intention might have been to allow for unconfiguring some options
 > and then rebuilding alsa-utils. However, this is a scenario that does
 > not work anyway.

 > The simplest fix for the `alsa-plugins` compatibility issue appears to
 > be to remove the `rm -rf` command.

 > Signed-off-by: Gleb Mazovetskiy <glex.spb@gmail.com>

Committed to 2021.02.x and 2021.05.x, thanks.
diff mbox series

Patch

diff --git a/package/alsa-utils/alsa-utils.mk b/package/alsa-utils/alsa-utils.mk
index 2658c827a0..427280c1e6 100644
--- a/package/alsa-utils/alsa-utils.mk
+++ b/package/alsa-utils/alsa-utils.mk
@@ -77,7 +77,6 @@  define ALSA_UTILS_INSTALL_TARGET_CMDS
 	fi
 	if [ -x "$(TARGET_DIR)/usr/sbin/alsactl" ]; then \
 		mkdir -p $(TARGET_DIR)/usr/share/; \
-		rm -rf $(TARGET_DIR)/usr/share/alsa/; \
 		cp -rdpf $(STAGING_DIR)/usr/share/alsa/ $(TARGET_DIR)/usr/share/alsa/; \
 	fi
 endef