diff mbox series

[1/3] package/php: remove ineffective opcache patch

Message ID 20210805085353.3457-1-p.debruijn@unilogic.nl
State Changes Requested
Headers show
Series [1/3] package/php: remove ineffective opcache patch | expand

Commit Message

Pascal de Bruijn Aug. 5, 2021, 8:53 a.m. UTC
Current opcache builds compile, but fail at runtime due to shm_unlink not
being resolvable.

Signed-off-by: Pascal de Bruijn <p.debruijn@unilogic.nl>
---
 .../0005-allow-opcache-cross-compiling.patch  | 37 -------------------
 1 file changed, 37 deletions(-)
 delete mode 100644 package/php/0005-allow-opcache-cross-compiling.patch

Comments

Arnout Vandecappelle Aug. 5, 2021, 4:44 p.m. UTC | #1
On 05/08/2021 10:53, Pascal de Bruijn wrote:
> Current opcache builds compile, but fail at runtime due to shm_unlink not
> being resolvable.
> 
> Signed-off-by: Pascal de Bruijn <p.debruijn@unilogic.nl>
> ---
>  .../0005-allow-opcache-cross-compiling.patch  | 37 -------------------
>  1 file changed, 37 deletions(-)
>  delete mode 100644 package/php/0005-allow-opcache-cross-compiling.patch
> 
> diff --git a/package/php/0005-allow-opcache-cross-compiling.patch b/package/php/0005-allow-opcache-cross-compiling.patch
> deleted file mode 100644
> index d168f71892..0000000000
> --- a/package/php/0005-allow-opcache-cross-compiling.patch
> +++ /dev/null
> @@ -1,37 +0,0 @@
> -From 9bb316c41a69935ee2072626467241889594bed4 Mon Sep 17 00:00:00 2001
> -From: Adam Duskett <aduskett@gmail.com>
> -Date: Mon, 28 Jun 2021 11:12:36 -0700
> -Subject: [PATCH] allow opcache cross-compiling
> -
> -Remove the check at the end of ext/opcache/config.m4 that prevents opcache from
> -being enabled in a cross-compiled environment. We pass the following as a
> -CFLAGS when opcache is enabled:
> -  -DHAVE_SHM_IPC
> -  -DHAVE_SHM_MMAP_ANON
> -  -DHAVE_SHM_MMAP_ZERO
> -  -DHAVE_SHM_MMAP_POSIX
> -  -DHAVE_SHM_MMAP_FILE
> -
> -Signed-off-by: Adam Duskett <aduskett@gmail.com>
> ----
> - ext/opcache/config.m4 | 4 ----
> - 1 file changed, 4 deletions(-)
> -
> -diff --git a/ext/opcache/config.m4 b/ext/opcache/config.m4
> -index 5492fd92..10c150ff 100644
> ---- a/ext/opcache/config.m4
> -+++ b/ext/opcache/config.m4
> -@@ -339,10 +339,6 @@ int main() {
> -   PHP_ADD_BUILD_DIR([$ext_builddir/Optimizer], 1)
> -   PHP_ADD_EXTENSION_DEP(opcache, pcre)
> - 
> --  if test "$have_shm_ipc" != "yes" && test "$have_shm_mmap_posix" != "yes" && test "$have_shm_mmap_anon" != "yes"; then

 I don't understand how opcache can work at all if you remove this patch.
have_shm_mmap_anon is still no after patch 2/3, so opcache won't work, right?

 Regards,
 Arnout

> --    AC_MSG_ERROR([No supported shared memory caching support was found when configuring opcache. Check config.log for any errors or missing dependencies.])
> --  fi
> --
> -   if test "$PHP_OPCACHE_JIT" = "yes"; then
> -     PHP_ADD_BUILD_DIR([$ext_builddir/jit], 1)
> -     PHP_ADD_MAKEFILE_FRAGMENT($ext_srcdir/jit/Makefile.frag)
> --- 
> -2.31.1
> -
>
Yann E. MORIN Aug. 10, 2021, 7:01 p.m. UTC | #2
Pascal, All,

Given the questions raised by this series, I think more testing and more
detailed commit messages that explain the changes will be needed.

As a consequence, I've marked this series as changes-requested.

Thanks!

Regards,
Yann E. MORIN.

On 2021-08-05 10:53 +0200, Pascal de Bruijn spake thusly:
> Current opcache builds compile, but fail at runtime due to shm_unlink not
> being resolvable.
> 
> Signed-off-by: Pascal de Bruijn <p.debruijn@unilogic.nl>
> ---
>  .../0005-allow-opcache-cross-compiling.patch  | 37 -------------------
>  1 file changed, 37 deletions(-)
>  delete mode 100644 package/php/0005-allow-opcache-cross-compiling.patch
> 
> diff --git a/package/php/0005-allow-opcache-cross-compiling.patch b/package/php/0005-allow-opcache-cross-compiling.patch
> deleted file mode 100644
> index d168f71892..0000000000
> --- a/package/php/0005-allow-opcache-cross-compiling.patch
> +++ /dev/null
> @@ -1,37 +0,0 @@
> -From 9bb316c41a69935ee2072626467241889594bed4 Mon Sep 17 00:00:00 2001
> -From: Adam Duskett <aduskett@gmail.com>
> -Date: Mon, 28 Jun 2021 11:12:36 -0700
> -Subject: [PATCH] allow opcache cross-compiling
> -
> -Remove the check at the end of ext/opcache/config.m4 that prevents opcache from
> -being enabled in a cross-compiled environment. We pass the following as a
> -CFLAGS when opcache is enabled:
> -  -DHAVE_SHM_IPC
> -  -DHAVE_SHM_MMAP_ANON
> -  -DHAVE_SHM_MMAP_ZERO
> -  -DHAVE_SHM_MMAP_POSIX
> -  -DHAVE_SHM_MMAP_FILE
> -
> -Signed-off-by: Adam Duskett <aduskett@gmail.com>
> ----
> - ext/opcache/config.m4 | 4 ----
> - 1 file changed, 4 deletions(-)
> -
> -diff --git a/ext/opcache/config.m4 b/ext/opcache/config.m4
> -index 5492fd92..10c150ff 100644
> ---- a/ext/opcache/config.m4
> -+++ b/ext/opcache/config.m4
> -@@ -339,10 +339,6 @@ int main() {
> -   PHP_ADD_BUILD_DIR([$ext_builddir/Optimizer], 1)
> -   PHP_ADD_EXTENSION_DEP(opcache, pcre)
> - 
> --  if test "$have_shm_ipc" != "yes" && test "$have_shm_mmap_posix" != "yes" && test "$have_shm_mmap_anon" != "yes"; then
> --    AC_MSG_ERROR([No supported shared memory caching support was found when configuring opcache. Check config.log for any errors or missing dependencies.])
> --  fi
> --
> -   if test "$PHP_OPCACHE_JIT" = "yes"; then
> -     PHP_ADD_BUILD_DIR([$ext_builddir/jit], 1)
> -     PHP_ADD_MAKEFILE_FRAGMENT($ext_srcdir/jit/Makefile.frag)
> --- 
> -2.31.1
> -
> -- 
> 2.25.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/php/0005-allow-opcache-cross-compiling.patch b/package/php/0005-allow-opcache-cross-compiling.patch
deleted file mode 100644
index d168f71892..0000000000
--- a/package/php/0005-allow-opcache-cross-compiling.patch
+++ /dev/null
@@ -1,37 +0,0 @@ 
-From 9bb316c41a69935ee2072626467241889594bed4 Mon Sep 17 00:00:00 2001
-From: Adam Duskett <aduskett@gmail.com>
-Date: Mon, 28 Jun 2021 11:12:36 -0700
-Subject: [PATCH] allow opcache cross-compiling
-
-Remove the check at the end of ext/opcache/config.m4 that prevents opcache from
-being enabled in a cross-compiled environment. We pass the following as a
-CFLAGS when opcache is enabled:
-  -DHAVE_SHM_IPC
-  -DHAVE_SHM_MMAP_ANON
-  -DHAVE_SHM_MMAP_ZERO
-  -DHAVE_SHM_MMAP_POSIX
-  -DHAVE_SHM_MMAP_FILE
-
-Signed-off-by: Adam Duskett <aduskett@gmail.com>
----
- ext/opcache/config.m4 | 4 ----
- 1 file changed, 4 deletions(-)
-
-diff --git a/ext/opcache/config.m4 b/ext/opcache/config.m4
-index 5492fd92..10c150ff 100644
---- a/ext/opcache/config.m4
-+++ b/ext/opcache/config.m4
-@@ -339,10 +339,6 @@ int main() {
-   PHP_ADD_BUILD_DIR([$ext_builddir/Optimizer], 1)
-   PHP_ADD_EXTENSION_DEP(opcache, pcre)
- 
--  if test "$have_shm_ipc" != "yes" && test "$have_shm_mmap_posix" != "yes" && test "$have_shm_mmap_anon" != "yes"; then
--    AC_MSG_ERROR([No supported shared memory caching support was found when configuring opcache. Check config.log for any errors or missing dependencies.])
--  fi
--
-   if test "$PHP_OPCACHE_JIT" = "yes"; then
-     PHP_ADD_BUILD_DIR([$ext_builddir/jit], 1)
-     PHP_ADD_MAKEFILE_FRAGMENT($ext_srcdir/jit/Makefile.frag)
--- 
-2.31.1
-