diff mbox series

[1/1] package/s390-tools: add libxml2 optional dependency

Message ID 20210801133324.3658611-1-fontaine.fabrice@gmail.com
State Superseded
Headers show
Series [1/1] package/s390-tools: add libxml2 optional dependency | expand

Commit Message

Fabrice Fontaine Aug. 1, 2021, 1:33 p.m. UTC
libxml2 is an optional dependency which is enabled by default since
version 2.17.0 and
https://github.com/ibm-s390-linux/s390-tools/commit/56fecf1832c3ebc4626ddf5c598762833c362d5e

Also set PATH to avoid the following build failures related to
curl-config and xml2-config:

/bin/sh: 1: curl-config: not found
Error: libcurl is not built with the OpenSSL backend
make[2]: *** [Makefile:54: check-dep-libekmfweb] Error 1

Fixes:
 - http://autobuild.buildroot.org/results/cfb46d7547c22f0a23aca2286dc5a1d2c20aadfc

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/s390-tools/s390-tools.mk | 8 ++++++++
 1 file changed, 8 insertions(+)

Comments

Yann E. MORIN Aug. 1, 2021, 2:10 p.m. UTC | #1
Fabrice, All,

On 2021-08-01 15:33 +0200, Fabrice Fontaine spake thusly:
> libxml2 is an optional dependency which is enabled by default since
> version 2.17.0 and
> https://github.com/ibm-s390-linux/s390-tools/commit/56fecf1832c3ebc4626ddf5c598762833c362d5e
> 
> Also set PATH to avoid the following build failures related to
> curl-config and xml2-config:

So, thjis is two different things:
  - a fix for finding curl-config
  - an optional dependency to libxml2

As such, this should be two patches.

> /bin/sh: 1: curl-config: not found
> Error: libcurl is not built with the OpenSSL backend
> make[2]: *** [Makefile:54: check-dep-libekmfweb] Error 1

I don;t like it much that we add staging in the path, I find it very
dangerous... I know we are doing that in quite a few other places, but
I don't think that should be an excuse not to fix this curl-config
properly.

The correct way, I believe, to dfix that, is to replace hard-coded calls
to curl-config with something like, in shell scripts:

    ${CURL_CONFIG:-curl-config} --cflags

while in Makefile, it would probably look like:

    CURL_CONFIG ?= curl-config
    FOO_CFLAGS = `$(CURL_CONFIG) --cflags`

And so on... Ditto for xml2-config, of course...

Regards,
Yann E. MORIN.

> Fixes:
>  - http://autobuild.buildroot.org/results/cfb46d7547c22f0a23aca2286dc5a1d2c20aadfc
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/s390-tools/s390-tools.mk | 8 ++++++++
>  1 file changed, 8 insertions(+)
> 
> diff --git a/package/s390-tools/s390-tools.mk b/package/s390-tools/s390-tools.mk
> index b5843fe0d6..3d3f24c181 100644
> --- a/package/s390-tools/s390-tools.mk
> +++ b/package/s390-tools/s390-tools.mk
> @@ -15,6 +15,7 @@ S390_TOOLS_MAKE_OPTS = \
>  	CFLAGS="$(TARGET_CFLAGS) -D_GNU_SOURCE" \
>  	LINK="$(TARGET_CC)" \
>  	LINKXX="$(TARGET_CXX)" \
> +	PATH="$(STAGING_DIR)/usr/bin:$(BR_PATH)" \
>  	WARNINGS=
>  
>  ifeq ($(BR2_PACKAGE_LIBCURL),y)
> @@ -56,6 +57,13 @@ else
>  S390_TOOLS_MAKE_OPTS += HAVE_GLIB2=0
>  endif
>  
> +ifeq ($(BR2_PACKAGE_LIBXML2),y)
> +S390_TOOLS_DEPENDENCIES += libxml2
> +S390_TOOLS_MAKE_OPTS += HAVE_LIBXML2=1
> +else
> +S390_TOOLS_MAKE_OPTS += HAVE_LIBXML2=0
> +endif
> +
>  ifeq ($(BR2_PACKAGE_NCURSES),y)
>  S390_TOOLS_DEPENDENCIES += ncurses
>  S390_TOOLS_MAKE_OPTS += HAVE_NCURSES=1
> -- 
> 2.30.2
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/s390-tools/s390-tools.mk b/package/s390-tools/s390-tools.mk
index b5843fe0d6..3d3f24c181 100644
--- a/package/s390-tools/s390-tools.mk
+++ b/package/s390-tools/s390-tools.mk
@@ -15,6 +15,7 @@  S390_TOOLS_MAKE_OPTS = \
 	CFLAGS="$(TARGET_CFLAGS) -D_GNU_SOURCE" \
 	LINK="$(TARGET_CC)" \
 	LINKXX="$(TARGET_CXX)" \
+	PATH="$(STAGING_DIR)/usr/bin:$(BR_PATH)" \
 	WARNINGS=
 
 ifeq ($(BR2_PACKAGE_LIBCURL),y)
@@ -56,6 +57,13 @@  else
 S390_TOOLS_MAKE_OPTS += HAVE_GLIB2=0
 endif
 
+ifeq ($(BR2_PACKAGE_LIBXML2),y)
+S390_TOOLS_DEPENDENCIES += libxml2
+S390_TOOLS_MAKE_OPTS += HAVE_LIBXML2=1
+else
+S390_TOOLS_MAKE_OPTS += HAVE_LIBXML2=0
+endif
+
 ifeq ($(BR2_PACKAGE_NCURSES),y)
 S390_TOOLS_DEPENDENCIES += ncurses
 S390_TOOLS_MAKE_OPTS += HAVE_NCURSES=1