diff mbox series

[1/1] package/gtest: fix host build

Message ID 20210801083641.2761809-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/gtest: fix host build | expand

Commit Message

Fabrice Fontaine Aug. 1, 2021, 8:36 a.m. UTC
Commit 9dfbbbb4105c47602da048c9bb9499fb8862e768 wrongly removed
dependency on host-python3 or host-python resulting in the following
build failure:

cp -rp /tmp/instance-2/output-1/build/host-gtest-1.11.0/googlemock/scripts/generator/cpp /tmp/instance-2/output-1/per-package/host-gtest/host/lib/python2.7/site-packages
cp: cannot create directory '/tmp/instance-2/output-1/per-package/host-gtest/host/lib/python2.7/site-packages': No such file or directory

Fixes:
 - http://autobuild.buildroot.org/results/a1d2e100a65d7c1c39c20bdd5bf687a804c94305

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/gtest/gtest.mk | 2 ++
 1 file changed, 2 insertions(+)

Comments

Thomas Petazzoni Aug. 1, 2021, 9:48 a.m. UTC | #1
On Sun,  1 Aug 2021 10:36:41 +0200
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> Commit 9dfbbbb4105c47602da048c9bb9499fb8862e768 wrongly removed
> dependency on host-python3 or host-python resulting in the following
> build failure:
> 
> cp -rp /tmp/instance-2/output-1/build/host-gtest-1.11.0/googlemock/scripts/generator/cpp /tmp/instance-2/output-1/per-package/host-gtest/host/lib/python2.7/site-packages
> cp: cannot create directory '/tmp/instance-2/output-1/per-package/host-gtest/host/lib/python2.7/site-packages': No such file or directory
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/a1d2e100a65d7c1c39c20bdd5bf687a804c94305
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/gtest/gtest.mk | 2 ++
>  1 file changed, 2 insertions(+)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/gtest/gtest.mk b/package/gtest/gtest.mk
index 474d127312..6447954e36 100644
--- a/package/gtest/gtest.mk
+++ b/package/gtest/gtest.mk
@@ -21,8 +21,10 @@  HOST_GTEST_LICENSE = Apache-2.0
 HOST_GTEST_LICENSE_FILES = googlemock/scripts/generator/LICENSE
 ifeq ($(BR2_PACKAGE_PYTHON3),y)
 HOST_GTEST_PYTHON_VERSION = $(PYTHON3_VERSION_MAJOR)
+HOST_GTEST_DEPENDENCIES += host-python3
 else
 HOST_GTEST_PYTHON_VERSION = $(PYTHON_VERSION_MAJOR)
+HOST_GTEST_DEPENDENCIES += host-python
 endif
 
 HOST_GTEST_GMOCK_PYTHONPATH = \