diff mbox series

[1/1] package/duma: fix build with gcc 11

Message ID 20210731213247.1747620-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/duma: fix build with gcc 11 | expand

Commit Message

Fabrice Fontaine July 31, 2021, 9:32 p.m. UTC
Fix the following build failure with gcc 11:

In file included from dumapp.cpp:39:
dumapp.h:88:49: error: ISO C++17 does not allow dynamic exception specifications
   88 |     void * DUMA_CDECL operator new(DUMA_SIZE_T) throw(std::bad_alloc);
      |                                                 ^~~~~

While at it, also drop DUMA_CPP which does not seem to be set since the
addition of the package back in 2013 in commit
bda69bf4e4b642ab199ffa13c7356709885f129d

Fixes:
 - http://autobuild.buildroot.org/results/ed838a55f09841a643b05e5a7a7ca0a9d2882acd

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/duma/duma.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Thomas Petazzoni July 31, 2021, 10:07 p.m. UTC | #1
On Sat, 31 Jul 2021 23:32:47 +0200
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> Fix the following build failure with gcc 11:
> 
> In file included from dumapp.cpp:39:
> dumapp.h:88:49: error: ISO C++17 does not allow dynamic exception specifications
>    88 |     void * DUMA_CDECL operator new(DUMA_SIZE_T) throw(std::bad_alloc);
>       |                                                 ^~~~~
> 
> While at it, also drop DUMA_CPP which does not seem to be set since the
> addition of the package back in 2013 in commit
> bda69bf4e4b642ab199ffa13c7356709885f129d
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/ed838a55f09841a643b05e5a7a7ca0a9d2882acd
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/duma/duma.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/duma/duma.mk b/package/duma/duma.mk
index 0e8a623bde..906db872d5 100644
--- a/package/duma/duma.mk
+++ b/package/duma/duma.mk
@@ -21,7 +21,7 @@  define DUMA_BUILD_CMDS
 	$(TARGET_MAKE_ENV) $(MAKE1) $(TARGET_CONFIGURE_OPTS) \
 		OS=linux \
 		DUMA_OPTIONS="$(DUMA_OPTIONS)" \
-		$(DUMA_CPP) -C $(@D)
+		CPPFLAGS="$(TARGET_CXXFLAGS) -std=c++11" -C $(@D)
 endef
 
 define DUMA_INSTALL_STAGING_CMDS