diff mbox series

[1/1] package/swupdate: needs dynamic libary

Message ID 20210731200327.1235994-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/swupdate: needs dynamic libary | expand

Commit Message

Fabrice Fontaine July 31, 2021, 8:03 p.m. UTC
dynamic library is needed since bump to version 2021.04 in commit
2c6b0359c3b819fadb4437b2d780e95c32fdab21 and
https://github.com/sbabic/swupdate/commit/f802cfa427686c5c90245ae08da36f4c7e31862f

Fixes:
 - http://autobuild.buildroot.org/results/e4b937c7421024bfcc4fbfa1a90f016134d3307f

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/swupdate/Config.in   | 5 +++--
 package/swupdate/swupdate.mk | 9 +--------
 2 files changed, 4 insertions(+), 10 deletions(-)

Comments

Thomas Petazzoni July 31, 2021, 10:07 p.m. UTC | #1
On Sat, 31 Jul 2021 22:03:27 +0200
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> dynamic library is needed since bump to version 2021.04 in commit
> 2c6b0359c3b819fadb4437b2d780e95c32fdab21 and
> https://github.com/sbabic/swupdate/commit/f802cfa427686c5c90245ae08da36f4c7e31862f
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/e4b937c7421024bfcc4fbfa1a90f016134d3307f
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/swupdate/Config.in   | 5 +++--
>  package/swupdate/swupdate.mk | 9 +--------
>  2 files changed, 4 insertions(+), 10 deletions(-)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/swupdate/Config.in b/package/swupdate/Config.in
index e87f695861..f601e45fcd 100644
--- a/package/swupdate/Config.in
+++ b/package/swupdate/Config.in
@@ -1,5 +1,6 @@ 
 config BR2_PACKAGE_SWUPDATE
 	bool "swupdate"
+	depends on !BR2_STATIC_LIBS
 	depends on BR2_TOOLCHAIN_HAS_THREADS
 	depends on BR2_USE_MMU # fork()
 	# swupdate requires a parser and uses libconfig as default
@@ -70,6 +71,6 @@  config BR2_PACKAGE_SWUPDATE_INSTALL_WEBSITE
 	  installed to /var/www/swupdate.
 endif
 
-comment "swupdate needs a toolchain w/ threads"
+comment "swupdate needs a toolchain w/ dynamic library, threads"
 	depends on BR2_USE_MMU
-	depends on !BR2_TOOLCHAIN_HAS_THREADS
+	depends on BR2_STATIC_LIBS || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/swupdate/swupdate.mk b/package/swupdate/swupdate.mk
index fe967d7fd7..402aa0a91f 100644
--- a/package/swupdate/swupdate.mk
+++ b/package/swupdate/swupdate.mk
@@ -93,7 +93,7 @@  else
 SWUPDATE_MAKE_ENV += HAVE_LIBWEBSOCKETS=n
 endif
 
-ifeq ($(BR2_PACKAGE_HAS_LUAINTERPRETER):$(BR2_STATIC_LIBS),y:)
+ifeq ($(BR2_PACKAGE_HAS_LUAINTERPRETER),y)
 SWUPDATE_DEPENDENCIES += luainterpreter host-pkgconf
 # defines the base name for the pkg-config file ("lua" or "luajit")
 define SWUPDATE_SET_LUA_VERSION
@@ -185,19 +185,12 @@  SWUPDATE_BUILD_CONFIG = $(@D)/.config
 SWUPDATE_KCONFIG_FILE = $(call qstrip,$(BR2_PACKAGE_SWUPDATE_CONFIG))
 SWUPDATE_KCONFIG_EDITORS = menuconfig xconfig gconfig nconfig
 
-ifeq ($(BR2_STATIC_LIBS),y)
-define SWUPDATE_PREFER_STATIC
-	$(call KCONFIG_ENABLE_OPT,CONFIG_STATIC)
-endef
-endif
-
 SWUPDATE_MAKE_OPTS = \
 	CROSS_COMPILE="$(TARGET_CROSS)" \
 	CONFIG_EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
 	CONFIG_EXTRA_LDFLAGS="$(TARGET_LDFLAGS)"
 
 define SWUPDATE_KCONFIG_FIXUP_CMDS
-	$(SWUPDATE_PREFER_STATIC)
 	$(SWUPDATE_SET_LUA_VERSION)
 endef