diff mbox series

package/libmbim: bump to version 1.26.0

Message ID 20210728074550.523-1-yegorslists@googlemail.com
State Accepted
Headers show
Series package/libmbim: bump to version 1.26.0 | expand

Commit Message

Voss, Samuel M Collins via buildroot July 28, 2021, 7:45 a.m. UTC
From: Yegor Yefremov <yegorslists@googlemail.com>

This release introduces meson build system support that fixes
gobject-intorspection issue with autotools.

As meson files are only available in git, switch the location to
https://gitlab.freedesktop.org.

Since 1.26.0 libgudev is not required anymore so drop this dependency.

Add support for bash-completion.

Fixes:
http://autobuild.buildroot.net/results/f8a81aad0e262a567a2b31712575472ae92e5518

Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
---
 package/libmbim/libmbim.hash |  2 +-
 package/libmbim/libmbim.mk   | 23 ++++++++++++++---------
 2 files changed, 15 insertions(+), 10 deletions(-)

Comments

Aleksander Morgado July 28, 2021, 10:21 a.m. UTC | #1
On Wed, Jul 28, 2021 at 9:45 AM <yegorslists@googlemail.com> wrote:
>
> From: Yegor Yefremov <yegorslists@googlemail.com>
>
> This release introduces meson build system support that fixes
> gobject-intorspection issue with autotools.
>
> As meson files are only available in git, switch the location to
> https://gitlab.freedesktop.org.
>
> Since 1.26.0 libgudev is not required anymore so drop this dependency.
>
> Add support for bash-completion.
>
> Fixes:
> http://autobuild.buildroot.net/results/f8a81aad0e262a567a2b31712575472ae92e5518
>
> Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>

Acked-by: Aleksander Morgado <aleksander@aleksander.es>

> ---
>  package/libmbim/libmbim.hash |  2 +-
>  package/libmbim/libmbim.mk   | 23 ++++++++++++++---------
>  2 files changed, 15 insertions(+), 10 deletions(-)
>
> diff --git a/package/libmbim/libmbim.hash b/package/libmbim/libmbim.hash
> index 2779be1e96..07cfd69163 100644
> --- a/package/libmbim/libmbim.hash
> +++ b/package/libmbim/libmbim.hash
> @@ -1,4 +1,4 @@
>  # Locally computed
> -sha256  02590736163fff10e5732191fccc1b9920969616ddc59613a003052a116a3c25  libmbim-1.24.8.tar.xz
> +sha256  63b53db0196dadea673f04524b0683ce40282f25bfd513d398e2a10b992cac01  libmbim-1.26.0.tar.gz
>  sha256  8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643  COPYING
>  sha256  dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551  COPYING.LIB
> diff --git a/package/libmbim/libmbim.mk b/package/libmbim/libmbim.mk
> index b343dec238..cdc3fabedb 100644
> --- a/package/libmbim/libmbim.mk
> +++ b/package/libmbim/libmbim.mk
> @@ -4,9 +4,8 @@
>  #
>  ################################################################################
>
> -LIBMBIM_VERSION = 1.24.8
> -LIBMBIM_SITE = https://www.freedesktop.org/software/libmbim
> -LIBMBIM_SOURCE = libmbim-$(LIBMBIM_VERSION).tar.xz
> +LIBMBIM_VERSION = 1.26.0
> +LIBMBIM_SITE = https://gitlab.freedesktop.org/mobile-broadband/libmbim/-/archive/$(LIBMBIM_VERSION)
>  LIBMBIM_LICENSE = LGPL-2.0+ (library), GPL-2.0+ (programs)
>  LIBMBIM_LICENSE_FILES = COPYING COPYING.LIB
>  LIBMBIM_CPE_ID_VENDOR = freedesktop
> @@ -14,12 +13,18 @@ LIBMBIM_INSTALL_STAGING = YES
>
>  LIBMBIM_DEPENDENCIES = libglib2
>
> -# if libgudev available, request udev support
> -ifeq ($(BR2_PACKAGE_LIBGUDEV),y)
> -LIBMBIM_DEPENDENCIES += libgudev
> -LIBMBIM_CONF_OPTS += --with-udev
> +ifeq ($(BR2_PACKAGE_GOBJECT_INTROSPECTION),y)
> +LIBMBIM_DEPENDENCIES += gobject-introspection
> +LIBMBIM_CONF_OPTS += -Dintrospection=true
>  else
> -LIBMBIM_CONF_OPTS += --without-udev
> +LIBMBIM_CONF_OPTS += -Dintrospection=false
>  endif
>
> -$(eval $(autotools-package))
> +ifeq ($(BR2_PACKAGE_BASH_COMPLETION),y)
> +LIBMBIM_DEPENDENCIES += bash-completion
> +LIBMBIM_CONF_OPTS += -Dbash_completion=true
> +else
> +LIBMBIM_CONF_OPTS += -Dbash_completion=false
> +endif
> +
> +$(eval $(meson-package))
> --
> 2.17.0
>
Thomas Petazzoni July 28, 2021, 7:13 p.m. UTC | #2
On Wed, 28 Jul 2021 09:45:50 +0200
yegorslists--- via buildroot <buildroot@busybox.net> wrote:

> From: Yegor Yefremov <yegorslists@googlemail.com>
> 
> This release introduces meson build system support that fixes
> gobject-intorspection issue with autotools.
> 
> As meson files are only available in git, switch the location to
> https://gitlab.freedesktop.org.
> 
> Since 1.26.0 libgudev is not required anymore so drop this dependency.
> 
> Add support for bash-completion.
> 
> Fixes:
> http://autobuild.buildroot.net/results/f8a81aad0e262a567a2b31712575472ae92e5518
> 
> Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
> ---
>  package/libmbim/libmbim.hash |  2 +-
>  package/libmbim/libmbim.mk   | 23 ++++++++++++++---------
>  2 files changed, 15 insertions(+), 10 deletions(-)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/libmbim/libmbim.hash b/package/libmbim/libmbim.hash
index 2779be1e96..07cfd69163 100644
--- a/package/libmbim/libmbim.hash
+++ b/package/libmbim/libmbim.hash
@@ -1,4 +1,4 @@ 
 # Locally computed
-sha256  02590736163fff10e5732191fccc1b9920969616ddc59613a003052a116a3c25  libmbim-1.24.8.tar.xz
+sha256  63b53db0196dadea673f04524b0683ce40282f25bfd513d398e2a10b992cac01  libmbim-1.26.0.tar.gz
 sha256  8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643  COPYING
 sha256  dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551  COPYING.LIB
diff --git a/package/libmbim/libmbim.mk b/package/libmbim/libmbim.mk
index b343dec238..cdc3fabedb 100644
--- a/package/libmbim/libmbim.mk
+++ b/package/libmbim/libmbim.mk
@@ -4,9 +4,8 @@ 
 #
 ################################################################################
 
-LIBMBIM_VERSION = 1.24.8
-LIBMBIM_SITE = https://www.freedesktop.org/software/libmbim
-LIBMBIM_SOURCE = libmbim-$(LIBMBIM_VERSION).tar.xz
+LIBMBIM_VERSION = 1.26.0
+LIBMBIM_SITE = https://gitlab.freedesktop.org/mobile-broadband/libmbim/-/archive/$(LIBMBIM_VERSION)
 LIBMBIM_LICENSE = LGPL-2.0+ (library), GPL-2.0+ (programs)
 LIBMBIM_LICENSE_FILES = COPYING COPYING.LIB
 LIBMBIM_CPE_ID_VENDOR = freedesktop
@@ -14,12 +13,18 @@  LIBMBIM_INSTALL_STAGING = YES
 
 LIBMBIM_DEPENDENCIES = libglib2
 
-# if libgudev available, request udev support
-ifeq ($(BR2_PACKAGE_LIBGUDEV),y)
-LIBMBIM_DEPENDENCIES += libgudev
-LIBMBIM_CONF_OPTS += --with-udev
+ifeq ($(BR2_PACKAGE_GOBJECT_INTROSPECTION),y)
+LIBMBIM_DEPENDENCIES += gobject-introspection
+LIBMBIM_CONF_OPTS += -Dintrospection=true
 else
-LIBMBIM_CONF_OPTS += --without-udev
+LIBMBIM_CONF_OPTS += -Dintrospection=false
 endif
 
-$(eval $(autotools-package))
+ifeq ($(BR2_PACKAGE_BASH_COMPLETION),y)
+LIBMBIM_DEPENDENCIES += bash-completion
+LIBMBIM_CONF_OPTS += -Dbash_completion=true
+else
+LIBMBIM_CONF_OPTS += -Dbash_completion=false
+endif
+
+$(eval $(meson-package))