diff mbox series

[1/1] package/htop: fix sources location

Message ID 20210724204801.1073334-1-daniil.stas@posteo.net
State Accepted
Headers show
Series [1/1] package/htop: fix sources location | expand

Commit Message

Daniil Stas July 24, 2021, 8:48 p.m. UTC
Change sources location from bintray to github since bintray doesn't
work anymore

Signed-off-by: Daniil Stas <daniil.stas@posteo.net>
---
Backport to: 2021.02.x, 2021.05.x
---
 package/htop/htop.hash | 2 +-
 package/htop/htop.mk   | 3 ++-
 2 files changed, 3 insertions(+), 2 deletions(-)

Comments

Yann E. MORIN July 24, 2021, 9:03 p.m. UTC | #1
Daniil, All,

On 2021-07-24 20:48 +0000, Daniil Stas spake thusly:
> Change sources location from bintray to github since bintray doesn't
> work anymore
> 
> Signed-off-by: Daniil Stas <daniil.stas@posteo.net>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
> Backport to: 2021.02.x, 2021.05.x
> ---
>  package/htop/htop.hash | 2 +-
>  package/htop/htop.mk   | 3 ++-
>  2 files changed, 3 insertions(+), 2 deletions(-)
> 
> diff --git a/package/htop/htop.hash b/package/htop/htop.hash
> index 647feabb8e..e9eb5daf4d 100644
> --- a/package/htop/htop.hash
> +++ b/package/htop/htop.hash
> @@ -1,3 +1,3 @@
>  # Locally calculated
> -sha256  19535f8f01ac08be2df880c93c9cedfc50fa92320d48e3ef92a30b6edc4d1917  htop-3.0.5.tar.gz
> +sha256  4c2629bd50895bd24082ba2f81f8c972348aa2298cc6edc6a21a7fa18b73990c  htop-3.0.5.tar.gz
>  sha256  c228cc14df980a23ea0c3c9ac957b904dd6a8514f6283db403de22e9179471be  COPYING
> diff --git a/package/htop/htop.mk b/package/htop/htop.mk
> index aa2ff24750..dd801b0dc0 100644
> --- a/package/htop/htop.mk
> +++ b/package/htop/htop.mk
> @@ -5,8 +5,9 @@
>  ################################################################################
>  
>  HTOP_VERSION = 3.0.5
> -HTOP_SITE = https://dl.bintray.com/htop/source
> +HTOP_SITE = $(call github,htop-dev,htop,$(HTOP_VERSION))
>  HTOP_DEPENDENCIES = ncurses
> +HTOP_AUTORECONF = YES
>  # Prevent htop build system from searching the host paths
>  HTOP_CONF_ENV = HTOP_NCURSES_CONFIG_SCRIPT=$(STAGING_DIR)/usr/bin/$(NCURSES_CONFIG_SCRIPTS)
>  HTOP_LICENSE = GPL-2.0
> -- 
> 2.32.0
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Baruch Siach July 25, 2021, 4:01 a.m. UTC | #2
Hi Yann, Daniil,

On Sun, Jul 25 2021, Yann E. MORIN wrote:

> Daniil, All,
>
> On 2021-07-24 20:48 +0000, Daniil Stas spake thusly:
>> Change sources location from bintray to github since bintray doesn't
>> work anymore
>> 
>> Signed-off-by: Daniil Stas <daniil.stas@posteo.net>
>
> Applied to master, thanks.

Wouldn't tar file hash change break the sources.buildroot.net cache?

baruch

>> ---
>> Backport to: 2021.02.x, 2021.05.x
>> ---
>>  package/htop/htop.hash | 2 +-
>>  package/htop/htop.mk   | 3 ++-
>>  2 files changed, 3 insertions(+), 2 deletions(-)
>> 
>> diff --git a/package/htop/htop.hash b/package/htop/htop.hash
>> index 647feabb8e..e9eb5daf4d 100644
>> --- a/package/htop/htop.hash
>> +++ b/package/htop/htop.hash
>> @@ -1,3 +1,3 @@
>>  # Locally calculated
>> -sha256  19535f8f01ac08be2df880c93c9cedfc50fa92320d48e3ef92a30b6edc4d1917  htop-3.0.5.tar.gz
>> +sha256  4c2629bd50895bd24082ba2f81f8c972348aa2298cc6edc6a21a7fa18b73990c  htop-3.0.5.tar.gz
>>  sha256  c228cc14df980a23ea0c3c9ac957b904dd6a8514f6283db403de22e9179471be  COPYING
>> diff --git a/package/htop/htop.mk b/package/htop/htop.mk
>> index aa2ff24750..dd801b0dc0 100644
>> --- a/package/htop/htop.mk
>> +++ b/package/htop/htop.mk
>> @@ -5,8 +5,9 @@
>>  ################################################################################
>>  
>>  HTOP_VERSION = 3.0.5
>> -HTOP_SITE = https://dl.bintray.com/htop/source
>> +HTOP_SITE = $(call github,htop-dev,htop,$(HTOP_VERSION))
>>  HTOP_DEPENDENCIES = ncurses
>> +HTOP_AUTORECONF = YES
>>  # Prevent htop build system from searching the host paths
>>  HTOP_CONF_ENV = HTOP_NCURSES_CONFIG_SCRIPT=$(STAGING_DIR)/usr/bin/$(NCURSES_CONFIG_SCRIPTS)
>>  HTOP_LICENSE = GPL-2.0
Yann E. MORIN July 25, 2021, 7:14 a.m. UTC | #3
Baruch, All,

On 2021-07-25 07:01 +0300, Baruch Siach spake thusly:
> On Sun, Jul 25 2021, Yann E. MORIN wrote:
> > Daniil, All,
> > On 2021-07-24 20:48 +0000, Daniil Stas spake thusly:
> >> Change sources location from bintray to github since bintray doesn't
> >> work anymore
> > Applied to master, thanks.
> Wouldn't tar file hash change break the sources.buildroot.net cache?

Damn, you're absolutely right! I've revert the change now.

Daniil, could you redo your patch, but rather than use the tag, use the
sha1 of the corresponding commit, and explain why we do so in a comment
and in the commit log?

Thanks!

Regards,
Yann E. MORIN.
diff mbox series

Patch

diff --git a/package/htop/htop.hash b/package/htop/htop.hash
index 647feabb8e..e9eb5daf4d 100644
--- a/package/htop/htop.hash
+++ b/package/htop/htop.hash
@@ -1,3 +1,3 @@ 
 # Locally calculated
-sha256  19535f8f01ac08be2df880c93c9cedfc50fa92320d48e3ef92a30b6edc4d1917  htop-3.0.5.tar.gz
+sha256  4c2629bd50895bd24082ba2f81f8c972348aa2298cc6edc6a21a7fa18b73990c  htop-3.0.5.tar.gz
 sha256  c228cc14df980a23ea0c3c9ac957b904dd6a8514f6283db403de22e9179471be  COPYING
diff --git a/package/htop/htop.mk b/package/htop/htop.mk
index aa2ff24750..dd801b0dc0 100644
--- a/package/htop/htop.mk
+++ b/package/htop/htop.mk
@@ -5,8 +5,9 @@ 
 ################################################################################
 
 HTOP_VERSION = 3.0.5
-HTOP_SITE = https://dl.bintray.com/htop/source
+HTOP_SITE = $(call github,htop-dev,htop,$(HTOP_VERSION))
 HTOP_DEPENDENCIES = ncurses
+HTOP_AUTORECONF = YES
 # Prevent htop build system from searching the host paths
 HTOP_CONF_ENV = HTOP_NCURSES_CONFIG_SCRIPT=$(STAGING_DIR)/usr/bin/$(NCURSES_CONFIG_SCRIPTS)
 HTOP_LICENSE = GPL-2.0