diff mbox series

[1/1] package/uboot-tools: concat files before passing to env image tool

Message ID 20210705121933.1055057-1-mirza.kapetanovic@gmail.com
State Accepted
Headers show
Series [1/1] package/uboot-tools: concat files before passing to env image tool | expand

Commit Message

Mirza Kapetanovic July 5, 2021, 12:19 p.m. UTC
Fix BR2_PACKAGE_HOST_UBOOT_TOOLS_ENVIMAGE_SOURCE so that files are actually concatenated
as described in the help text.

Signed-off-by: Mirza Kapetanovic <mirza.kapetanovic@gmail.com>
---
 package/uboot-tools/uboot-tools.mk | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

Comments

Voss, Samuel M Collins via buildroot July 6, 2021, 11:55 a.m. UTC | #1
Hi Mirza,


> From: Mirza Kapetanovic <mirza.kapetanovic@gmail.com>
> Sent: Monday, July 5, 2021 7:19 AM
> To: buildroot@buildroot.org <buildroot@buildroot.org>
> Cc: Weber, Matthew L Collins <Matthew.Weber@collins.com>; Mirza Kapetanovic <mirza.kapetanovic@gmail.com>
> Subject: [External] [PATCH 1/1] package/uboot-tools: concat files before passing to env image tool 

> Fix BR2_PACKAGE_HOST_UBOOT_TOOLS_ENVIMAGE_SOURCE so that files are actually concatenated
> as described in the help text.

Reviewed-by: Matthew Weber <matthew.weber@collins.com>
Thomas Petazzoni July 18, 2021, 5:52 p.m. UTC | #2
On Mon,  5 Jul 2021 14:19:33 +0200
Mirza Kapetanovic <mirza.kapetanovic@gmail.com> wrote:

> Fix BR2_PACKAGE_HOST_UBOOT_TOOLS_ENVIMAGE_SOURCE so that files are actually concatenated
> as described in the help text.
> 
> Signed-off-by: Mirza Kapetanovic <mirza.kapetanovic@gmail.com>
> ---
>  package/uboot-tools/uboot-tools.mk | 5 +++--
>  1 file changed, 3 insertions(+), 2 deletions(-)

Applied to master, thanks.

Thomas
Peter Korsgaard Aug. 4, 2021, 11:02 a.m. UTC | #3
>>>>> "Mirza" == Mirza Kapetanovic <mirza.kapetanovic@gmail.com> writes:

 > Fix BR2_PACKAGE_HOST_UBOOT_TOOLS_ENVIMAGE_SOURCE so that files are actually concatenated
 > as described in the help text.

 > Signed-off-by: Mirza Kapetanovic <mirza.kapetanovic@gmail.com>

Committed to 2021.02.x and 2021.05.x, thanks.
diff mbox series

Patch

diff --git a/package/uboot-tools/uboot-tools.mk b/package/uboot-tools/uboot-tools.mk
index 8963d6182e..4d1fc46e25 100644
--- a/package/uboot-tools/uboot-tools.mk
+++ b/package/uboot-tools/uboot-tools.mk
@@ -156,11 +156,12 @@  endif #BR_BUILDING
 
 define HOST_UBOOT_TOOLS_GENERATE_ENVIMAGE
 	$(HOST_UBOOT_TOOLS_GENERATE_ENV_DEFAULTS)
-	$(@D)/tools/mkenvimage -s $(BR2_PACKAGE_HOST_UBOOT_TOOLS_ENVIMAGE_SIZE) \
+	cat $(UBOOT_TOOLS_GENERATE_ENV_FILE) | \
+		$(@D)/tools/mkenvimage -s $(BR2_PACKAGE_HOST_UBOOT_TOOLS_ENVIMAGE_SIZE) \
 		$(if $(BR2_PACKAGE_HOST_UBOOT_TOOLS_ENVIMAGE_REDUNDANT),-r) \
 		$(if $(filter "BIG",$(BR2_ENDIAN)),-b) \
 		-o $(@D)/tools/uboot-env.bin \
-		$(UBOOT_TOOLS_GENERATE_ENV_FILE)
+		-
 endef
 define HOST_UBOOT_TOOLS_INSTALL_ENVIMAGE
 	$(INSTALL) -m 0755 -D $(@D)/tools/uboot-env.bin $(BINARIES_DIR)/uboot-env.bin