diff mbox series

[1/1] package/libsndfile: fix c99 check

Message ID 20210620180409.1167370-1-bernd.kuhls@t-online.de
State Accepted
Headers show
Series [1/1] package/libsndfile: fix c99 check | expand

Commit Message

Bernd Kuhls June 20, 2021, 6:04 p.m. UTC
The check for c99 contains "include <wchar.h>" although the package
itself does not use wchar functions outside Windows-specific code.
This patch forces the detection of c99 for toolchains lacking wchar.

Fixes:
http://autobuild.buildroot.net/results/62c/62c07e66491e2fcf32d3921f8286ec1293591194/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
 package/libsndfile/libsndfile.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Thomas Petazzoni July 18, 2021, 11:59 a.m. UTC | #1
Hello Bernd,

On Sun, 20 Jun 2021 20:04:09 +0200
Bernd Kuhls <bernd.kuhls@t-online.de> wrote:

> The check for c99 contains "include <wchar.h>" although the package
> itself does not use wchar functions outside Windows-specific code.
> This patch forces the detection of c99 for toolchains lacking wchar.
> 
> Fixes:
> http://autobuild.buildroot.net/results/62c/62c07e66491e2fcf32d3921f8286ec1293591194/
> 
> Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
> ---
>  package/libsndfile/libsndfile.mk | 1 +
>  1 file changed, 1 insertion(+)

Thanks for the research and fix. However the commit log for fixes like
this should always include some details about since when the problem is
occurring and why. Indeed, we want to easily understand if the problem
is applicable to our LTS branch.

In this case, I did the research: the problem didn't exist before the
bump of libsndfile to 1.0.31. Since the bump to libsndfile to 1.0.31
was done in June 2021, the LTS branch is not impacted.

I have amended the commit log with those details, but it would be good
to have such details in your future commit logs :-)

Thanks a lot!

Thomas
diff mbox series

Patch

diff --git a/package/libsndfile/libsndfile.mk b/package/libsndfile/libsndfile.mk
index 69530c98ed..c955b9d088 100644
--- a/package/libsndfile/libsndfile.mk
+++ b/package/libsndfile/libsndfile.mk
@@ -15,6 +15,7 @@  LIBSNDFILE_CPE_ID_VENDOR = libsndfile_project
 # disputed, https://github.com/erikd/libsndfile/issues/398
 LIBSNDFILE_IGNORE_CVES += CVE-2018-13419
 
+LIBSNDFILE_CONF_ENV = ac_cv_prog_cc_c99='-std=gnu99'
 LIBSNDFILE_CONF_OPTS = \
 	--disable-sqlite \
 	--disable-alsa \