diff mbox series

[1/1] package/tor: unset the NDEBUG flag

Message ID 20210620162030.1149816-1-bernd.kuhls@t-online.de
State Rejected
Headers show
Series [1/1] package/tor: unset the NDEBUG flag | expand

Commit Message

Bernd Kuhls June 20, 2021, 4:20 p.m. UTC
For details see:
https://gitlab.torproject.org/tpo/core/tor/-/blob/main/src/lib/log/util_bug.h#L56

Fixes:
http://autobuild.buildroot.net/results/aab/aabc7fd3093b1a7f08de8d06a1875eb5d231be4c/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
 package/tor/tor.mk | 3 +++
 1 file changed, 3 insertions(+)

Comments

Yann E. MORIN July 4, 2021, 7:55 p.m. UTC | #1
Bernd, All,

On 2021-06-20 18:20 +0200, Bernd Kuhls spake thusly:
> For details see:
> https://gitlab.torproject.org/tpo/core/tor/-/blob/main/src/lib/log/util_bug.h#L56
> 
> Fixes:
> http://autobuild.buildroot.net/results/aab/aabc7fd3093b1a7f08de8d06a1875eb5d231be4c/
> 
> Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>

We are now no longer setting NDEBUG in the infra; see a1c7cff1a081.

So this patch is no longer needed; I've marked it as rejected.

Thanks!

Regards,
Yann E. MORIN.

> ---
>  package/tor/tor.mk | 3 +++
>  1 file changed, 3 insertions(+)
> 
> diff --git a/package/tor/tor.mk b/package/tor/tor.mk
> index e0db278fb9..fca272f836 100644
> --- a/package/tor/tor.mk
> +++ b/package/tor/tor.mk
> @@ -62,6 +62,9 @@ endif
>  # uses gnu extensions
>  TOR_CONF_ENV = ac_cv_prog_cc_c99='-std=gnu99'
>  
> +# tor does not support building with NDEBUG enabled
> +TOR_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -UNDEBUG"
> +
>  ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
>  TOR_CONF_ENV += LIBS=-latomic
>  endif
> -- 
> 2.30.2
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/tor/tor.mk b/package/tor/tor.mk
index e0db278fb9..fca272f836 100644
--- a/package/tor/tor.mk
+++ b/package/tor/tor.mk
@@ -62,6 +62,9 @@  endif
 # uses gnu extensions
 TOR_CONF_ENV = ac_cv_prog_cc_c99='-std=gnu99'
 
+# tor does not support building with NDEBUG enabled
+TOR_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -UNDEBUG"
+
 ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
 TOR_CONF_ENV += LIBS=-latomic
 endif